Sign in with
Sign up | Sign in
Your question

I7 920 Only one thread - no hyper-threading - Please help

Last response: in CPUs
Share
August 28, 2011 9:52:54 AM

Hi all,

I have an Intel i7 920 on a Asus P6T Deluxe V2.

The problem is that I can only see one core and one thread.

It is supposed to have 4 cores each one having hyper-threading, kind of like eight virtual CPU's.

I have checked the BIOS has the correct settings to use all cores and hyper-threading is active ( I have even tried to turn it on and off again, but no luck).

I have also checked msconfig making sure the settings are correct (other forums pointed to msconfig), but still no luck.

Ultimatly I have tried installing Linux (Debian and Gentoo) and OpenSolaris, and all show the same result so I am pretty sure it is a hardware problem.

I have tried updating the BIOS for my motherboard, but no luck.

Is there anythong else I can do ?, please hepl, my next step is to buy a ney motherboard and/or CPU but is an expensive alternative I dont want to get to.

I think the thing that bugs me most is that it is the first time I have bought an Intel, before I have only had AMD systems.

At some point in the past I remember seeing eight virtual cpu's in the task manager, but since some time back, nothing. (I have tried a few windows versions apart from the others mentioned).

Thank you for your help.

Regards, Mark.
a b à CPUs
August 28, 2011 10:23:05 AM


The setting in MSConfig - Boot - Advanced Options - Numbers of Processors should be grayed out (unticked), just making sure that is what you have it set at?
Maybe try enabling it, reboot, then untick and reboot again, If that is how you have it set, though I guess you have already tried this.


a b à CPUs
August 28, 2011 10:31:05 AM

MSConfig - Boot - Advanced Options - Numbers of Processors, check the box(On top of Numbers of Processor or under/near it) and select 8... If it still shows 4 Thread, go into BIOS and reset the settings and/or reset CMOS...
Related resources
August 28, 2011 12:28:39 PM

Hi, Thanks for the answers. If I go in to msconfig - BOOT.INI - Advanced Options:

/NUMPROC is not checked.
If I do select it, It only allows me to select '1' (in a non editable dropdown combo). (can't enter nor 4 nor 8).

I will try to find boot.ini and manually set /NUMPROC=8 (or 4) and see what happens.

I even talked to the local hardware distributor and they said they had never seen this before. Just my luck :) 

Thanks for the help I will keep this posted.
August 28, 2011 12:44:10 PM

Well I have edited boot.ini (C:\Boot.ini) following this article:

http://support.microsoft.com/kb/289022

rebooted and still only get 1 core and one thread. It is pretty frustrating because the system is overall pretty slow (Its a i7 920 with 6 Gb of RAM, it should be fast).

I think I will try and buy a new motherboard when I get the cash. Or maybe start with a new CPU, bugger. I might just go for an AMD system to be sure.
!