Sign in with
Sign up | Sign in
Your question

Asrock 970 extreme 3 problem

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
May 17, 2012 3:20:41 PM

Hey guys, i've recently bought a new rig and now when it's assembled it won't give screen/beeps. I'll post specs and what i've already tried below.

Asrock 970 extreme3
AMD Fx 8210 8x3100ghz
Corsair 4GB 2x CMV4GX3M1A1333C9
AMD Radeon hd 7870 2gb
Ms-N750-VAL-CM 750W
Corsair ssd 60gb
Liteon i has 124b

This what i've tried
-Carefully read and performed the no post/screen/beeps sticky (nothing)
- swapped a confirmed working psu (nothing)
-swapped gpu for geforce 7200 trying to get signal through vga (nothing)
- swapped hdd with a working os on it/without os on it (nothing)
-reseated ram,cpu, hdd,gpu and psu, have not tried reseating the mobo yet.

The only things that work are the fans, the dvd drive can open up but closes as soon when its open. And my mouse gives the little red light beneath it.

I really dont know what to do anymore. Help would be very appreciated
a b V Motherboard
May 17, 2012 3:27:18 PM

The motherboard might need a BIOS update. Not all AM3+ motherboards have the BIOS support for FX CPUs when you first buy them if their BIOS isn't updated before shipping it to you. To update the BIOS, you'll need an older AM3 CPU (Athlon II, Sempron, Phenom II) to update it with. If that doesn't work, then the board is probably DOA.
m
0
l
a b V Motherboard
May 17, 2012 3:30:18 PM

Make sure you connected 8-pin cpu header if yes try without gpu
m
0
l
Related resources
May 17, 2012 3:30:27 PM

Is your board updated with latest BIOS? Can you try an older AMD cpu because there is a possibility that Mobo may be bad.
m
0
l
a b V Motherboard
May 17, 2012 3:34:27 PM

THE UNKNOWN said:
Make sure you connected 8-pin cpu header if yes try without gpu


If OP tries without the graphics card, then what is OP supposed to do? This system has no integrated graphics. Also, the terms "GPU" and "video/graphics card" are NOT synonymous.
m
0
l
a b V Motherboard
May 17, 2012 3:42:21 PM

blazorthon said:
If OP tries without the graphics card, then what is OP supposed to do? This system has no integrated graphics. Also, the terms "GPU" and "video/graphics card" are NOT synonymous.


Oh yes i not checked onboard graphics
m
0
l
Anonymous
a b V Motherboard
May 17, 2012 9:50:01 PM

I'll try to get my hands on an older AM3 CPU tomorrow and I'll report back when I have more info.

Also, everything's connected just like it should, hence I am confused why it doesn't show anything.
m
0
l
Anonymous
a b V Motherboard
May 18, 2012 5:02:26 PM

Turned out it were some bent pins on the processor,performed a bios update while i was at it, thanks for the help guys ! :-)
m
0
l
a b V Motherboard
May 18, 2012 5:06:55 PM

You're welcome.
m
0
l
July 10, 2012 9:23:49 AM

i have the same problem, but i know that the ram is not on the list for supported ram, but i figured it would still at least post, the ram, gpu, and psu work in another pc, cant test my 8120, but i did put an am3 cpu in it and the problem persists. what are the chances that it is just the ram?
m
0
l
a b V Motherboard
July 10, 2012 2:49:27 PM

c4pt1n54n0 said:
i have the same problem, but i know that the ram is not on the list for supported ram, but i figured it would still at least post, the ram, gpu, and psu work in another pc, cant test my 8120, but i did put an am3 cpu in it and the problem persists. what are the chances that it is just the ram?


You might need a BIOS update for your FX CPU. Some boards need a BIOS update for them. If that doesn't help or even let you do it, then your board could be dead. Check for bent pins like OP had.
m
0
l
!