Sign in with
Sign up | Sign in
Your question

NAS Failed, HDD ok, cant access my data

Last response: in Networking
Share
August 26, 2010 12:23:50 AM

Hello Community,

I have a 500GB Simpletech NAS that I have used for about 1.5 years. A couple of days ago the NAS box failed on me, the blue light does not turn on, only the yellow turns on.

I pulled the 3.5" 500GB HDD out of the NAS box, purchased a USB 3.5Inch HDD enclosure off eBay and hooked up the HDD to it. Then plugged it into a Windows 7, Windows XP and Ubuntu 9.1 (on vmware) machines.

On Windows 7 it says your device has been installed and ready to use, but nothing shows up under My Computer. Same with XP.

Ubuntu shows nothing either (apparently it is supposed to show up on the desktop).

Does anyone know how I can get access to my data? I am pretty confident that the HDD is fine, it sounds normal and doesnt get hot.

Thanks!
August 26, 2010 8:59:40 AM

Can you;
Right click my computer and click manage
Then go down to disk management
See if your harddrive appears on that list, if it does, then let me know, cause I'll tell you what to do next

Thx
m
0
l
August 26, 2010 4:37:02 PM

Thank you for your response.


Windows 7 disk management shows the drive as 128GB Not Initialized. on the right panel it has a black bar and below the black bar it says. 128.00GB and Unallocated. Thats incorrect, the drive is 500GB.

I also installed Ubuntu 10.4 last night on vmware and it does not pop on the screen as a drive. When I look in the disk utility it shows a drive with 138GB capacity which is wrong, the drive is 500GB

m
0
l
Related resources
August 26, 2010 4:40:39 PM

I called Simpletech (now purchased by Hitachi) tech support and warranty, they said since you are out of warranty by 3~4 days you are SOL.

The person knew very little about hard drives as I talked to him (and I am not that tech savvy) and he sounded clueless, just asked me many questions (like my address, phone number, email, age, blah blah) and then tried accusing me of mis-handling the drive "o, did you touch the ... when you open the drive?" and after the end he basically said since you are 4 days out of a 3 yr warranty then f/u (excuse my language here).

I asked him if there is anyone at Simpletech who knows what format this drive is, linux? ntfs? fat? and he said he asked around and no one knows the answer at Hitachi.

Let is be recorded in Tom's Hardware for everyone to know Hitachi SUCKS and Hitachi Warranty and Customer service is non-existence.
m
0
l
August 26, 2010 8:04:01 PM

Have you tried the drive in a machine directly? I had an external go on me and put it into my machine to verify the drive. I'd try that, sometimes 3rd party enclosures can be a bit wonky.
m
0
l
August 26, 2010 8:43:05 PM

I only have an older Desktop (8 years old) running Windows 2000. I put it in that machine with different jumper and cable setting (cable select, master and slave modes) and nothing shows up in My Computer.
m
0
l
August 26, 2010 9:13:38 PM

I think I know the problem. It's windows 2000. That's why it's only seeing 128GBs.

First are you running Windows 2000 w/ Service Pack 3?

If so you can configure the OS to see larger hard disks.

Click on Start >> Run and type regedit
Scroll to "HKEY_LOCAL_MACHINE / System / CurrentControlSet / Services / Atapi / Parameters / Create a new DWORD value named EnableBigLba and set its value to 1

Your motherboard may also need to enable LBA48 support. This can be changed in the BIOS if your motherboard supports it. IF it doesn't you may need to flash a new BIOS to the mobo if one is available.
m
0
l
August 26, 2010 10:45:15 PM

Thanks runningbot but I dont think you read my first post, I am testing this on Windows 7 with a USB enclosure and it doesnt show up. Then I tested it on Windows 7 host, running VMWARE with Ubuntu Linux 10.04 and still didnt show up in Ubuntu. Then I tested it on Windows XP, and nothing shows up. And lastely I put it on my old desktop running Windows 2000 as a secondary master and still nothing showed up.

In windows 2000nothing shows up. Its in Windows 7 and Ubuntu where I get the 128GB size showing.
m
0
l
August 27, 2010 4:42:14 AM

Ok so there are two things that come into factor

So you said that it said not initialized, that would mean that the dive is not formatted, or the ntfs partition is corrupt....

So I'm thinking

How many partitions did you have set up on the drive

Do you mind formatting the drive as a last resort

I'm thinking though that the ntfs partition is corrupt... Try a couple of things

I'm not sure if this will work
But boot up your windows 7 disk or your system repair disk

Go to something like repair disk
See if you have an option to select the physical 500GB drive, not sure if that will work but I think I came accross something like that

If that doesn't work see if you can find anything like (repair ntfs partition) (given that your drive was formatted to ntfs( if you have single files larger than 4Gb on the drive this is ntfs)

Let me know what happens but I'm at school ATM so at about 4:30 I can be at my pc and guide you properly

Thx
m
0
l
August 27, 2010 5:13:26 PM

Ok, the story in short format.

The hard drive was part of a NAS, the brand is Simpletech. It came preformatted, neither I or the CSR at Hitachi know what format it is in. It may be linux but Ubuntu didnt read it.

The drive is formatted and was working 100% fine and I am sure it still works 100% fine, the problem is the NAS Enclosure has burnt out and doesnt turn on anymore so I cant access my files.

No partition is corrupt, why would it be corrupt, the hard drive was 100% fine before the NAS burnt out.

I pulled the HDD out of the NAS enclosure and put it in a $15, 3.5" USB Enclosure from eBay and tried it with Windows 7, Windows XP, Windows 2000 and Ubuntu and absolutely nothing shows up in my computer which is frustrating.

I dont want to use disk format utility, I will lose my data.
m
0
l
August 29, 2010 2:02:38 AM

From my chair three things could be wrong.
1. The USB enclosure is faulty. If you can, put the physical HDD into a computer and see if that computer sees it. If it does it's may be the USB enclosure.

2. The drive may be dead. If you tried the above and the drive didn't show up try putting a different drive into the USB enclosure. If it works with a different drive things start to look grim.

3. The drive may be some mystery device. In which case you could buy the same or similar (brand, chip hardware) NAS enclosure and try the drive in there. If the drive still doesn't show up I'd weigh the cost of having the data restored against the regret of loosing it.
m
0
l
August 30, 2010 1:55:53 PM

Now mate look, when we give you suggestions, you need to follow them, we cant spend all day thinking of ideas that could fix YOUR problems.

It's no help when we give you suggestions
and you just throw them out the window... Your the one asking for help
so do what we say or there is no point....

Now I've told you this
Your partition could be corrupt
Now if there wasn't a corrupt partition, you wouldn't have this
problem in the first place

Now with my recommendation of above, when I said to go into disk management, your drive showed up, which emans there is nothing wrong with the enclosure, but more to do with the filesystem on your harddrive..
It appeared as (if i read correctly) the first 128GB as not initialsed and another 128GB is unallocated, where is all the other data dude... it is a 500GB.

So with what was said above... Not initialised means it has not been formatted to a filesystem, so its just raw data,,, nothing..... and unallocated is just space that is not allocated to a specific drive letter or partition... so when you have a whole drive that says unallocated, you just need to create a new partition.

Do you get where im coming from... these are all signs of the corruption of the file system....

Try some file recovery programs that can run a deep scan on your harddrive and (given that you have a big enough internal harddrive) will allows you to restore to your other harddrive..
I know its a hassle to go through this *** but you have to.

Anyway.... i hope this helps... and please do follow my recommendations because if you dont, you wont get anywhere.

oh and try one other thing... where your drive is in disk management, right click and assign drive letter, and set like E" or F: ( this seems liek a pretty obvious thing to do, but it may work)

Thanks dude and please keep me posted.
m
0
l
February 16, 2011 2:52:07 AM

I have a SimpleShare 500gb device that worked fine with WinXP. I can't get it to work with Win7. I read some of their KB articles and see that it's running on a Linux platform. That's why Win7 can't recognize the drive.

Sounds like you're out of luck unless you know something about Linux.
m
0
l
December 26, 2011 11:22:19 PM

Lots of SimpleShare info here:
http://www.suphammer.net/forum

Read through the forum. Some people have had success retrieving data.

The File System used is RiserFS which apparently works under Linux.

From Gento Wiki:
http://en.gentoo-wiki.com/wiki/Reiser4
Reiser4 is the latest version of the Reiser File System. Reiser4 is a filesystem type that was under development by Namesys. It is presently being maintained by former Namesys developers.

An excerpt from Wired Mag:
"ReiserFS, is a file system unlike any other. Rather than assign data a fixed location on a hard drive, it uses algorithms to frequently reposition information, including the code that makes up the file system itself. It elegantly maximizes storage space, but it can also complicate data recovery when a computer crashes. If the algorithms are corrupted, the file system will be unable to locate its own position. All the data it organizes disappears into an indistinguishable mass of 0s and 1s. The contents of that hard drive will be irretrievably lost. "
m
0
l
!