P8P67 Deluxe - DRAM_LED solid red.

Hello!
I built my computer today with the motherboard ASUS P8P67 Deluxe.
The problem is, when i boot up the computer the DRAM_LED is solid red. I've checked the RAM-sticks and changed their place but nothing happens. The motherboard has a little display which says "55" that means "No memory inserted".

This happens to both my RAM-sticks. Do you guys think my RAM is faulty?
What can i do to fix this? I've reset the CMOS and checked all the cables.
5 answers Last reply
More about p8p67 deluxe dram_led solid
  1. Is the memory speed same for both?
  2. What exact sort of RAM is this?

    Before you say it... My guess is not Kingston, not Crucial, probably Corsair maybe the XMS model line.

    Anyway, have you tried RAM 1 stick at a time? What about in different slots?
  3. Have you tried the "MemOK!" button???
  4. Corsair. Did I call it or what?

    Did you do what I asked? Trying 1 stick at a time in different slots and such?
Ask a new question

Read More

Asus DRAM RAM LED Monitor Motherboards Computer