Solved

HD5770 FLICKERING ISSUES CRYSIS 2

Hi all i have been having an ongoing problem with my video cards flickering during game play! For some strange reason when in game if settings are changed from full screen to windowed the problem improves 100% All GPU temps are normal at idle and stress. Ive just installed Crysis 2 and it seems to be running smooth but the flickering is really bad!! Ive tried adjusting all the settings including V-sync and don't no what else to do!!!
Any suggestions would be greatly appreciated!
CHEERS

SPECS
i5 750 @3.2ghz
4gb ram 1333mhz
2xHD5770 crossfire
res 1920x1080
10 answers Last reply Best Answer
More about hd5770 flickering issues crysis
  1. Its a crossfire issue which all amd users are facing.wait for amd to release new drivers to fix the issue as its a Nvidia biased game
  2. celpas said:
    Its a crossfire issue which all amd users are facing.wait for amd to release new drivers to fix the issue as its a Nvidia biased game



    Which it explains why it clears up when i use windowed mode! Because crossfire is disabled
    ! Im pretty sure heaps of other people have this problem! You would think that amd would have a fix for this!
  3. amd will have a fix for it eventually. The game just came out 2 days ago.
  4. Best answer
    Yeah I've been experiencing this issue since I bought the game. Disabling crossfire definitely does fix it, but at the cost of performance. I also have 2x 5770's with no O/C. Its less of a performance hit to disable crossfire then it is to run in windowed mode in most cases.

    I've been searching for a fix for several days now. This issue is also happening on some Nvidia configurations from what I've seen. Something to do with dual GPU handling on the bloom effects for lighting.

    I've heard of a couple people fixing it with the following workaround and allowing crossfire to remain enabled.

    1.) Downloading the latest ATI catalyst Application profiles from the ATI website:
    11.2 CAP4 - Should be on the page provided below.
    http://sites.amd.com/us/game/downloads/Pages/radeon_win7-64.aspx

    2.) Installing the profiles and reboot the computer.

    3.) Go to the installed game directory, and rename the EXE file.
    - Rename "Crysis2" to "rift"

    4.) Try relaunching the game and see if the flickering is gone.

    This tricks the game to run the profile for the game rift, which apparently resolves the flickering issue. I can't do this myself because I have the steam release, and so changing the EXE that is bound to the steam login effectively stops the game from launching for me. But this might work with a retail copy that is not tied to a steam account.

    I've heard that renaming to the crysis2.exe "shift2" or "bioshock" may also resolve the issue as it will try and utilize these other profiles which have multiple instances of working for other users.

    Hopefully this alleviates the issue for some of you until a proper fix can be made.

    Performance is excellent, but all lighting effects cause a flickering issue which makes the game unplayable.

    SPECS
    AMD x6 @3.4ghz
    4gb ram 1600mhz
    2xHD5770 crossfire
    res 1920x1080
  5. In any case the game looks the same at all 3 levels so might as choose high and get more fps.in crysis warhead the difference between medium an high was so huge that it actually made me tolerate low frames.In this case all 3 levels look same so I can't justify low frames on extreme
  6. Best answer selected by heeems74.
  7. Has anyone tried tweaking the graphics settings using the console commands?

    http://www.pcgamer.com/2011/03/22/use-console-commands-to-enable-hidden-graphic-settings-options-in-crysis-2/
  8. Crossfire gets disabled when running in windowed mode hence why it fixes if you forcefully disable crossfire or go into windowed mode.

    I might be new here but its handy to tell people how things actually work and research it rather then guess.

    But just so everyone understands Crossfire only works in full screen so if you do indeed run in windowed mode you loose the crossfire performance anyway.

    If you don't believe me google it or go read it from ATI/AMD directly like I just did.
  9. Setting the brightness to 50 and selecting the bioshock profile on Radeon Pro worked for me.
    My spects:
    i3 530
    M.B. asrock extreme
    2x Ati 5770 crossfire
    6 Gb DDR3

    I hope it helps
  10. Ishkrish said:
    Yeah I've been experiencing this issue since I bought the game. Disabling crossfire definitely does fix it, but at the cost of performance. I also have 2x 5770's with no O/C. Its less of a performance hit to disable crossfire then it is to run in windowed mode in most cases.

    I've been searching for a fix for several days now. This issue is also happening on some Nvidia configurations from what I've seen. Something to do with dual GPU handling on the bloom effects for lighting.

    I've heard of a couple people fixing it with the following workaround and allowing crossfire to remain enabled.

    1.) Downloading the latest ATI catalyst Application profiles from the ATI website:
    11.2 CAP4 - Should be on the page provided below.
    http://sites.amd.com/us/game/downloads/Pages/radeon_win7-64.aspx

    2.) Installing the profiles and reboot the computer.

    3.) Go to the installed game directory, and rename the EXE file.
    - Rename "Crysis2" to "rift"

    4.) Try relaunching the game and see if the flickering is gone.

    This tricks the game to run the profile for the game rift, which apparently resolves the flickering issue. I can't do this myself because I have the steam release, and so changing the EXE that is bound to the steam login effectively stops the game from launching for me. But this might work with a retail copy that is not tied to a steam account.

    I've heard that renaming to the crysis2.exe "shift2" or "bioshock" may also resolve the issue as it will try and utilize these other profiles which have multiple instances of working for other users.

    Hopefully this alleviates the issue for some of you until a proper fix can be made.

    Performance is excellent, but all lighting effects cause a flickering issue which makes the game unplayable.

    SPECS
    AMD x6 @3.4ghz
    4gb ram 1600mhz
    2xHD5770 crossfire
    res 1920x1080



    "I just did the Above solution and fixed the Problem. I have no more flickering and i feel like my head is not going to explode any more thanks for the Info mate"
Ask a new question

Read More

Graphics Cards Games Crysis Graphics