Closed Solved

Asus Rampage IV Formula Bios reset

20th May, 2012.

Hello Gents,

well here it goes, I recently built a new system based on x79 chipset :) – it boots perfectly very responsive and lightning speed :o but the problem is this:
once I make any changes in the bios let's say lil overclocking, voltage tweaking, Dram timings…etc. it will boot again with the same settings I entered BUT (BUT) once I turn off the system (Unplug) the power cable from the socket ALL settings and I MEAN all settings including the clock, date, bios setting resets to factory default??!! :cry: Even the clock shows date as 2005??!! :cry:
Please help meeeee???


System Specs:
CPU: i7-3820
MOBO: Asus Rampage IV Formula
Ram: Corsair 16gb 1600mhz
SSD: ocz 128
GPU: GTX 680
5 answers Last reply Best Answer
More about asus rampage formula bios reset
  1. Best answer
    That sounds like one of two problems:

    1) defective or missing battery
    (the battery on the motherboard is for remembering your BIOS changes)

    2) the CMOS reset pin has the jumper on it
    (some motherboards have two pins which you then jumper together with the computer off to reset the BIOS to default)

    My guess is the battery.

    a) check the voltage, or
    b) buy another battery, or
    c) borrow another battery (you'd have to redo the BIOS settings if you take it out of another computer)
  2. hi photonboy,

    I really was thinking about the battery few minutes ago (what the odds??) I have couple of batteries laying around I will change them if it works someone is getting a best answer :)
  3. Best answer selected by axtenar.
  4. update: I changed the battery with new one and it worked like a charm!!! I am running i7-3820 4.65mhz 24/7 on water!!!

    thanks for the help photonboy.
  5. This topic has been closed by Nikorr
Ask a new question

Read More

Motherboards BIOS