Sign in with
Sign up | Sign in
Your question

Installed memory (RAM): 8.00 GB (4.00 GB usable)

Last response: in Memory
Share
May 20, 2012 7:00:30 PM

SOLVED

So, I just built my first computer and it is, at least, working. I read the FAQ, which was informative, but I didn't see my specific issue. I read through a few pages of threads to make sure this hasn't been asked too recently, and I both apologize and give thanks if it has been answered previously.

I am stuck on this single-channel memory mode problem. Windows and UEFI BIOS recognize both DIMMS; however, the BIOS says Single-Channel memory mode, specifically:

total memory: 8192MB
Single-Channel memory mode
DDR3A1: 4096MB (DDR3-1333)
DDR3A2:
DDR3B1: 4096MB (DDR3-1333)
DDR3B2:

Whereas Windows 7 says:
Installed memory (RAM): 8.00 GB (4.00 GB usable)

Below I will include other system details, as they may or may not be relevant.

Mobo: ASRock 970 extreme3 (UEFI Version 970 extreme3 P1.40 [up to date])
CPU: AMD Phenom ii 965 BE
RAM: 2x G.Skill Ripjaws 4GB DDR3-1333
GPU: Geforce gtx 550 ti
PSU: 500W Cooler Master
OS: Windows 7 Home Premium 64bit

Many thanks!


Edit: I did contact ASRock, as well as G.Skill by phone; however, they both did no more than refer me to the other :pfff: 

Edit: I will update attempted fixes so far here, to save complete reading of the thread.

-Updated the BIOS to the most recent version

-Reinstalled RAM on A2 and B2, and on A1 and B1

-Checked, and unchecked msconfig/boot/advanced/max memory

-Cleared CMOS and restored BIOS to default

-Forced the CPU fan clamp shut, as recommended by my friend. (Initially I was uncomfortable with the amount of force necessary, as this is my first build; however, after reading about it on here, I felt more comfortable with it).

-Banged head on table

-Reinstalled DIMMS from A1/B1 back to A2/B2

-Swapped RAM sticks' places, i.e. A2 to B2 and B2 to A2

-Booted with each stick separately, one stick was fine, the other failed to boot each time. This was done using the DDR3_A1 slot for both, as to eliminate the possibility of a faulty DIMM slot as the cause. This was repeated several times with the same result each time.

-Mailed back bad RAM stick and submitted necessary RMA paperwork through G.Skill directly (newegg can not accept 1 of the 2 DIMMS, but the manufacturer can).

-SOLVED: New stick arrived, and upon installation, solved the problem.
a b } Memory
May 20, 2012 7:14:51 PM

There is a setting in Windows that controls this.

I don't remember how to get there at this moment, but you can set a max memory usable by windows to a lower than the maximum amount this way.

It is possible somehow that number got set to 4.

You may want to look into that. I will look around too and see if I can remember how it is done.

- Edit - I did find it. Hit start, type in MSCONFIG then go to the boot tab and hit advanced options. In there is the maximum memory thing.
m
0
l
May 20, 2012 7:32:27 PM

Raiddinn said:
There is a setting in Windows that controls this...

...Hit start, type in MSCONFIG then go to the boot tab and hit advanced options. In there is the maximum memory thing.


I tried this. when I click maximum memory, it shows 8192MB, then I click apply. It prompts me to restart to have the changes take place. I restart, and then I see this when I check the settings again.

Edit: hang on this picture isnt viewable, let me try to get a better one.

Here

m
0
l
Related resources
May 20, 2012 9:50:07 PM

After reading this post, I have additional information.

http://www.tomshardware.com/forum/306527-28-heatsink-in...

I had the same problem, i felt I was applying too much pressure. I got the latches on, but I did not pull the black lever arm up, because it was so firmly in place, I felt it would break if I did. Should I have forced it, and if I didn't, could that somehow be disabling my dual-channel functionality?
m
0
l
a b } Memory
May 21, 2012 2:38:38 AM

Nothing in my experience would lead me to believe that the mounting of your CPU fan would have anything to do with having 4 GBs of RAM not be recognized in Windows.

Dual channel is really pretty meaningless. All dual channel really means is that your two sticks worth like 2% better through some magical process than they work "independently" (in single channel mode). Breaking dual channel mode is a pretty big yawn fest.

I would be worried about why dual channel mode wasn't working, but the lack of dual channel would really have nothing to do with how much RAM is or isn't recognized in Windows.

The lack of dual channel would tell me that I was or wasn't supposed to put RAM in, say, slots 1 and 3 rather than slots 1 and 2. Regardless of which type of board you get one of those will almost always be a dual channel capable setup and the other will almost never be on the same motherboard.

It is weird, though, that you try to change the memory amount and it tells you to take a long walk off a short cliff.

Have you tried using any other values than 8 and 4 in that box? Like 5, for instance?

Also, would you mind telling me which video card(s) you have?

Also, what are the makers and model types of each of those RAM sticks?
m
0
l
May 21, 2012 4:15:36 AM

Raiddinn said:
Nothing in my experience would lead me to believe that the mounting of your CPU fan would have anything to do with having 4 GBs of RAM not be recognized in Windows.

Dual channel is really pretty meaningless. All dual channel really means is that your two sticks worth like 2% better through some magical process than they work "independently" (in single channel mode). Breaking dual channel mode is a pretty big yawn fest.

I would be worried about why dual channel mode wasn't working, but the lack of dual channel would really have nothing to do with how much RAM is or isn't recognized in Windows.

The lack of dual channel would tell me that I was or wasn't supposed to put RAM in, say, slots 1 and 3 rather than slots 1 and 2. Regardless of which type of board you get one of those will almost always be a dual channel capable setup and the other will almost never be on the same motherboard.

It is weird, though, that you try to change the memory amount and it tells you to take a long walk off a short cliff.

Have you tried using any other values than 8 and 4 in that box? Like 5, for instance?

Also, would you mind telling me which video card(s) you have?

Also, what are the makers and model types of each of those RAM sticks?


Yeah, I posted that they are G.Skill RAM, though I neglected to mention they are the Ripjaws series. I bought them as a pair.
The GPU is a Geforce gtx 550 ti
Thanks Raiddinn
m
0
l
a c 84 } Memory
May 21, 2012 4:45:57 AM

first off if you want two channel ram speed you have to have the dimms in a0 and a1 or b0 and b1. the other issue is normal for windows 7. is using some of the 4g ram as a ram drive. that ram drive gets larger the more items are running at start up.
ie jave updates..itunes helper.....office..your printer driver or cam software....the more icons that pop up on the tool bar at start up the more ram windows needs to run them.
m
0
l
a c 146 } Memory
May 21, 2012 5:04:00 AM

Un-check the Maximum Memory box in msconfig | Boot | Advanced Options!

m
0
l
May 21, 2012 5:04:30 AM

smorizio said:
first off if you want two channel ram speed you have to have the dimms in a0 and a1 or b0 and b1. the other issue is normal for windows 7. is using some of the 4g ram as a ram drive. that ram drive gets larger the more items are running at start up.
ie jave updates..itunes helper.....office..your printer driver or cam software....the more icons that pop up on the tool bar at start up the more ram windows needs to run them.



http://www.manualowl.com/m/ASRock/970-Extreme3/Manual/2...

Here is the manual for the mobo. On page 14, it clearly shows that I installed the RAM correctly. I will note that I did initially install the RAM on A2 and B2, per the instructions. ASRock tech support recommended I switch it to A1 and B1, and was puzzled as to why the manual said A2 B2. The problem is the same on both configurations.
m
0
l
a c 146 } Memory
May 21, 2012 5:06:02 AM

Also, try enabling Memory Remaping in BIOS, or something like this,

if you manage to find it in your BIOS SETUP.
m
0
l
May 21, 2012 5:11:09 AM

nikorr said:
Un-check the Maximum Memory box in msconfig | Boot | Advanced Options!

http://www.vistax64.com/attachments/general-discussion/16252-stupid-ram-problem-memory.jpg


I tried this, and this is how I have it currently set. I am still only able to use 4GB.
Thanks for the reply. I don't think I meet the recommendations of the CMOS reboot, although I may resort to that. I am calling AMD tomorrow to see if they can help at all. We shall see, but I'm not holding my breath. Thanks for the reply.
m
0
l
a c 146 } Memory
May 21, 2012 5:21:21 AM

Straften said:
I tried this, and this is how I have it currently set. I am still only able to use 4GB.
Thanks for the reply. I don't think I meet the recommendations of the CMOS reboot, although I may resort to that. I am calling AMD tomorrow to see if they can help at all. We shall see, but I'm not holding my breath. Thanks for the reply.

I just that your screenshot is checked. Should be unchecked.
m
0
l
May 21, 2012 5:53:23 AM

nikorr said:
Also, try enabling Memory Remaping in BIOS, or something like this,

if you manage to find it in your BIOS SETUP.


Ok, I went looking for this and was unable to find it; however, I found the option about unganged mode. Changing that caused boot failure, so I had to clear CMOS anyway! lol
While i had the case open and the power off, I "Hulked out" on the CPU fan clamp to make it lock into place more firmly - just in case.

So just to recap:

Un-checked the Maximum Memory box in msconfig/boot/advanced
Cleared CMOS per the instructions in your video link, after checking with my manual
Forced clamp down on CPU fan, to secure it even more
Have successfully booted, and am posting from problem machine
Still have the posted issue


Thanks again to all who can help. I will say, if I figure it out through a different channel, I will make sure to post the solution here! I'm going back into BIOS to poke around, if I break it, I can clear CMOS again and will reply from another device if necessary.
m
0
l
a c 146 } Memory
May 21, 2012 6:02:05 AM

Also, do u have the latest BIOS?

That would be 1 reason to perform the update.
m
0
l
May 21, 2012 6:06:08 AM

nikorr said:
Also, do u have the latest BIOS?

That would be 1 reason to perform the update.


Yes sir, I have the most recent version of the BIOS. Should I try installing the RAM on A1 and A2, even though it says to install on A1 and B1, or A2 and B2?
m
0
l
a c 146 } Memory
May 21, 2012 6:07:33 AM

Try to reseat the RAM, move it around, it works in many cases like this.
m
0
l
a c 146 } Memory
May 21, 2012 6:16:31 AM

Install the memory module into the slots DDR3_A2 and DDR3_B2 for the first priority.
m
0
l
May 21, 2012 6:16:52 AM

nikorr said:
Try to reseat the RAM, move it around, it works in many cases like this.


What do you mean, can you go into a little more detail please? Do you mean, wiggle it around? Just reinstall it a fourth time? Or switch the slots?

BIOS/Windows are recognizing that both are installed, but will only use 4GB for some reason. I'm game to try anything at this point. I need to get this figured out soon, or I will take advantage of that 30day warranty!
m
0
l
May 21, 2012 6:18:42 AM

nikorr said:
Install the memory module into the slots DDR3_A2 and DDR3_B2 for the first priority.


I had it this way when I first installed. It came to reside in DDR3_A1 and B1 as a result of trying to fix this. Ah well, may as well move them back.
m
0
l
a c 146 } Memory
May 21, 2012 6:28:54 AM

I meant swap the RAM places.
m
0
l
May 21, 2012 6:56:09 AM

nikorr said:
I meant swap the RAM places.


Just did this. Still not using all 8
m
0
l
a b } Memory
May 21, 2012 1:26:16 PM

The way I see it...

AI + B1 vs A2 + B2 vs A1 + A2 vs B1 + B2 isn't going to affect the problem that Windows sees all 8 GBs but is only using 4 GBs of it.

Neither stick is bad and none of the ports on the motherboard are bad.

The RAM sounds like it is pushed all the way down in the slots just fine.

The CPU fan clamp even un-hulked-out-on has/had nothing to do with it.

It sounds to me like a clearly Windows oriented problem.

I managed to bring you to the right area where RAM would be limited in Windows and apparently when you change the setting nothing actually changes in the computer.

At this point, if I was sitting in the OPs chair, I would reinstall Windows. Not repair it I mean blow away everything and start from scratch.
m
0
l
May 21, 2012 5:36:05 PM

Raiddinn said:
The way I see it...

AI + B1 vs A2 + B2 vs A1 + A2 vs B1 + B2 isn't going to affect the problem that Windows sees all 8 GBs but is only using 4 GBs of it.

Neither stick is bad and none of the ports on the motherboard are bad.

The RAM sounds like it is pushed all the way down in the slots just fine.

The CPU fan clamp even un-hulked-out-on has/had nothing to do with it.

It sounds to me like a clearly Windows oriented problem.

I managed to bring you to the right area where RAM would be limited in Windows and apparently when you change the setting nothing actually changes in the computer.

At this point, if I was sitting in the OPs chair, I would reinstall Windows. Not repair it I mean blow away everything and start from scratch.


I would agree with you if the BIOS didn't say

total memory: 8192MB
Single-Channel memory mode
DDR3A1: 4096MB (DDR3-1333)
DDR3A2:
DDR3B1: 4096MB (DDR3-1333)
DDR3B2:

It should be in dual channel mode. These are matching sticks bought in a pair, with all new parts; not, some mismatched Frankenstein machine. I'm worried there is a hardware problem with the mobo at this point. It is worth reinstalling windows just in case, before I start the return process, god knows I don't want to do that.

Edit: Windows can't affect BIOS, right?
m
0
l
a b } Memory
May 21, 2012 6:19:59 PM

Windows would not be able to affect the BIOS, that is right.

Windows is located on the hard drive, the BIOS is located on the motherboard itself.

As I mentioned before, the single channel mode thing doesn't affect the maximum capacity of RAM. All it affects is efficiency of RAM usage.

My computer has 8 GBs of RAM in it and it is in dual channel mode. The motherboard said to put the sticks in slots A1 and B1 and that's what I did. Windows lists my RAM as 8 GBs with 7.9 GBs usable.

Even if I moved my RAM to A1 and B2, breaking dual channel mode it would still say 8 GBs with 7.9 GBs usable. My computer would just run 2% slower or whatever.

I don't know why your sticks wouldn't be in dual channel, but it really sounds like it has nothing to do with the amount of RAM recognized by Windows.

Windows clearly sees the whole 8 GB is present, it just doesn't opt to use 4 GBs of it for whatever reason I don't know.

In any event, I would strongly encourage you to reinstall windows before you start RMAing things.
m
0
l
May 21, 2012 7:01:03 PM

Raiddinn said:
Windows would not be able to affect the BIOS, that is right.

Windows is located on the hard drive, the BIOS is located on the motherboard itself.

As I mentioned before, the single channel mode thing doesn't affect the maximum capacity of RAM. All it affects is efficiency of RAM usage.

My computer has 8 GBs of RAM in it and it is in dual channel mode. The motherboard said to put the sticks in slots A1 and B1 and that's what I did. Windows lists my RAM as 8 GBs with 7.9 GBs usable.

Even if I moved my RAM to A1 and B2, breaking dual channel mode it would still say 8 GBs with 7.9 GBs usable. My computer would just run 2% slower or whatever.

I don't know why your sticks wouldn't be in dual channel, but it really sounds like it has nothing to do with the amount of RAM recognized by Windows.

Windows clearly sees the whole 8 GB is present, it just doesn't opt to use 4 GBs of it for whatever reason I don't know.

In any event, I would strongly encourage you to reinstall windows before you start RMAing things.



After calling Microsoft, and being refered to ASRock, we tried something I should have thought of myself. I booted with 1 stick of RAM in A1: Successful boot. Switched to the other stick of ram in A1: boot failure. After repeating this a few times to be sure, can we safely assume that I received a bad RAM stick?
m
0
l
a c 146 } Memory
May 22, 2012 1:20:47 AM

Can u try to boot in the safe mode?
m
0
l
May 22, 2012 1:54:18 AM

nikorr said:
Can u try to boot in the safe mode?


it wont boot at all with the bad ram stick. I'll just start the RMA process. I'll update this thread if replacing the stick works!
m
0
l
a c 146 } Memory
May 22, 2012 2:07:35 AM

Hopefully new RAM will fix it. That's the last check : )

Than it would be the mobo or the PSU.
m
0
l
a b } Memory
May 22, 2012 12:24:16 PM

That is weird. I think it must be the first time I have heard of Windows refusing to use a stick of RAM because Windows thinks the RAM is bad.

Good catch on their part.
m
0
l
June 5, 2012 7:41:37 PM

New RAM stick arrived, and I booted with it to make sure it was good. Once that worked, I put in the other good stick (with the machine off obviously,) and just like that BIOS recognized dual channel mode. Windows recognizes, and is using 8GB. I am happy :D 

So, in conclusion, if you have a computer in which

windows sees 8BG, but says only 4 are usable,
and,
the BIOS will not go into Dual-Channel mode with DIMMS installed,

chances are you have a bad DIMM! I suppose it would be the same for SIMM, but lets not go there on assumptions. Good luck and thanks everyone!
m
0
l
June 11, 2012 10:03:32 AM

My case solved:
Fujitsu LH520
Installed RAM:
KINGMAX DDR3-1066 2GB
SAMSUNG DDR3-1066 2GB
=> BIOS see them, Windows see them
=> Dual channel, with CPU-Z
=> installed 4GB, 2050MB "hardware reserved"

Installed RAM:
SAMSUNG DDR3-1066 2GB
=> installed 2GB, 2MB "hardware reserved"

Installed RAM:
KINGMAX DDR3-1066 2GB
=> CANNOT BOOT !!!

Installed RAM:
SAMSUNG DDR3-1333 2GB
=> installed 2GB, 2MB hardware reserved

Installed RAM:
SAMSUNG DDR3-1333 2GB
SAMSUNG DDR3-1066 2GB
=> installed 4GB, 2MB hardware reserved
Available: 2975MB
Cached: 1298MB
Total: 4094MB
Installed: 4096MB

Installed system: Windows 7 SP1 64-bit
In msconfig, normal boot selected.
In boot, advanced option, max. memory unchecked.
No memory remapping or frame buffer options in BIOS settings.

Conclusion:
In-compatible memory WITH WINDOWS 7 ONLY !!!
or dead memory of the KINGMAX D3-1333 !!!
m
0
l
!