Sign in with
Sign up | Sign in
Your question

ASRock P67 Extreme 4 Gen 3 - Won't Post

Last response: in Motherboards
Share
May 21, 2012 12:29:40 AM

I'm trying to put together my new machine. I've built a computer before but it's been five years. I installed everything seemingly correctly, and when I power up the machine all the fans are running, I get power to the motherboard and everything. However I don't get anything on the screen and I get four error beeps with a error code 55 from the indicator on the board. This seems to indicate no memory installed, but the memory is installed and in the correct spots as described in the manual, I've tried it in different places and with no memory at all, still the same issue.

I've gone though that checklist and everything is done correctly. I don't know if this memory issue (which could easily be caused by the speed of the memory or something) would affect it not showing anything on the screen at all though. I read about how you can change it manually in the bios to what you want it to read memory and that it might fix a problem like that but I can't get into the BIOS.
a b V Motherboard
May 21, 2012 2:07:52 AM

Please list your memory specs.
m
0
l
a b } Memory
a b V Motherboard
May 21, 2012 7:23:13 AM

How many memory stick do you have? Is all the memory have same speed?

Its better to list your memory specs as previous poster said.
m
0
l
!