Why cant i play GTA4?

Hi everyone.
I think this is not the proper place to post this but i just wanna know why cant i play GTA 4 on my pc? with patch 1.02 or 1.2 idk exactly

OS:Windows 7 64-Bit
CPU: Intel Core i5-650 3.2Ghz
MOBO: ASUS P7H55/USB3
RAM: Kingston 4GB DDR3 --- 2x2GB
GPU: GIGABYTE Gtx 550 Ti @ 1005Mhz
PSU: GIGABYTE Superb Powersupply 460W
HDD: Western Digital Caviar Blue 500GB (also got WD 500Gb My Passport External HDD)
DISPLAY: Samsung SyncMaster B1930n 18'5

others which arent significant to running but i'll put it anyway
KEYBOARD: Logitech WAVE
MOUSE: Razer Deathadder 3500 DPI
SPEAKERS: Creative 2.1 (my super old speaker but still working fine xD)

Feedbacks and comments are greatly appreciated :)

Ty in advance.

-NanoSuitFan211
4
answers
Last reply
More about play gta4
  1. I don't know, why can't you?
  2. I would start with checking drivers versions for the MB and GPU. The hardware seems all fine.... Might be worth it to run CPUz and confirm your hardware is as expected.
  3. Well even if i run it at 800x600 with lowest settings i get 20 fps and it flactuates to even 10 fps idk why just weird and my Gpu-z and cpuz says all the stats are right. in gta it says that i am using 900/1000mb something like this. Btw i play bulletstorm maxxed with 60 fps, crysis 2 very high in 60 fps, split second, burnout paradise, bfbc2 50-70 fps all maxxed too, Nfs shift maxxed, dirt2 and other games. So i am sure my hardwares are working at their level. btw all on 1366x768 resolution.

    the only problem is running GTA 4 maybe its poorly coded
  4. I recently just built my new computer with similar specs and same Graphics card.

    It took about 2-3 hours for the whole update process, and the game works great. played for 5 hours right off the bat. No issues at all.

    I was just really patient with the install/update process(i did want to throw stuff around at several points).

    I had to go through all the updates and at one point I had to uninstall the social club because it was "part" of the game with a recent update and no longer separate. Make sure that gets done. It was also very annoying to have my rockstar social club account linked to my Windows live account. I just read everything and let the computer works it's updates.

    I also noticed that when I do play the game my memory is at 3.8 GB so you may need more RAM. Also, is the passport external HD powered by USB? If so your power supply may not be up to task. Try unplugging it.


    I would deactivate the game license, uninstall everything. And start from scratch, and take your time.
    Here are rockstars most recent instal instructions

    http://support.rockstargames.com/entries/479447-gta-iv-pc-installation-instructions

    Hopefully it's not a hardware issue.
    ______________________
    GIGABYTE GA-970A-UD3
    COOLER MASTER eXtreme Power Plus RS500-PCARD3-US 500W
    AMD Phenom II X4 955 Black Edition
    CORSAIR Vengeance 8GB (2 x 4GB)DDR3 1600
    EVGA GeForce GTX 550 Ti
    Windows 7 Home Premium SP1 64-bit
Ask a new question

Read More

Homebuilt Systems