Zotac Z68ITX-A-E Front Panel Audio problem linux

Hi All,

I've asked this question in many places and haven't gotten an answer. I have two board which use the same realtek alc892 audio codec/chipset. Basically on one board, there is NO SOUND FROM THE FRONT PANEL HEADPHONE JACK. Here are the two boards.
ZOTAC Z68ITX-A-E (See page 19 of the manual http://downloads.zotac.com/mediadrivers/mb/man/pa198.pdf)
ASRock H67M-ITX/HT (See page 31 of this manual ftp://174.142.97.10/manual/H67M-ITXHT.pdf)

Ubuntu 12.04 is the flavor of linux i use. The drivers are correctly installed during installation. However, on the zotac board the "Sound Settings" doesn't have a "Headphones" setting under the "Output" tab of "Sound Settings"

I should note that I have installed Windows on both of these motherboard and the Front Panel Audio WORKS on both of them. Headphone works in Windows 7 Ultimate, but not on the Zotac board in Linux.

I tried installation several times. Tried updating the drivers to the ones provided by Realtek on their website and it still didn't work.
Then I checked the Front Panel header on both boards. They are almost similar. same 10 pin configuration with pin 8 missing (no pin).
Pins 6 and 10 are both stated as "Reserved" under the motherboard specification and I suspect that may be the culprit.
On the ASRock mother board pins 6 and 10 are MIC and HEADPHONE jack detect output. Also, after looking at Intel's specification of HDA Connectors, it seems that the ASRock board is correct and the ZOTAC board isn't (or is "Reserved" their way of saying something else?).

My case is the LianLi PCQ08B and it has an HD Audio connector.

So my question is, is ZOTAC to blame or is there a problem with the LINUX drivers which misinterprets the front panel audio pins? And why the hell is it working in WIndows and not in Linux?

Please help. I've been struggling to get an answer from anyone with this regard.

Thanks
Chhatc
4 answers Last reply
More about zotac z68itx front panel audio problem linux
  1. If front audio is working in windows, then why blame to zotac. Maybe linux driver is not working. Try updating to new driver.

    Actually windows are upnp, linux are less upnp.
  2. I appreciate your response but it isn't a very educated one. Telling me who to blame and not to blame doesn't solve my problem. I've already provided most of the information from my findings in this post in the matter of the HD Audio jack pin configs on the two boards, and the case that I am using.
    If the chipset is identical (ALC892 codec) then the result should also be identical in LINUX as well as Windows.

    I'm just here so that someone who knows more about HD audio jack config can have a look at my findings and point me in the right directions.

    FYI i've already posted this on zotac support forum, dslreports, anandtech, and launchpad.net... i just want to make sure im being advised correctly.

    C
  3. Then only thing that can help you, is a good driver for linux from manufacturer.

    Here is a link of latest driver from realtek for linux:
    http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

    Try this.
  4. Already been through the task of downloading the drivers from realtek and compiling the alsa driver locally... did not work. Which is why i am here!
Ask a new question

Read More

Motherboards Zotac Front Panel