Sign in with
Sign up | Sign in
Your question

Laptop GPU Driver ????? Windows Experience index

Last response: in Graphics & Displays
Share
March 25, 2011 8:37:22 PM

Hello!!
I recently installed windows 7 x32 on a laptop, but i noticed there was no aero and it looked real ugly.
but the laptop should support Aero, i mean it has Intel integrated graphics (128MB,pixel shader 2 supported), on a laptop, so i checked the experience index.
the 3d graphics was on 1.0
so i looked in print and view detailed information
And What i found there was that:
total available graphics memory was on Not detected; and dedicated memories was on "0"
and i recently installed intel Graphics driver GMA werediscontinued and for XP, was it a bad idea?

HELP ME PLEAZE MY ENGLISH NOT GOOD!
a c 214 U Graphics card
March 25, 2011 10:05:42 PM

Windows 7 is much more graphicly demanding than any other version of Windows,espically Windows XP.It use's up more VRAM to make it look pretty.You can change the theme to Windows 7 Basic and you might get a slight improvement but 128MB isn't a lot.

You could try downloading drivers from the company that made your laptop(through their webiste).That may also improve performance and it might register correctly.

Have you downloaded all the Updates for Windows 7 including SP1?
March 26, 2011 6:21:00 AM

Humour me for a moment, turn off UAC.
Install the windows Xp drivers you have for your laptop that were supported in windows XP, but not win7.
Do this by right clicking the intel VGA driver exe and going to the compatibility tab, and checking it to windows XP.

Then run the instal once you have applied the changes.

i did this on our old PC downstairs and it got aero to work properly...though the wei only went up by 1 point when the graphics driver is correctly being initialised by win7.
Infact I have been able to do this on most older hardware/laptops included that intel has decided to stop supporting drivers for win7.
Related resources
March 26, 2011 10:17:19 AM

curtis_87 said:
Humour me for a moment, turn off UAC.
Install the windows Xp drivers you have for your laptop that were supported in windows XP, but not win7.
Do this by right clicking the intel VGA driver exe and going to the compatibility tab, and checking it to windows XP.

Then run the instal once you have applied the changes.

i did this on our old PC downstairs and it got aero to work properly...though the wei only went up by 1 point when the graphics driver is correctly being initialised by win7.
Infact I have been able to do this on most older hardware/laptops included that intel has decided to stop supporting drivers for win7.


yea, but i have already installed it in compatibility mode, and i tried the experience index AFTER the GMA driver was installed.
March 26, 2011 10:18:50 AM

purple stank said:
Windows 7 is much more graphicly demanding than any other version of Windows,espically Windows XP.It use's up more VRAM to make it look pretty.You can change the theme to Windows 7 Basic and you might get a slight improvement but 128MB isn't a lot.

You could try downloading drivers from the company that made your laptop(through their webiste).That may also improve performance and it might register correctly.

Have you downloaded all the Updates for Windows 7 including SP1?
no i haven't really, maybe the SP1 would fix it? !
March 26, 2011 10:19:55 AM

curtis_87 said:
Humour me for a moment, turn off UAC.
Install the windows Xp drivers you have for your laptop that were supported in windows XP, but not win7.
Do this by right clicking the intel VGA driver exe and going to the compatibility tab, and checking it to windows XP.

Then run the instal once you have applied the changes.

i did this on our old PC downstairs and it got aero to work properly...though the wei only went up by 1 point when the graphics driver is correctly being initialised by win7.
Infact I have been able to do this on most older hardware/laptops included that intel has decided to stop supporting drivers for win7.


i already turned the *** off the moment i installed windows 7 lol
March 26, 2011 3:05:49 PM

ok, am bout fresh out of ideas then, you could also try to find the igfx.exe for the driver once its installed and hit compatibility on that too(the app it runs in windows ) but then you've probably tried that already, I had to try a few permutations before i managed to get it to work on some of them, but yeah as purple stank said get the drivers from your laptop manufacturer and try that, direct from intel can be a pain sometimes...oh yeah, I remember what I did, one of them I found the vista driver and compatibility hit that also...

http://www.sevenforums.com/drivers/637-installing-video...

Worth a look.. good luck.
March 29, 2011 12:17:47 PM

yea so my chipset is GMA 915/910! but i already thried installing and uninstalling the intel driver.. (for Win XP)
and it seemed to work (eg i tried the index again and the aero experience had moved up from 1.0 to 1.6!)

BUT the and and graphics is still on 1.0, and if i go see advanced , then it still says that memory not available, 0mb, 0mb! Thats not much of an issue, but i'd sure like to enable aero!
March 29, 2011 12:21:05 PM

curtis_87 said:
ok, am bout fresh out of ideas then, you could also try to find the igfx.exe for the driver once its installed and hit compatibility on that too(the app it runs in windows ) but then you've probably tried that already, I had to try a few permutations before i managed to get it to work on some of them, but yeah as purple stank said get the drivers from your laptop manufacturer and try that, direct from intel can be a pain sometimes...oh yeah, I remember what I did, one of them I found the vista driver and compatibility hit that also...

http://www.sevenforums.com/drivers/637-installing-video...

Worth a look.. good luck.


btw my chipset is GMA 915/910! but i already tried installing and uninstalling the intel driver.. (for Win XP)
and it seemed to work (eg i tried the index again and the aero experience had moved up from 1.0 to 1.6!)

BUT the and and graphics is still on 1.0, and if i go see advanced , then it still says that memory not available, 0mb, 0mb! Thats not much of an issue, but i'd sure like to enable aero!

i still havent updated to SP1, would it work? gonna try,
a b U Graphics card
March 29, 2011 5:07:51 PM

...If you install a driver for XP on a Vista/7 machine, be happy it works at all. Thats a miracle in its own right.
March 29, 2011 7:26:21 PM

DANG! DX I just found out that intel did not make a Vista or 7 compatible driver! that means that there IS NO driver for Intel GM 910 /915 to support aero! only the xp ones!

look: http://www.intel.com/support/graphics/sb/cs-023606.htm

what about the memory? who cares -.- ..

wish some hacker made a 915 WDDM driver from intel gma 945 or something, cause its only Intel's fault!
!