X-fi pci express stop working

Hello,

Strange one... Have the PCI-express X-Fi card, been working fine until today. Can get sound from the headphone jack, but not the normal speaker outputs. Speakers work connected to anything else, but no longer the normal speaker outputs from the sound card. I've tried updating drivers but no luck.

Any ideas what could be wrong?

Thanks in advance
6 answers Last reply
More about express stop working
  1. Probably a setting through the audio chipset or software, are you running windows 7? have a look at the output channel settings in the X-fi software and start playing around there.
  2. ^ +1
  3. Did this happen after having headphones plugged in? It could be a damaged headphone jack and the soundcard not knowing the headphones have been unplugged.
  4. +1^ seems a very logical explanation with that sound card you should be able to set another sound output port as your default stereo output port try change it to a different physical port on the sounds card and see if that makes any difference.
  5. Uninstall the SoundBlaster in the Device Manager (DO NOT uninstall the Drivers) and then restart the PC and when Windows starts it should detect and reinstall the sound card. This may fix it.

    If not, reinstall the Creative drivers (get the latest drivers from the Creative site). You should have the What You Hear (what SoundBlaster calls the "System Mixer") and the other missing recording devices.
  6. Hey razor as far as i know he has already tried new driver software and that has not worked for him. "'Ive tried updating drivers but no luck. "
Ask a new question

Read More

Sound Cards Speakers PCI Express Components