Sign in with
Sign up | Sign in
Your question

X-fi pci express stop working

Tags:
  • Sound Cards
  • Speakers
  • PCI Express
  • Components
Last response: in Components
Share
September 3, 2011 11:28:24 AM

Hello,

Strange one... Have the PCI-express X-Fi card, been working fine until today. Can get sound from the headphone jack, but not the normal speaker outputs. Speakers work connected to anything else, but no longer the normal speaker outputs from the sound card. I've tried updating drivers but no luck.

Any ideas what could be wrong?

Thanks in advance

More about : pci express stop working

September 8, 2011 11:40:21 AM

Probably a setting through the audio chipset or software, are you running windows 7? have a look at the output channel settings in the X-fi software and start playing around there.
m
0
l
September 8, 2011 1:33:57 PM

^ +1
m
0
l
September 8, 2011 11:18:38 PM

Did this happen after having headphones plugged in? It could be a damaged headphone jack and the soundcard not knowing the headphones have been unplugged.
m
0
l
September 9, 2011 12:13:27 PM

+1^ seems a very logical explanation with that sound card you should be able to set another sound output port as your default stereo output port try change it to a different physical port on the sounds card and see if that makes any difference.
m
0
l
September 9, 2011 12:16:38 PM

Uninstall the SoundBlaster in the Device Manager (DO NOT uninstall the Drivers) and then restart the PC and when Windows starts it should detect and reinstall the sound card. This may fix it.

If not, reinstall the Creative drivers (get the latest drivers from the Creative site). You should have the What You Hear (what SoundBlaster calls the "System Mixer") and the other missing recording devices.
m
0
l
September 9, 2011 2:30:53 PM

Hey razor as far as i know he has already tried new driver software and that has not worked for him. "'Ive tried updating drivers but no luck. "
m
0
l
!