Closed Solved

ASRock Z77 Pro 3 - Takes 20-30 seconds on the splash screen

When i press Tab to see what it's doing, it's not doing anything...at least it's not showing anything.
It just has the copyright, bios revision and the date.
Then it after 20-30 seconds it shows the typical bios stuff and proceeds to load windows (windows loads within 5 seconds..SSD rocks!)

I'm normally used to having the Bios splash screen disappear within 3 seconds and start up windows....
But I also used a very old mob and had a regular SATA HDD...

Is this typical behavior or is there something wrong with my mobo?
If I press Del to get into setup, it takes the same 20-30 seconds as well.

Here are my specs.
ASRock z77 pro3 with the lastest bios revision
i5 3570k
8gb ram
HD 7850

I tried disabling Legacy USB rom and that did nothing.
21 answers Last reply Best Answer
More about asrock takes seconds splash screen
  1. I have almost the same setup. I noticed the same issue but now it loads quickly.

    Don't know what it was, maybe windows doing stuff in the background? Has your issue also cleared up?
  2. Nope, I still have the same problem. Did you do anything differently? Change drivers?
  3. I have same mobo. It used to load to windows quickly, now I wonder ...why is it taking so long. I have a blank screen for a minute then it loads. I have added more things, which I assume is slowing it down; but not sure if its all programs.

    Also, when I walk away from my computer (more than 10 minutes) the screen will shut off. When I return I hit keys or mouse and wait 20 seconds for screen to start, weird. Anybody else get this? Before, I hit the key and screen is up in 2 seconds.
  4. Best answer
    I have an Asrock Z77 Pro 4 and I don't have any of those problems. My board is pretty much the same as the Pro 3 is.

    Anyway, in my experience if it takes super long to boot it is probably a hardware failure OR you have your computer set to do some long serious of startup checks in the BIOS.

    Look in the BIOS and make sure you are not doing any sort of extended testing. If you aren't, then try to disconnect things that don't absolutely have to be connected and see if that fixes it.

    Stuff like extra hard drives, cd drives, USB devices, extra RAM sticks, extra video cards, and stuff like that.
  5. I think it could also be looking for boot drive, i may have set it up to look only at the HDD for boot not the DVD or EXT USB drive (which I have connected)
  6. Are u in the AHCI mode?

    Do u have a PCI wireless adapter?
  7. What's the BIOS version?
  8. I installed Windows 7 in AHCI mode and set the appropriate settings in Bios.
    I'm pretty sure I do not have a PCI wireless adapter.
    The only slot that I am using is for my PCI-e video card.
    Bios revision is 1.2. I just noticed that 1.3 is out, but it seems like it was only intended for Windows8 users. Should I flash it anyways?
  9. Did you try booting it without all that extra stuff connected like I asked?

    It sounds a whole lot to me like the computer doesn't like a piece of hardware attached to the motherboard.

    If you get rid of everything you don't absolutely have to have, like the USB hard drive, anything else USB, CD drives, any extra internal hard drives, and so on then the problem might clear up immediately and then you will know it was one of those removed things.
  10. I don't have any USB drives.
    The only hard drive I have is the one currently connect to it..the SSD.
    I do have a integrated video card, so I'll try removing my video card when I get home.
    I'll also try removing my CD drive when I get home.
    Is there anything else I can remove?
  11. Not sure if this will help but....
    When I first start my computer "Bios Splash Screen" stays on for about 20 seconds. Then it loads windows.
    When I press tab this is the text I see.

    Quote:
    Copyright (c) 2011 American Megarrends, Inc.
    BIOS Date: 4/24/2012 20:05:40


    AFTER 20 seconds....the following text loads very fast and the windows splash screen comes up. (had to record this part with a camera and go frame by frame to catch it)

    Quote:
    Z77 Pro3 UEFI P1.20
    CPU: Intel(R) Core(TM) i5-3570K CPU @ 3.4GHz Speed:3400MHz
    Total Memory: 8126MB

    Press F2 or DEL to run Setup
    Press F11 for Boot Menu

    Detected ATA/ATAPI Devices...
    SATA Port0: M4-CT128M4SSD2
    SATA Port3: ASUS DRW-24B1ST c


    The text above takes less than 1 second to load.
  12. You can remove the 2nd RAM stick.
  13. Found the culprit! It turned out to be the SATA cd drive....
    Once I disconnected it, it takes a maximum of 5 seconds for the windows logo to appear....
    So now that I know the culprit...how do I fix it?
  14. Was there a cd in it?
  15. If not, try to upgrade a firmware on it.
  16. When the CD is installed, is it first in the boot order?
  17. The CD was installed the same time I build my computer.
    Had the problem from day 1 so I suspect that to be the only problematic hardware.
    It is listed second in the boot order.
    When I try to update the firmware, it gives me an error.
    When I try to use the DOS exe file, it says please download the x64 bit version (which i have done already)
    When I use the WIN exe file, it give me an error like 3-3-3-0 unable to find device.
  18. I would just trash the CD drive and get a new one, they are like $20.

    I had the exact same thing happen to me and I just got a new one.

    The only difference is that I did the firmware update just fine and it didn't fix the problem. Replacing it with a new one fixed it right away.
  19. newegg here i come.
  20. Best answer selected by pkpkay.
  21. This topic has been closed by Nikorr
Ask a new question

Read More

ASRock BIOS Splash Screen Motherboards