Sign in with
Sign up | Sign in
Your question

ASUS Bios won't update for my new chipset.

Last response: in Motherboards
Share
May 24, 2012 5:05:26 PM

I have a fully operational ASUS P5LD2 Ver 1.0 board with the 1st model Pentium D 805 processor that works fine. I picked up a Pentium D 950 but need to up date the bios prior to install.

So far I've downloaded and unzipped AFUDOS V2.32,
AMI BIOS update tool and P5LD2 BIOS 1903. I copied these to formatted fat32 usb thumb drive, then
reset the system and pressed F8, selected USB thumb drive option. From there the screen goes black and nothing else happends.
I even watched the ASUS instructional youtube video...

I have seen some posts and watched a video on EZ-Flash but in the video it showed a tools option in cmos, and i'm not seeing that in my cmos?

Any ideas??

Oh and I contacted ASUS tech support as well, no response yet...

a b V Motherboard
May 24, 2012 6:34:55 PM

Do you have a writable CD drive? Maybe it would work from the CD instead.

Boards that old sometimes have trouble recognizing USB drives outside of Windows. Especially if the USB stick is a newer kind.
May 24, 2012 6:57:37 PM

Sounds like you have used a USB port that is not "powered" on at boot. Move it to a rear USB port that is powered and try again. Usually two ports default to power on unless its optioned in the bios. ** As some bios have options that require you enable the "USB power at boot" option**.
Related resources
a c 111 Ĉ ASUS
a c 431 V Motherboard
May 24, 2012 7:21:41 PM

as your changing the bios and there a lot of the for that mb. check to see what one your at now and the one you downloaded. if you have the first one or near that your going to have to load each and every bios one at a time. most bios look for just the last one to be a vaild flash file. also make sure the flash file is unzipped and named right and is on the root dir of the usb stick.
May 24, 2012 8:50:26 PM

Here's where I'm at so far: When I hit F8 after post I get like 4 options.
Option 1 is boot from floppy.. I don't have a floppy.
Option 2 is boot from sata Maxtor HDD
Option 3 is boot from ide WD HDD
Option 4 is boot from cd.
option 5 is boot from usb drive MMC (MMC is the brand of stick I have) so power should be ok. Stick is pretty old as it's only 512mb.

I tried cd but it's not bootable so that wont work.
I then made a bootable cd with MS dos 6.22 and thats the closest so far, It gets to to the A: promt. then I go to D: promt and load my cd with new bios BIOS 1903.iso and bios loader AFUDOS V2.32.exe but i don't remember the dos commands.
I tried (cd bios_1903) looks like d:>[bios_1903] but from here tried install and install *.* with no luck.
a b V Motherboard
May 24, 2012 9:05:41 PM

There should be an option on the splash screen that tells you what key to hit if you want to use EZFlash. You should be able to use that.

You will need the CD with the updated bios on it, but it doesn't need to be a bootable CD. It just needs to have the BIOS file on the root of the CD.
May 24, 2012 9:16:59 PM

Raiddin, you might be on to something. I got an email back from tech support.

Dear Valued Customer,

Thank you for contacting ASUS Customer Service.

My name is Jany and it's my pleasure to help you with your problem.

Suggest you use EZ Flash utility to update BIOS for a try.
Format the USB flash disk as a bootable disk.
Store the BIOS file to it.
When POSTing, press Alt+F2 and enter EZ Flash menu to update the BIOS.

Welcome to refer Troubleshooting & FAQ for ASUS products in ASUS website:
http://support.asus.com/servicehome.aspx?SLanguage=en

If you continue to experience issues in the future, please do not hesitate

to contact us.

Best Regards,

Jany

I'll try this when i get home... wish me luck..
May 24, 2012 9:19:53 PM

What is or how do i make a bootable usb flask disk?
a c 111 Ĉ ASUS
a c 431 V Motherboard
May 24, 2012 9:51:29 PM

http://www.softpedia.com/get/System/Boot-Manager-Disk/B...
you dont need to you have the wrong file the end of the file should not be iso it should be .rom the mb flash file program (f6) i think at post that has the dos based rom program built in is looking for *rom not .iso.
May 24, 2012 9:56:58 PM

sorry about that, it is .rom
a b V Motherboard
May 24, 2012 10:13:06 PM

If you have an ISO file you have to use a program that can deconstruct it and make a CD out of it. You can't just copy it directly to a storage device like that.

Something like ImgBurn should work.
May 25, 2012 2:04:01 PM

pressing ALT+F2 brings up EZ flash which then scans for bios files on floppy and optical drives. when I unzipped and saved the bios file I named it P5LD2_BIOS which might exceed the amount of allowed characters because it finds it then give some error & I think I read a post that it has to be 8 characters or less. I'll rename it P5LD2.rom and try again. I'm getting down to my last ditch effort, hooking up a floppy drive...
a b V Motherboard
May 25, 2012 3:57:00 PM

Don't rename the file anything. Leave the name as whatever it already was when you downloaded it.
!