Sign in with
Sign up | Sign in
Your question

GA-970A-D3 "Loading Operating System" problem

Tags:
  • Gigabyte
  • BIOS
  • Motherboards
Last response: in Motherboards
Share
May 24, 2012 7:30:04 PM

Specs:
GA-970A-D3
AMD FX-4100 Zambezi 3.6GHz
G.SKILL Ripjaws Series 8GB DDR3 1600 (PC3 12800)
4 x HGST Deskstar 0S03230 3TB drive
1 x Seagate Barracuda ES 750GB drive

BIOS updated to latest version (F9). BIOS posts just fine. SATA is set to AHCI for all 6 SATA ports. I'm NOT using the on board RAID. All other settings are set to Optimized defaults. I'm using RedHat Enterprise Linux 6 server and the install works perfectly. All drives are available to the installer and all OS files are loaded on the 750GB drive. Upon reboot, the BIOS posts, goes black for about 15 seconds and then says "Loading Operating System". At that point it stops.

All research I've done says that this is a common problem with this board and updating the BIOS solves the problem. I'm running the latest BIOS version and the problem remains. I've switched out the 750GB drive holding the OS and reloaded numerous times now with no real luck. I know this problem is with the BIOS and not with the software (RHEL, windows, etc). My next step is to download the latest BIOS again and try to redo the update. Maybe I got a bad BIOS image or something.

Any others ideas would be appreciated.

More about : 970a loading operating system problem

a c 481 V Motherboard
May 24, 2012 7:59:17 PM

it may be the mb not reading your ram right so the speed and voltage could be off. also check to see if your using the xmp profile or stock. see if setting the bios to 1300 and 1.5v and something like 9-9-9-9 timing changes anything. if not try taking out one dimm.
m
0
l
May 24, 2012 8:59:55 PM

The ram voltage is set to auto and is 1.5V as stated in the G.Skill specs for the modules. As for the timing, I'm not exactly sure what to do here. Gigabyte is confusing me ion terms of the timing settings. The CAS latency is set to "11T". I've never seen timing settings like this. I'm used to seeing 9-9-9-24-2N which are the timing specs reported by G.Skill.

My guess for the correct settings are:

DDR3 Timing - Manual
CAS# latency - 9T
1T-2T Command Timing - 2T
RAS to CAS R/W Delay - 9T
Row Precharge Time - 9T
Minumum RAS Active Time - 24T

I'll give that a go. In terms of the xmp profile, it was my understanding that xmp goes along with Intel processors and not AMD. Am I wrong there?

Thanks for the help, it's appreciated!
m
0
l
Related resources
May 24, 2012 9:03:36 PM

OK, after setting the ram timing manually, the BIOS posts, It says "Loading Operating System" quickly, the screen goes black, seems to reset once, and now I just have a blinking cursor.

I'm really feeling like this is not a memory issue. I have the DVD set as the first boot device and when I have a bootable DVD in the drive, the system says "Loading Operating System" for a split second and then boots the DVD correctly. This has got to be something to do with the SATA drives and how they are configured.

I tried switching the SATA settings to Native IDE but I got the same results. Back to more testing......
m
0
l
a c 481 V Motherboard
May 25, 2012 1:32:43 AM

are you trying to run both os or just windows?? if your trying to run both you need a boot loader. as windows wants to put part of itself into the master boot record. a few years ago when people did two boot os. they had to load windows first and partion the drive in 1/2. windows needs to be on the active partion and needs to make a system partion. then people would load the other os that they wanted.
m
0
l
May 25, 2012 2:38:13 PM

Definitely no winblows at all. Only Linux for me. I have setup plenty of dual-boots in the past but this one is strictly RHEL6.

I suppose I could try something like Linux Mint or Ubuntu just to rule out any weirdness with the RHEL6 boot loader. I'm really thinking that this is a MB issue talking with SATA but it would be good to discount the other possibilities.

m
0
l
a c 481 V Motherboard
May 26, 2012 3:02:09 AM

with new mb there two bios nows the old stock ones were used to and eufi (sp) bios. with the bios set to default the new gui bios are the first bios. you have to look on the easy screen bottom to see what drive is the first one. if it not the hard drive you want then go into advance mode and under hard drives select the one you want to boot first. if they wont change check the sata ports that your hard drive that you want to boot from is on port 0. most cheap mb and bios are going to boot in order from 0-6. if you have the drive on the wrong port it could be on the 3 party sata chipset and they might not let the drive boot.
m
0
l
May 26, 2012 8:06:15 PM

Hey, I have been having the same exact issue as you. Tested RAM, swapping out HD to different SATA ports to no conclusion. I think its the Motherboard. My model is the Gigabyte Z68ap-d3 rev 2.0. BIOS is fully updated. Let me know if you come up with any solution to this.
m
0
l
May 29, 2012 2:21:05 PM

I don't think this board has the GUI BIOS (EUFI). This board goes right into the regular text based BIOS we are all used to. I've checked the order of the hard drives and settings multiple times now. I've tried having the main OS hard drive in the SATA0 port and also in the SATA5 port. The ports get split up into SATA0-3 and SATA4-5 but there is no mention of multiple SATA chipsets in the manual. It appears that all 6 are on the same chipset.

I really do not want to have to RMA this motherboard and get a new one but I'll have too soon if this issue cannot get resolved.

I appreciate the help greatly....
m
0
l
a c 481 V Motherboard
May 29, 2012 3:44:44 PM

if your using a add on sata card for the raid drives. try pulling the card out and seeing if the os will boot if it does it could be an irq issue or a missing driver on the os drive.
m
0
l
May 29, 2012 10:15:20 PM

Sorry, I don't think I said anything about an add-on sata card of any type. I'm using the 6 on-board sata ports but NOT using the RAID setting. I want to use AHCI but I can deal with IDE if I must.
m
0
l
a c 481 V Motherboard
May 30, 2012 12:43:48 AM

try this...most new mb has two bios the efi and the old cmos check that efi bios is on...if not the 4tb drives wont be seen. another trick is unplug the other drives and do an install of your os and see that one drive and one cd-rom will boot. with new mb and sata ports they boot from the first port 0 to the highest port 6. you want to put the hard drive on port 0 if not you have to change them in hard drive boot order.
m
0
l
May 30, 2012 3:35:23 AM

This BIOS does not have the graphical EFI BIOS, at least, I can't see the option for it. I even went so far as to reset the CMOS using the jumper.

It does have an option for the EFI CD/DVD Boot option. It's set to automatic by default but I switched it so that it definitely will turn it on.

I also disconnected all hard drives except the OS drive and the DVD. OS hard drive is in SATA0, DVD is in SATA1. SATA mode is set to AHCI. Did a full clean install, all went well, rebooted.......

ended up with the blinking cursor and the OS never boots.

Next I switched from AHCI and set to Native IDE and same results.

This is maddening. I've never had this much trouble with a Gigabyte board before. I typically buy them as they work really well with RedHat Enterprise.
m
0
l
June 5, 2012 8:10:15 PM

Sorry to leave anyone curious hanging but I finally gave up and RMA'd the motherboard. the new motherboard (different model) arrives tomorrow so hopefully this one works better.
m
0
l
June 11, 2012 7:57:02 AM

Hi ccar_support, I am also have problems with the ga-970a-d3 motherboard. I have already RMA'd one board and the replacement board is no better.

Can you tell me which board you chose to replace yours and whether it solved the problem. Thanks.
m
0
l
June 18, 2012 3:15:40 PM

I ended up going with a GA-990xa-ud3 from Gigabyte. Once I got the new board in, I found the same type of issues.

I FINALLY found a solution that worked. Try this with your current board.

- Make sure your BIOS is fully updated

- On a separate system, load your OS install (windows, Linux, etc) onto a bootable USB. There are multiple ways to do it. (Unetbootin, usb-creator, etc)

- Unplug your SATA DVD-rw from the motherboard and yank it from the system.

- Have only your OS destination hard drive plugged into the sata0 port

- in the BIOS, set your sata to ahci or native ide (it's your choice).

- Boot from the usb stick and install normally.

For me, all was fine once I removed the sata dvd from the mix. For some reason, the BIOS hung up in the handoff from, bios to OS even if the hard drive was set as the first boot device. After I had the OS installed and running, I was able to connect 4 other sata hard drives and create a RAID with no problems. The system is acting completely normal now.

Good luck with your rig!
m
0
l
June 22, 2012 10:03:30 PM

Thanks for your reply. I replaced the Gigabyte board with the Asus M5A78L-M/USB3. Amazingly the same BSOD problem persists. The only 2 pieces of H/W I haven't replaced are the DVD writer and the CPU.

What I cannot understand is that a previous build with the same Gigabyte board had no problems and is running fine. Only difference was that the LG DVD drive was a slightly different model and the CPU was a Phenom 955 (current one is Athlon II 260).

I will be replacing the DVD writer since it is starting to make some noises. If the BSOD problem persists with the new DVD writer I will try your solution - thanks for posting the details. It does seem amazing that we need to go to go through these contorsions.

I will post back when I find the solution for this problem.
m
0
l
July 1, 2012 2:58:57 AM

Here is an update for anyone interested. With the Gigabyte 970a-d3 motherboard, as suggested by ccar_support, I did try to load Win 7 (64) off a USB boot drive with the DVD unplugged, but did not have any luck - it hung about half way through.

The Asus M5A78L would BSOD when I tried to load the motherboard drivers especially the ATI Catalyst driver. If I only loaded the minimum drivers and avoided the Catalyst driver it seemed OK. Otherwise it was unstable with frequent BSODs. Updating the BIOS and changing memory had no effect.

I decided to return the Asus board for an Gigabyte B75m-D3H socket 1155 motherboard. Interestingly when installing Win 7 it rejected the HDD due to the GParted partitioning scheme (500 GB with 4 partitions). I had to delete the partitions before Win 7 would load. It runs fine and I am happy with it.

I still do not know why the other motherboards were having problems. The first one built is running fine.
m
0
l
February 6, 2013 6:07:45 PM

Hi--just wanted to add to this thread in case anyone else is having problems with this board--one problem I was having was that I could not see the Gigabyte splash screen or access the bios setup menu, though my OS would boot. It turned out that the GUI bios did not work with my video card, at least not with an HDMI monitor attached. I switched to a VGA monitor and then could access the GUI bios setup menu.

It's pretty bad that the new GUI menu doesn't support all video cards/setups. It's worse that it provides no warning or indication that this might be the case. There's not that much advantage over a text-based bios menu, and I wasted countless hours trying to figure it out.

Note, I am referring to the Rev 3.0 version of this motherboard (the Gigabyte 970A-D3). Early revisions may use the old bios menu. The bios version was F8.

m
0
l
!