Sign in with
Sign up | Sign in
Your question

Keyboard doesn't work on USB 3.0

Last response: in Motherboards
Share
May 25, 2012 1:55:40 AM

I just built a new machine with a Gigabyte Z77X-UD3H, and my keyboard doesn't seem to work with the USB 3.0 ports in the back. I'm using a SteelSeries Shift keyboard, and I only seem to get minor functionality when it's plugged in. Some of the keys simply don't work, and none of the hotkeys/media keys do anything. The SteelSeries software doesn't recognize the keyboard at all. I talked to the SteelSeries support people, and they said it was a motherboard issue.

The keyboard works fine if I use any of the USB 2.0 ports in the front. Unfortunately, this motherboard does not have USB 2.0 ports in the back at all, so I'm stuck with wrapping my cables around to the front of the case. My motherboard firmware is up to date, and I've played around with BIOS/UEFI settings with no luck so far. Any ideas?

Edit: I installed the latest drivers from the Gigabyte website. No change in behavior.

More about : keyboard work usb

a b V Motherboard
May 25, 2012 2:24:39 AM

I get issues with my MS keyboard plugged into a USB 3 port also. Not consistantly, but it is troublesome enough to force a cold reboot.

It seems that USB 3 is not 100% backward compatible.
m
0
l
a b V Motherboard
May 25, 2012 2:47:24 AM

Some system have to install USB3 driver to work correctly,

u can check your mobo manufacture website for new usb 3 driver....
m
0
l
Related resources
a c 125 V Motherboard
May 25, 2012 3:25:19 AM

Have you installed the following 2 drivers? If not, then install them and revisit the issue:
VIA USB 3.0 Driver
Intel USB 3.0 Driver
m
0
l
May 26, 2012 1:40:44 AM

Yes, I've tried both drivers. Nothing different.
m
0
l
February 7, 2013 9:24:24 PM

I have a gigabyte gigabyte z77x-up4th which is similar to your motherboard and it has very similar issues with USB 3.0. I am using a logitech G110 keyboard and it works most of the time but if I plug in a joystick or 360 controller into one of the other USB 3.0 ports it loses functionality until I unplug the controller. The G110 has a built in sound card and USB port and if I plug anything into those ports the keyboard loses functionality on USB 3.0. I installed a USB 2.0 back plate and it fixed the issues in windows but when plugged into the USB 2.0 back plate which does plug into a USB 2 header on the motherboard I am unable to use the keyboard in the bios or during the boot stage like to select between dual OS or pressing Delete to get into bios doesnt work. I have tried many settings in the bios and cannot figure this out. I think it has something to do with the Via USB 3.0 drivers. They really need to be updated.

Edit: I also have issues with my Logitech G930 headphones on USB 3.0 and my keyboard doesnt light up properly sometimes after restart. I have NEC USB 3.0 ports on my old gigabyte X58a-ud3r motherboard and they never had any issues but I did not use them that often for things other than USB 3.0 external Hard drives.

Also I have tried all the driver updates as well from the Gigabyte website, the Disk that came with board, and even directly from Intel and VIA. Still no difference.

Does anyone know what the Intel USB 3.0 driver even does? Is it for different USB 3.0 ports or does it work in conjunction with the VIA Driver? As far as I know the 3.0 ports are all controlled by VIA chipset. So what is the intel driver even for? My old mobo did not require 2 drivers for USB 3.0.
m
0
l
a b V Motherboard
February 8, 2013 12:43:31 AM

check the latest bios probably fixing your kb problem already.
m
0
l
February 8, 2013 1:17:25 AM

I have the latest non beta bios. F9.. there is a beta F10b not sure if it would be worth upgrading to.
m
0
l
February 8, 2013 3:46:34 AM

Still running into this problem myself. I contacted both Gigabyte and Steelseries, and neither want to accept fault on this (so no replacements, no refunds). This is really bothersome.
m
0
l
February 8, 2013 4:24:29 AM

I figured that would be the case. I also posted about it on Logitech forums and contacted logitech they think its the Via USB 3.0 drivers.
m
0
l
!