Sign in with
Sign up | Sign in
Your question

6990 struggles with crysis 2??

Last response: in Graphics & Displays
Share
March 29, 2011 2:12:06 AM

Hi guys,

can anyone explain to me why 2 6990s struggle with crysis 2? im running 5760x1080. I barely runs. I am runing the early preview drivers which supposidly have better cfx support..

The game barely runs in eyefinity..why is that??

I mena it runs, just for the hardware, really horrible to the point where I stopped playing it.

Deadspace for ex ran GREAT...homefront pretty good too.. but not eyefinity.. deadspace 2 was eyefinity

More about : 6990 struggles crysis

March 29, 2011 2:12:32 AM

I see the 6990 doing well with metro 2033 at a smaller res..is the res just too high?
m
0
l
March 29, 2011 2:35:36 AM

metro is one of the most demanding dx11 game and it became one of the benchmark suite instead of game to some people just like how the original crysis was. you can look at this review:

http://www.techpowerup.com/reviews/ASUS/Radeon_HD_6990/...

even with single 1600p monitors 6990 cannot get playable framerates with very high setting. as for crysis 2 i heard there was some problem regarding multi-gpu though i'm not really sure if the problem already fixed or not.
m
0
l
Related resources
March 29, 2011 2:38:46 AM

renz, crysis 2 runs HORRIBLE! I have several games on reserve at gamestop and this one I was waiting for the most. I wont play it until the drivers are updated..I guess?

Doesnt one of the drivers mention "better" cfx perf with crysis 2?
m
0
l
March 29, 2011 2:42:59 AM

have you tried playing with single monitor?
m
0
l
March 29, 2011 2:44:04 AM

no but I will. I just want to use eyefinity..
m
0
l
March 29, 2011 2:49:52 AM

then try to run the game on the lowest preset. AFAIK the difference between three preset are hardly noticeable but if you run on extreme preset it does eat your frame rates
m
0
l
March 29, 2011 2:52:27 AM

I will give it a try..although it detected my hardware as being extreme..?
m
0
l
March 29, 2011 3:34:13 AM

asus p6t deluxe v2..980x, 12 gig ddr3 memory.. dual 6990, 1200 watt power supply..windows 7 ultimate..
m
0
l
March 29, 2011 3:39:16 AM

with one monitor, runs crazy fast.. I wonder if its a multi gpu thing or just an eyefinity thing..
m
0
l
March 29, 2011 3:44:39 AM

3.3 ghz... now im noticing massive screen flickering.. jeeze.. its got to be that AMD didnt optimize their drivers yet for the game to run in quadfire
m
0
l
March 29, 2011 3:45:50 AM

Or that Crysis 2 is a buggy console disaster.
m
0
l
March 29, 2011 3:49:49 AM

I was thinking that..but honestly, im not sure how to do that
m
0
l
March 29, 2011 3:50:32 AM

I remember on my old alpha workstaiton, i just had to adjust a few jumpers to make the system work faster..
m
0
l
March 29, 2011 3:53:27 AM

No jumpers - it is all in the BIOS/Software these days. Just browse around the web a bit - almost all review sites have an overclocked 980X and I'm sure they have some ballpark figures to start off with.
m
0
l
March 29, 2011 3:54:51 AM

but would homefront run well if I was bottlenecking? I can certainly try and overlock
m
0
l
March 29, 2011 3:55:14 AM

I did notice that asus has software that I can use to overclock my system.. would that do the trick?
m
0
l
March 29, 2011 3:58:34 AM

While we are on the topic of OCing Psycho, what was the stock voltage on your 2600K?
m
0
l
March 29, 2011 4:00:51 AM

sorry if I sound dense.. multi is multiplier? what would that be under?if i change that to 30, what will that do? will i see the cpu in the bios reported as runing at 4 ghz?
m
0
l
March 29, 2011 4:02:49 AM

Multi is multiplier off of the BCLK. So 30x133 = 3990MHz. Turn off Turbo boost too.
m
0
l
March 29, 2011 4:05:12 AM

let me see if I can find it..brb
m
0
l
March 29, 2011 4:09:38 AM

I was just letting him know he'll see 3.99, not 4 :D 
m
0
l
March 29, 2011 4:10:34 AM

the only thing i found under adv settings with the cpu ratio that could be changed t
m
0
l
March 29, 2011 9:49:08 AM

cpu ratio is what you want. with quadfire your asking for trouble, few games run well in quadfire. just use 1 card and see how it runs. i bet it runs better.
m
0
l
March 29, 2011 3:17:24 PM

FWIW - I run Xfired 5850's and Gpuz says the second card is idling. The game displays the Xfire logo so it looks like it is running in game. I am using the latest AMD drivers and Cap4 release. Also a 980x at 4.4G

On a 1900x1200 monitor it runs great. I will try the Eyefinity - I had not thought about that...
m
0
l
March 29, 2011 3:26:25 PM

17seconds said:
...video chopped...

Funny Matto... That very flickering (though I didn't have it quite so frequently) in AMD multi-GPU setups in other games such as BFBC2 and MOH is the reason I went out and bought 2 580s.

Again, we see more frames per second clearly not equaling better performance. I really hope AMD gets crossfire worked out because the hardware is capable (or is it?).
m
0
l
March 29, 2011 3:30:20 PM

I believe it's a problem with the game. It does'nt want to handle dual GPU setups at all.

Im having a massive problem with my 6950 crossfire setup at the moment with poor performance and flickering. If you play the game in window mode then It stops, but who wants to play a game in window mode!?

Hopefully ATI or EA will get their backsides into gear and sort out a patch/fix!
m
0
l
March 29, 2011 5:03:01 PM

marney_5 said:
I believe it's a problem with the game. It does'nt want to handle dual GPU setups at all.

Im having a massive problem with my 6950 crossfire setup at the moment with poor performance and flickering. If you play the game in window mode then It stops, but who wants to play a game in window mode!?

Hopefully ATI or EA will get their backsides into gear and sort out a patch/fix!

The video showed it running flawlessly at 90 FPS on a GTX 590.
m
0
l
March 29, 2011 6:10:41 PM

@Eyefinity - It doesnt just happen with crossfire it's happening to SLI also..... This Really frustrates me! Almost 4 years in development and this happens!
m
0
l
March 29, 2011 6:14:34 PM

marney_5 said:
@Eyefinity - It doesnt just happen with crossfire it's happening to SLI also..... This Really frustrates me! Almost 4 years in development and this happens!

It's running smoothly on my SLI. No problems to report here.
m
0
l
March 29, 2011 9:18:07 PM

I doubt it will be anytime soon. If it were that close to being done, they would have just put it in the release. I imagine that was more of a statement to pacify the PC gamer rage for them going backward on visual quality.
m
0
l
March 29, 2011 10:54:49 PM

17seconds said:


Who is that guy, and why does he have my job??

But seriously, he didn't buy all those himself right? Right??

Also, Cry-Adam on the MyCrysis forums has stated that a DX11 patch is not coming. Or more specifically, he said he doesn't know where the rumours are coming from, that they are completely unofficial, and that if there is to be any patch it will appear on the MyCrysis webpage first and foremost.
m
0
l
March 29, 2011 11:11:14 PM

Linus Tech Tips - Your Youtube source of dependable PC hardware reviews. Dude's got about $10,000 worth of video cards laying around. He even briefly forgets where he put the GTX 590.
m
0
l
March 29, 2011 11:12:42 PM

Quote:
Have that same monitor. 120hz > All

He even has an Asus ROG motherboard box leaning up against the wall.
m
0
l
March 30, 2011 7:12:50 AM

Right this is weird..... After a few hours of trying to find out why my crossfire setup is under performing in the following.

Crysis 2 - Flickering, stuttering.
3D Mark 11 - Score drops by 2000
Mass Effect 2 - Stuttering, slow performance.

I uninstalled Crysis 2 and everything back to normal! No drop in performance in the above, 3D Mark11 score is back up and Mass Effect runs fine as normal.

Is anyone else finding these issues with Crysis 2?!!!!
m
0
l
March 30, 2011 1:01:16 PM

It's a virus! We should have known.
m
0
l
March 30, 2011 3:09:05 PM

Don't worry... They'll have a driver fix for this next month.
m
0
l
March 30, 2011 5:42:13 PM

well sounds like crossfire is working like it should again...
m
0
l
March 30, 2011 7:34:17 PM

Quote:
Have that same monitor. 120hz > All



lol nice flickering with the 6990s just a quality overall showing :lol:  1400 dollars worth of gpu and you get that?
m
0
l
March 30, 2011 7:36:39 PM

Quote:
Have that same monitor. 120hz > All



so are you playing all your games at a constant 120 fps? I never understood that argument. Its either that or you don't use vsync and you can deal with the variable framerates and inevitable screen tearing?
m
0
l
March 30, 2011 7:39:59 PM

yeah well my question would pertain to any game, even though the crysis 2 performance with current drivers look pathetic
m
0
l
April 1, 2011 3:23:23 PM

Even the new ATI drivers and CAP doesn't fix the issues yet.

The problem is Crysis2 only uses ONE GPU. So if you have CROSSFIRE 6990s..... Not only is it NOT USING the second card, it's only using ONE GPU on the 1st 6990, since it is a dual GPU card

Sucks balls I know
m
0
l
April 1, 2011 3:59:21 PM

yeah I noticed the same when I had 6870 crossfire, it now runs a lot better on a single oc'ed gtx 570 :)  although the game all in all is not that impressive imo
m
0
l
April 1, 2011 4:07:57 PM

Yeah not impressive at all. IT's a fun game, and would be great on its own merit, especially running on the 5yr old xbox. BUT as a sequel to CRYSIS it is a complete and utter failure
m
0
l
April 1, 2011 4:14:09 PM

^couldn't have said it much better myself, agreed


xbox 360 is more than 5 years old now isnt it?
m
0
l
April 1, 2011 4:20:49 PM

wakanabi said:
Even the new ATI drivers and CAP doesn't fix the issues yet.

The problem is Crysis2 only uses ONE GPU. So if you have CROSSFIRE 6990s..... Not only is it NOT USING the second card, it's only using ONE GPU on the 1st 6990, since it is a dual GPU card

Sucks balls I know


Both of my 8800GT's GPU's are being used by Crysis 2, which I thought was a bit odd seeing as how I keep seeing posts from people saying that neither SLi or Crossfire work in this game.
m
0
l
April 1, 2011 4:22:59 PM

I think crossfire doesnt work too well bc my 6870 crossfire (before I ditched it) was not utilizing tha second card very much if at all, imo

but on the other hand sli might work ok
m
0
l
April 1, 2011 4:26:14 PM

Mousemonkey, it's because you are running old drivers for your 8800s. For some reason the old drivers will use xfire just fine. But for everyone with brand new cards and drivers it doesn't work..... pretty ridiculous I know. MY friend with dual GTX570s has same issues as me
m
0
l
!