Sign in with
Sign up | Sign in
Your question

Remote desktop stopped working over internet but works over local net

Last response: in Networking
Share
August 29, 2010 9:44:33 PM

Ive been using remote desktop for a very long time now. Recently it stopped working over the internet, but i can still log into another computer on home network from home and i can log into another computer at work from work. I control router at my office and my home and nothing has changed on either network. I even rebooted both routers and i disabled windows firewall. This has been driving me crazy. home computers r win xp and at work one is xp and one is win7pro-64bit. Could cablevision(my provider at work)or Fios(home provider) of blocked this some how because i do it so much?
August 30, 2010 2:04:42 PM

Well first check if your IP hasnt changed for your router.

Second thing is check if the ports 3389 is open on your router and windows firewall...
to check these ports go to the comp)uter that you want to remote desktop to (the one at home) and look for a site called sheilds up (or just online port scan) and enter the port 3389

Try those suggestions and get back to me ok.

Thanks,
Axxeon

m
0
l
August 30, 2010 6:11:28 PM

the port is open and ip's are the same. i was wrong about something in my original post. I can remote desktop into my house(xp based) from my office(win7-64bit based), but i cant from home to office. and at home i still can remote desktop into another home computer and at work i can into another work computer. So over internet works only in one direction
m
0
l
Related resources
August 30, 2010 7:26:14 PM

Your office's internet connection and configuration is the issue.

You have your home set up that if you RDP into your public IP address, it'll connect to your home computer. Your office internet connection needs to be configured the same way. If you RDP to your office's IP address, you'll need to have it port forward to your office PC.

This would be relatively easy if at the office you have a small network. If you have a larger network and network admins, etc, it'll be harder. That part will require a VPN solution most likely.

If you have control over your office network, you'll have to configure the router to forward port 3389 to the IP address of your work computer. When you RDP to the office's IP address, it'll forward it to your computer.
m
0
l
August 31, 2010 4:00:56 PM

i have everything setup already. I changed the port for one of the computers at each location to port 3390 and the RDP registry key. I did this months ago and i checked and settings are the same. I can only log into one computer at home from the office. I cant log into either computer at the office from either computer at home. I was starting to think it was the one computer at home that i cant log into, but the fact that i cant log into the office from either home pc has me thinking it cant be.
m
0
l
August 31, 2010 7:28:33 PM

You made a registry change? Not the right way of going about it.

On the office router, you need to set up port forwarding. You assign a port to forward (3389) and forward to a destination IP address (your work computer's IP address).

Make sure RDP is enabled on your work computer and the correct users have access. From there you will need to RDP to your office router's public IP address and it will redirect it to your computer.

If you don't have access to the router, you won't have access to RDP to your work computer. RDP'ing out will be easier since you would then have full control over the router and computer at home.
m
0
l
September 1, 2010 5:53:43 AM

I have 2 pc's at each location so i had to change the port's on one at each location....


Either way, i made the changes over 6 months ago and had no problems until last week.
m
0
l
June 17, 2011 8:20:08 PM

I have the exact same problem. My Remote connection was working till some time ago and then it stopped working (only one way). I disabled the firewall, checked my port and IP and read a bunch of stuff on the net but still no luck.

Did you manage to solve your problem?

EDIT: And yes, remote desktop works using my local ip within my network like you said.
m
0
l
October 20, 2011 4:24:04 PM

With Hello :
Problem Solved !
It`s a Port forwarding . Please Going To your NAT Part of Router (ADSL Modem) And Add Port 3389 IN TCP and UDP Port For Your Local Network IP(TCP Is Enough) :D  . I Think You Change Local Ip And Forget Change Port Forward Ip . Good Luck :hello: 
m
0
l
October 20, 2011 8:29:05 PM

Hello,

Thanks for the reply, I almost gave up on fixing my problem (it still have the same problem).

I am not sure I understood what you meant. I followed everything on the following site (including adding port 3389 to "Port Forwarding"). I just checked my router and these settings are still there. Do I need to do anything else? How come a change in my local IP will change what I do since I am not actually entering it anywhere? Also do you mean something else than the router port forward settings when you say "NAT part of router"?

Port-Forwarding for DIR-655

Thanks a lot,
Nac
m
0
l
!