Sign in with
Sign up | Sign in
Your question

DEll Dimension (9200)Disaster

Last response: in Systems
Share
June 16, 2011 11:50:00 PM

Hi All...

Im having a right nightmare with a Dell Dimensions Desktop PC

Dimensions/specs

http://support.dell.com/support/edocs/systems/dim9200/e...



This machine had a RAID 0 array set up and one of the harddrives began to fail and showed allsorts of errors on boot...it had Vista Business pre-installed on it. ( no disk)

Overview of first actions

Backed up data onto external HDD
Ran virus check, CKDSK, Defrag and Dell Diagnostic to make sure.
Updated BIOS from 5.0 to 5.3
made sure all other downloadable automated drivers etc were ok

Second

Tried to run the recovery partition from the desktop..no joy..threw up just a red x with "error"
Tried to run the recovery partition off boot..no joy either..

Third

Broke the RAID array in two giving me 2x 250 GB drives combined 500GB
formatted the drives back to raw partitions
Switched from RAID to ATA/Auto RAID in BIOS
Switched the good HDD onto the primary channel 0 and disconnected the other
Set the boot order ok
Tried fresh XP install (SP 2)...NOTE this XP disc has been modded and used successfully to be used for an external USB device to carry the OS on a different machine, basically it installs the USB drivers early so an eternal HDD could be used instead of an internal HDD..has worked fine many times before on NON Dell machines

Problems

Now, those nice people at Dell dont use P2P connections for their Keyboard and Mouse :ouch:  devices so I had to use USB devices.....all well and good you say as my XP install has this very support modded into it..nope....
I get into the install fine and go through 5-6 generic USB controller verifications ( the system asking my permission to install them/verify them, as a result of my mod)...but, when it gets to the last one..the Root hub..the Mouse and Keyboard quits working..and I have to reboot....as I cant control what I want it to do...


More

So..i think..ok, gotta get me some updated chipset drivers in, so made a USB flash/floppy boot device and found some likely looking system files..that went fine until I asked the XP install to install RAID/SCSI drivers via F6...the flash device wasnt found so I went back to my other rig and designated the USB flash drive as drive A...like a floppy...( later did i realise that its only exclusive for the machine im working on)

I cant get the Dell to see the USB flash drive as drive A, but I can get it to do a little something on an exclusive USB boot.( says its installing USB driver profiles) .but after about 10 mins the screen goes black..and nothing..... :fou: 

Yes...the Dell folks dont have floppy DD either..and guess what I dont have a floppy cable...just and old FDD stuck inmy electrical box...

So nothings working...the BIOS isnt giving me any hints whatsoever..if i set to primary CD boot..i get the XP install...set to a primary USB..then I get that...it wont detect on F6...( I have given it about a million "F" words :fou:  )

I reset the CMOS/NVram jumper, and made sure the BIOS looked ok after
I also "zero" wrote the drive to make sure it was clear....(can u guess how long i have spent on this)


Despirate

So i try and a generic Intel chipset support bundle..but hey..they are all executables only and I dont know how to get them in INF formats to be added to a boot device like my USB flash drive....a look round Dells website..and INtels website..i was nearly violently ill from soo many choices, sub categorys and rediculous dropdown menus that made no sense to me ( Im an Orthodox AMD/ASUS/MSI/Nvidia person)...at least they are easier to look at for help :cry: 

The last ditch..was to try a switched install..install the main stuff on my other rig..and switch the HDD back to the Dell.....i knew it wouldn't work..BSOD time...


Please..has anyone got any ideas?...why the hell wont this Dell allow me to have USB devices..like the essential keyboard/mouse on install?

Help me please :heink: 

Martyn
June 17, 2011 2:16:24 AM

Some general thoughts.

An apparently failing drive is not always a failing drive. Sometimes it's a drive controller. Have you tried another SATA port?

XP SP2 should have USB keyboard support built in. Do you not have the original CD?
Related resources
June 18, 2011 7:53:03 PM

I guess I've always used IDE mode for XP installs :)  Thanks for passing that along!
June 18, 2011 9:37:06 PM

Interestingly..my BIOS version only gave ATA/Auto RAID...or RAID only funktions .........

so i just went auto..there was no hint of any IDE power management or AHCI settings

This guide, if follwed to the letter...works!...

Thanks Proxi for posting

Martyn :-)
!