Closed Solved

RAM issue

i recently bought new hardware to upgrade from. installed everything and everything works correctly, but my ram "stock" frequency is at 1333 according to the bios, when it should be at 1600. i didn't install any software, or drivers, or did a bios update. i just did a strict hardware installation and plan to do a reinstall of the OS when i get my SSD in [wont boot windows and receive BSOD on my current HDD. could be because everything on the HDD was originally AMD, and the switch to Intel is causing it to boot incorrectly.] it could be the QVL and the ram not actually being tested in the list. i tried uping the frequency and rebooting but then i'm forced to shut down and reset it as it says "overclocking failed". i guess i'm fine with running at 1333, but its annoying because if i wanted to run at that speed, i might as well should have boughten the 1333 version instead.

running:

i7-3770K [should support 1333/1600 stock]
Sabertooth z77 [should support up to 1866 stock]
geIL Black Dragon 32GB 1600
6 answers Last reply Best Answer
More about issue
  1. you have to reinstall if you switched motherboards, 1600MHz is probaly XMP so you would have to enable it
  2. Best answer
    try updating the bios the second one has:
    SABERTOOTH Z77 BIOS 0906
    1.Improve system stability.
    2.Improve memory compatibility. <--- that!

    but go for the latest.
  3. thanks you two. i'll go ahead and update the bios then since i have to wait on the SSD. i still have the old parts from the AMD build. thefore i'll just hold onto the HDD before i reformat it just in case there is other stuff on it i need to back up.
  4. Best answer selected by branden_lucero.
  5. That Bios update did it. had to remove 3 sticks though and reinserted them for it to reboot though, but i set them at 1600, did a quick reinstall on a small HDD to make sure and everything's golden.
  6. This topic has been closed by Nikorr
Ask a new question

Read More

Memory RAM