Sign in with
Sign up | Sign in
Your question

2GB of Ghost RAM, why???

Last response: in Memory
Share
June 1, 2012 9:15:43 PM

Hi to all. This is my problem:

I have 4GB of Ram installed (physically), 2x2GB in Dual Channel and Unganged Mode, but my Win7 64 bits tells me that i have 6GB installed but only 4GB usable. The "Resource Monitor" shows that i have 2051 Mb of Ram Reserved for Hardware and another 4000 Mb of ram used+free. I think Win7 supose that the 2Gb of "ghost Ram" is reserved for Hardware, couse can't reach it.
I can see the "ghost Ram" with the boot cd of Memtest86+ too, when showin' the DMI Data. It tells me that i have:

Slot 1 : 2048 MB
Slot 2 : 0 MB
Slot 3 : 2048 MB
Slot 4 : 2048 MB (this is the "ghost RAM"!!!)

I dont have nothing installed physically in this Slot of the MB, i know it. I tried to re-flash my BIOS with the last that Gigabyte gives me (the same that i already had), beeing sure that i disabled the "Keep DMI Data" option as Gigabyte recommends for this BIOS version, but nothing changed. The Bios version is FGf, is Beta, but is the last one, and is the ONLY one that is suposed to support my AMD x6 1075T (yes, its sad but true), but Gigabyte tells that is functional despite it "removes boot PXE ROM & unlock CPU core function".

I tried too to quit the Dimm of Slot 3 and put it in Slot 4, and NOTHING has changed, the same info in Memtest 86+ (v.4.10), the same in Win7 too. But the more funny thing is that
I'M STILL IN "Dual Channel" !!!!!.
My Ram timmings are relaxed, CL9-9-9-24, 2T, all in Auto, and the Ram is running at 1333MHz. I disabled all "Eco" functions in BIOS as is recommended here in this web (C1E,ErP,C&Q....).
There are some things that dont seems to work well. I can't switch from Unganged to Ganged mode, i changed in Bios but at boot it still tells me Unganged. Despite i put off "Eco" functions in BIOS in CPU-z i still see my CPU multiplier fluctuate from x4 to x15 (x17 too but it's normal is the core turbo).

I think i need some help, if you want more info, i will post it too. The specs of my system are in my signature. Thanks to all for your help.

More about : 2gb ghost ram

a b } Memory
June 1, 2012 9:48:33 PM

Have you checked by CPUZ ? Imo it's glitch post some pictures of it
Might possible it's new baby of them or your house is hunted by ghost :) 
June 6, 2012 2:19:22 PM

It can't be a new baby of them :non:  , are too young to do it. :) 


This is what CPU-z says:

http://imageshack.us/photo/my-images/853/cpuzw74gbnq.jp...

The dimms were in slot 1 and 4 when i took the screenshot but cpu-z still showed the slots 1 and 3 as populated instead of 1 and 4.
In the screenshot we can see that cool n quit still lows the multiplier to x4 despite its disabled in BIOS.

Dont know what its happening......
Related resources
a b } Memory
June 7, 2012 4:22:50 PM

Can you post win7 states that tell's you your having 6gb ?

I followed that link and your system memory is 4gb which is alright as it's 2x2gb in slot 1 and 3 but you said it's in 1 and 4 make sure it's in 4th slot
June 7, 2012 7:42:56 PM

I'm absolutely sure that my dimms were in slots 1 and 4, it was me who put it there, and i could saw it through the little holes of my case that are up in it, when i wrote it.

As i said, my Bios is the newest , the last one that Gigabyte offers for my motherboard (revision 2.1), and as i said i already had Fgf version of bios but reflashed it again with Fgf (with a new download from the web) thinkin' it could be a bad flash, or a bad downloaded Bios. I reflashed it with the Q-Flash utility, and disabling the "Keep DMI Data", as Gigabyte says in its web for this bios, but all stayed the same.

But now the situation has changed, i moved the dimms from 1&4 to 2&4 for see if my motherboard likes better the dimms away from socket. Now the Win7 only says that i have 4GB (the 6GB and only 4GB usable are gone), and i though that all was right, problem solved, couse the "Resouce Monitor" has erased the 2051Mb of Hardware Reserved too and seems allright, but when i ran Cpu-z i saw that it says that are in Slot 1 and 2!!! :ouch: 

I booted the cd of memtest86+ and now the DMI Data of it says i only have one dimm in Slot 2!!! im going crazy :pt1cable: 

I will post some pictures of all of this in few minutes.
June 7, 2012 9:46:21 PM

Here are the screenshots. This is what Memtest86+ says when i select "Memory DMI Info":

http://imageshack.us/photo/my-images/220/memtest8607062...

This is what CPU-Z shows in Win7 x64:

http://imageshack.us/photo/my-images/443/cpuzdimms2y4nq...

And this is the picture of the manual of my motherboard where it gives the memory info, here you can see how is its configuration and where i placed the dimms.

http://imageshack.us/photo/my-images/62/mbslotsdimms2y4...

Thanks for all the help.
June 7, 2012 9:55:42 PM

I made a mistake writin' before, as you can see on the screenshot of the memtest86+, it says i only have one dimm on slot 2, and not in the slot 1 as i wrote before. :)  (Fixed now)
a b } Memory
June 8, 2012 7:58:32 AM

When they're in 2n4 it showed 1n2 it's possibly glicth but if you getting performance problems try different sticks

I dont understand the laguage of last picture but seems like
install in 1n2 or 3n4 slot
a c 347 } Memory
June 8, 2012 9:18:36 AM

I take little currency in any of these Apps when it comes down to pure accuracy. CPU-z in may case reads DIMM Slots 1-5 and nothing on slots 6-8 (I know I have 8x4GB) installed. Further, Memtest86+ has no concept of my SB-E CPU or it's chipset.

However, for 'free' my only expectation is 'do no harm'. CPU-z does have the other data correct and Memtest can reliably 'test my RAM' which is all I care about.

There's such a diversity of chipsets, CPU, and alike and worst there 'is NO standard' and there's a lot of 'probe data' that's simply wrong.

To make absolute certain that all of you RAM is being used properly look at the Resource Monitor and if there's unexpected 'Hardware Reserved' then you might have an issue; IF your MOBO has an iGPU then factor in that 'Shared Memory' as part of the Hardware Reserved dedicated to the iGPU. Example if you allocate 2GB (2048MB) of RAM to the iGPU then expect 2048 + 20~50MB (typical) to show up.

June 8, 2012 2:35:46 PM

Jaquith i think it's true, maybe i shouldn't care about what memtest shows, but dont know if i should do the same with cpu-z reads, seems that much people trust in what it shows, but yes it might be a glitch.

When i had my sticks of ram on 1&3 slots the Resource Monitor showed 2051MB of Hardware Reserved, but now that are in 2&4 slots all seems alright, almost nothing of Hardware Reserved (I have iGPU but its disabled in BIOS).

Im gonna forget about memtest and cpu-z, but there are some little things that still worry me, and makes me think maybe something is wrong on my hardware or in my bios,..... why i can't change Ram from Unganged mode to Ganged??, i know that Unganged is suposed to performance better, or at least for multi-thread, but i think i should be able to switch between these two modes.
a c 347 } Memory
June 8, 2012 3:15:21 PM

I don't trust, and I see oddball i.e. programming errors all day. I'm a SQL programmer ;) 

Clearly, you must use the 'proper' DIMM slots for correct Dual/Tri/Quad Channel operation and installed per the manual. In most MOBO's keep the RAM in the same colored DIMM slots and in most situations: CPU | blank | RAM | blank | RAM | I don't know for certain what AMD MOBO or CPU you are using to give you a better answer.**

Leave it Unganged, here's a good technical guide -> http://www.ilsistemista.net/index.php/hardware-analysis...

**noted:
/If this is your set up then don't simply Memory Clock -> 8 and hope all will be fine./
MICRO: AMD X6 1075T
MOTHERB: GIGABYTE 890GPA-UD3H
MEMS: GSKILL F3-12800CL9D-4GBNQ (2x2048)

CPU | blank | RAM | blank | RAM |
DCT Unganged (default) ; leave it

DDR3-1600 (9-9-9-24 @ 1.50v) on ANY non-FX should always have the FSB -> 240MHz and/or on BE (Black Edition) CPU-NB Frequency -> 2400MHz; otherwise the CPU's IMC will through some errors.

FSB -> 240MHz & AMD Phenom II X6 1075T 3GHz
Math:
3000/200 = 15
3000/240 = 12.5
1600/240 = 6.67

BIOS:
FSB -> 240MHz
CPU Clock Ratio -> 13 ; 13*240Mhz = 3120MHz = 3.12GHz
Memory Clock -> 6.67 ; 6.67*240MHz = 1600MHz

DCTs Mode -> Unganged
DDR3 Timing Items -> Manual
CAS# latency -> 9
RAS to CAS R/W Delay -> 9
Row Precharge Time -> 24
-
DRAM Voltage Control -> 1.50v~1.55v

Save & Exit = Yes
!