Sign in with
Sign up | Sign in
Your question

External HDD wont work with FAT32

Last response: in Components
Share
September 12, 2011 12:21:55 PM

Was hoping someone could help me, I've been using an iomega HDD to play movies on my xbox360 until recently it stopped working, either because i dropped it or i put a corrupted file on it?

So i tried reformatting it, formatted it to NTFS then back to FAT32 with Fat32Formatter, when it is formatted in FAT32 it cant be opened with my laptop or on my xbox360. BUT it will work fine with my laptop when formatted in NTFS (which is why i'm not sure if the problem is because i dropped it).

does anyone have any ideas on how i can get it working with FAT32 again or should i just give up but a new one for my xbox360 and use this as storage?
September 12, 2011 7:51:59 PM

Fat 32 is not supported by all windows operating system which might be your issue.
September 12, 2011 7:59:56 PM

i dont think this is the problem as I was using the HDD with both the laptop and the xbox for months to play movies through the xbox, i think i remeber having to format it to fat32 before, and assume it wouldnt have worked with the xbox unless it had been fat 32 all that time. and the fact that once it is fat32 it wont work on the xbox either (stops xbox from starting properly if it is connected and on)
September 12, 2011 10:39:25 PM

see if iomega has a low level format tool. And then format it to ntfs or fat32 if that worked ok.
!