Sign in with
Sign up | Sign in
Your question

Odd problem, think my psu is partially dead?

Tags:
  • Power Supplies
  • Computers
  • Components
Last response: in Components
Share
September 12, 2011 1:36:37 PM

So I just swapped my laptop with my brother for a gaming rig which i built about a year and a half back. Quite excited about gaming on pc again but there is a hardware problem with this computer that I need to solve first. I suspect it is one of the rails on the power supply but don't have any spare PSU's (or cash at the moment) to test out so thought I'd ask here before I decide what I need to do next...

So he said that he was watching a film on the computer with no problems (there has been no problems with this computer since it was first built), he left the computer for a while and it had gone into sleep mode by the time he came back. He went to turn it back on but the power light just flashed on briefly and then off and that was it. If you try and boot the computer up that is what happens, sometimes the HDD light flashes on and off with the power light. If you press the power button again, nothing will happen until you turn the switch off on the back of the PSU and then back on again. However, when you do try and turn it on, the lights come on - on the motherboard and the power and reset buttons on the motherboard stay lit up. Also when you try and turn it on there are 2 red lights that flash on briefly on the ATI 4870 GPU (neither of us can remember if those lights on the GPU normally flash on so thought I'd mention it).

When you do attempt to power up, no fans move at all (all the fans are wired straight to the psu and a fan controller). I tried wiring one of the fans to the motherboard and then powered up. The fan literally jolted and that was all. So this tells me that the fan was at least very briefly getting some sort of power from the motherboard but not when it was wired straight to the psu. But why doesn't the fan keep spinning when attached to the motherboard, because the lights on the motherboard stay on?

I'm not sure how many rails this power supply has as I'm not entirely sure about what rails are. I'm fairly sure it has 2 though. So my best guess so far is that one of the rails has gone on the PSU. I did try resetting the bios with the jumpers incase the motherboard was somehow a problem but it didn't appear to do anything. It just seems that the computer very briefly attempts to boot up but then stops straight away.

I'm trying to save a bit of cash to fix it but I don't want to fork out for a replacement PSU incase there could be a different problem. Does anyone have any suggestions to what the problem could be? Also does anyone know what the amperage requirement is for an ATI 4870 1GB? (I've searched that loads and can't find a definitive answer - would be useful to know for my potential new PSU).

Thanks so much for any help that anyone can give :) 

More about : odd problem psu partially dead

September 12, 2011 2:25:58 PM

oh yeah i forgot to add there are no beep codes coming from the motherboard at all. not from the motherboard speaker or from the soundcard. please throw some ideas out there if you have any as im stumped :/ 
September 14, 2011 1:32:26 PM

I have made a little bit of progress with identifying the problem. Last night i borrowed a working psu from a working computer. i tried it in mine but the everything is the same apart from with this psu i borrowed, the power lights on the front panel dont light up at all, also i can get the fan to move at all by wiring it to the motherboard. i know that my psu works ok as i also wired it up to the computer that i borrowed a psu from and it worked fine.

So i have definitely ruled the psu out of the equasion here which is nice :)  I've tried unplugging all the drives, graphics card and ram but still no result (though i didnt expect it to do anything tbh). I'm really starting to think it is a motherboard problem. I have reset the CMOS with the jumpers countless times but no result. I think what is happening is that the power supply wants to boot but the motherboard obviously has control over the psu so it stops it dead in its tracks within miliseconds. i'm wondering if the computer going into sleep mode messed with the bios and it just cant power out of it. i'm thinking its bios corruption/error.

So i have 2 questions now:

1. Does anyone have any other ideas on what the problem could be before i start hassling ebuyer/asus for an RMA on my motherboard?

2. Does anyone know how long the warranty period is on asus motherboards? lol... It's an M3A79-T Deluxe which i purchased in january 2009.


Many thanks for any help offered. I'm struggling a bit here! 0_o
a b ) Power supply
September 14, 2011 1:43:44 PM

1. not sure but sounds likew your right on it being the board.
2. Asus boards have 3-5 year warranty depending which one it is, so yours will be in warranty whatever. I had to RMA a power supply to Ebuyer but as it was over a year old I had to send it direct to OCZ (in the Netherlands) as Ebuyer will only deal with the 1st year.
September 14, 2011 1:50:50 PM

I meant to say that i cant get the fan to move at all with the new psu and the gpu lights dont come on either. i think its probably irrelivant anyway. also i have discovered that asus motherboards have a 3 year warranty so im good for that, just dont wanna get stung for cash sending it back if its not the motherboard which is at fault...
September 14, 2011 1:52:32 PM

Yeah that might be the case. I'll check with ebuyer first and see what they say. Im just trying to be sure it is the motherboard thats at fault incase i get it wrong and incur unnecessary charges :/ 

Thanks for the reply :) 
September 15, 2011 2:59:54 PM

just a reply about ebuyer if its of interest to anyone...

the board had 4 months of warranty left luckily! i explained to ebuyer what happened and they are going to sort out a repair/replacement for me. i think they may even be paying for me to return it also (not sure). ive had some crappy experiences with ebuyer in the past but this one seems to be going ok so far...
!