Sign-in / Sign-up
Your question

Poor HD quality - HDMI to PC - PayPal reward for fix!

Tags:
  • Tuner Cards
  • HD
  • HDMI
  • Graphics
Last response: in Graphics Cards
April 4, 2011 12:56:59 PM


Hi, i have a 19' "NEON C 1997F" HD Ready LCD TV purchased from morrisons in the UK.
It is HD ready with 1080i & 720p modes. It has 1 HDMI port and the usual others. Maximum resolution: 1440x900

I have a pc with an ATI 5770 card installed with up to date drivers and CCC.
In every mode and resolution that i have tried, the quality looks very poor. The text seems blotchy and very jagged.

I can use the VGA connection @ 1360x768, and this looks alot better, but still not as sharp on the text as i would like.
I would really like HD quality like i thought i would be getting.

I can provide more details, info or pictures if needed.

About the PayPal: If a working fix is provided that single person will receive £5 English pounds (about 10 dollars?) sent to their PayPal account, if they so wish.
Would cost me more to change monitors so i'm happy to pay :) 

Thanks for any possible help/fix.

Lee.

More about : poor quality hdmi paypal reward fix

April 4, 2011 3:09:41 PM

Its your TV most likely. Check the data sheet specs for the native resolution (pixel matrix of your TV. It is limited to 720P
ore 1360x768 (720P).

When in HDMI you should select 1360x768 as well
April 4, 2011 6:04:22 PM

I do not have the data sheet specs (instruction manual?) anymore.
Can't say i ever remember them coming with the TV in the first place...

I plugged in the HDMI cable (which is a gold plated cable that came with the Xbox 360) and selected 720p mode and the resolution above, and although it fits the screen the same as the VGA does, the quality looks very poor. I don't have an issue with the image fitting the screen, its the quality of it.

I took a picture of the info on the side of the box, just incase it helps in some way:

http://i106.photobucket.com/albums/m248/leethedon1/PIC0...

Thanks for the help.
Related resources
April 5, 2011 3:02:14 AM

Open Catalyst Control Center
Go to Desktop and Displays
Desktop Management
Desktop Properties

Select the Display and Refresh rate that will work for your TV. Try each one until you find the one that will work for you.
April 5, 2011 8:16:34 AM

Tried each one a number of times, many fit the screen fine, but the quality is still blotchy and unfocused. As before.

?

Thanks.
April 5, 2011 11:49:08 AM

In your first post you stated MAX Resolution of 1440x900.
If this is the panels max pixel size it is just taking the larger resolutions and resizing the down. Which would be blurry.
April 5, 2011 5:54:16 PM

Unolocogringo said:
In your first post you stated MAX Resolution of 1440x900.
If this is the panels max pixel size it is just taking the larger resolutions and resizing the down. Which would be blurry.


Right ok, so how do i deal with this then?

Although, when going through all the resolutions and refresh rates, i came accross sizes that were smaller than the screen, giving the black bars at top & bottom, and that was just as blurry and blotchy too?

Thanks.
April 5, 2011 6:50:24 PM

the tv's or tv's monitors have theirs prossesor and and in connection the pc hdmi makes a few problems in native resolutions....better to buy simple monitor that make and cheaply.
April 5, 2011 7:03:57 PM

johnk10 said:
the tv's or tv's monitors have theirs prossesor and and in connection the pc hdmi makes a few problems in native resolutions....better to buy simple monitor that make and cheaply.


So its not possible to get HD quality from this current setup? Even though its a HD tv and can play HD fine from other sources (xbox etc..) ?

Thanks.
Anonymous
April 5, 2011 7:35:52 PM

It is not possible to get HD quality from that Monitor!

Full HD is 1920x1080

Your TV is 1440x900

Your TV is only HD ready or capable of 720p

TV and monitors are different in their makeup!

TV you sit further away, monitor you sit close up to it, therefore the size of the pixels are different (Pixel Pitch) allowing your eyes to resolve the resolution at the correct distance leading to a clear picture.

Sit to close to a TV and it is not sharp, go sit monitor distance from any other TV in the house and look at text and you will see what I mean.

TV = Good for Motion film
Monitor good for PC static text ect!

Also the box lies to you, it does not do 1080i as the max resolution is 900 not 1080i, so it downscales 1080i stream to fit! Marketing ploy!

http://www.hdtvorg.co.uk/focus/resolution.htm

all you need to know about HD
April 5, 2011 7:49:00 PM

Thanks for the info.

It looks like i have to get a pc monitor after all.

Just so confusing how a friend has a HD tv and runs his pc though that without issue. Plus the fact the 360 shows in proper HD..

And if this TV is capable of displaying in 720p, why when selected does that look awful too? I don't mean just a little bit, something sitting further back would solve, i mean really awful. As if the image was drawn by a 10 year old with a WAX crayon!

Thanks for the help & info.
April 5, 2011 8:34:58 PM

Use DVI (not HDMI, it's the same video quality) and turn off Morphological Antialiasing in the CCC.
April 5, 2011 8:52:36 PM

17seconds said:
Use DVI (not HDMI, it's the same video quality) and turn off Morphological Antialiasing in the CCC.



Checked CCC and can not see the "Morphological Antialiasing" option.

I'm currently using a vga cable from my pc to tv (with a dvi adapter on the graphics card) as this is the only way currently to get "some" use out of this tv. The resolution of 1360x768 is a perfect fit, just the sharpness is not as good as i would like. But i thought this would be the case and did not worry about it as i thought i could use the HDMI option and have a sharp clear image with that.
April 5, 2011 9:21:21 PM

leethedon1 said:
Checked CCC and can not see the "Morphological Antialiasing" option.

I'm not using AMD, so I'm not sure where to find the setting, but it's also called "MLAA". It applies a sort of blurry antialiasing to the entire scene, and is independent of antialiasing that may be supported in games.

Often, using a pure DVI connection can fix some of the resolution problems with HDMI with no loss in image quality. You just lose audio if you are connecting to speakers built in to the monitor/TV.
April 5, 2011 10:30:22 PM

Try reinstalling drivers and using a different cable if you have an extra one.
If not, pick one up for $2-$3, no need to invest hundreds into a cable.
April 5, 2011 10:37:42 PM

does your HDTV only have a VGA input? If it does, then it's a piece of ***.
April 6, 2011 9:53:36 AM

17seconds said:
I'm not using AMD, so I'm not sure where to find the setting, but it's also called "MLAA". It applies a sort of blurry antialiasing to the entire scene, and is independent of antialiasing that may be supported in games.

Often, using a pure DVI connection can fix some of the resolution problems with HDMI with no loss in image quality. You just lose audio if you are connecting to speakers built in to the monitor/TV.


The ATI 5770 card im using has 2 DVI connections and HDMI, however the TV has VGA & HDMI only, so i am having to use a VGA 2 DVI adapter. No full DVI connection is possible.

I have now found the antialiasing options on the 3D section of CCC. Will test & check these options now.

plznote said:
Try reinstalling drivers and using a different cable if you have an extra one.
If not, pick one up for $2-$3, no need to invest hundreds into a cable.


Installed & re-installed all drivers & updated to newest CCC. No results. Don't have a spare cable to test, will hopefully be able to get hold of a spare soon to test. However i don't think this will be the answer :( 


lmulder said:
does your HDTV only have a VGA input? If it does, then it's a piece of ***.


It has VGA, HDMI, scart & various audio connections.


Thank you everyone for the help & advice.

April 6, 2011 10:56:45 AM

leethedon1 said:
So its not possible to get HD quality from this current setup? Even though its a HD tv and can play HD fine from other sources (xbox etc..) ?

Thanks.


precisely my friend...:) 

And i have to the same problem my tv monitor sony brabia 42''.......Finally i buy 1 monitor pc, samsung syncmaster t260 26'' and all problems and my nervus :)  ends....

(the better connection to pc monitors is HDMI to DVI.....no problems)
April 6, 2011 7:55:50 PM

Last attempts have been tried and have failed. Hoping to get a 2nd HDMI cable soon but i doubt that will change anything.

Looks like im going to have to get another monitor after all :( 

Shame, i was really hoping to have just the 1 that could do it all.

So full DVI is what i want to be going for then on a TFT LCD type monitor? Or is a HDMI 2 DVI better in some way?

Thanks.
April 6, 2011 9:24:39 PM

full DVI....some monitors like as HP used 2 conections dvi for a new graphic card ......the difference from hdmi is that in dvi does not pass sound from the cable thing useless...sorry to all for my english :) 
April 8, 2011 1:25:34 AM

Got CCC
Select Desktop Properties
Select MyDigitalFlat-Panels

Work on the different options for Flat Panel
-Properties (Digital Flat-Panel)
-HDTV Support (Digital Flat-Panel)
-LCD Overdrive (Digital Flat-Panel)


The above will give you different display and refresh rates...
Try all of it and see if you can find the supports the limitation of your display
April 11, 2011 6:10:50 AM

You have to look at your TV video properties, and find the input source selection and set it to PC.

Then make sure that you have the over scaling (or underscaling) in CCC set to 0% (or 100% i forget which one it says)



I have the same card, same issue. and this fixed it for me
April 13, 2011 5:25:53 PM

Hi again, thanks for the new tips. Tried all suggestions above and also a new HDMI lead but the problems still persists.

Seems like some people have managed to fix there issues by changing the input settings on the TV, however i can not seem to edit anything on mine.

Here is the list that comes up when i press the Source button:

DTV
TV
SCART
AV
YPBPR
DVD
VGA
HDMI
April 13, 2011 5:54:54 PM

leethedon1 said:
Hi again, thanks for the new tips. Tried all suggestions above and also a new HDMI lead but the problems still persists.

Seems like some people have managed to fix there issues by changing the input settings on the TV, however i can not seem to edit anything on mine.

Here is the list that comes up when i press the Source button:

DTV
TV
SCART
AV
YPBPR
DVD
VGA
HDMI



Don't choose source, go to the menu, where it has the video and color options and that sort of thing. Under there you will see an option to change the input type to PC. Then after words correct for overscaling. Note that the overscaling option will only show up if Catalyst Control Center detects the monitor as a HDTV, which means that you need to configure the TV properly by selecting the right source type.
April 13, 2011 10:17:03 PM

I have tried that. There is a PC section in the menu, but is not selectable with HDMI. It can only be accessed when using VGA, and even then it is very basic. Auto size adjust etc..

The options to configure the TV in the way you are talking about are just not there. Unless there is some kind of hidden menu i cannot access.
April 13, 2014 10:51:13 AM

For me I changed the TV's settings' sharpness to 0. It totally worked for me! It used to be too sharp and not smooth and now it's perfect