Closed Solved

P8z68 deluxe/gen3 bios update 0301 to 3304, image integrity check failed. usb f

Hello all, thanks for taking the help in advance.
Attempting to upgrade my bios, followed all procedures, yet i get "Image integrity check failed".
please help
6 answers Last reply Best Answer
More about p8z68 deluxe gen3 bios update 0301 3304 image integrity check failed
  1. Best answer
    Did you try downloading the BIOS file again or writing it to a different device?
  2. yes. tried several and several devices
  3. You get the error when trying to flash from the BIOS utility? If so, have you tried resetting the settings to the default values? If that doesn't help, then I would suggest contacting Asus support.
  4. Thanks for your help. I had a thought this morning, to download the ROM from a 32bit computer and save it to the USB drive. Worked like a charm. odd though.

    I do have a follow up question but ill start a new thread.
  5. Best answer selected by Dragon007.
  6. This topic has been closed by Nikorr
Ask a new question

Read More

Chipsets BIOS USB Motherboards