Sign in with
Sign up | Sign in
Your question

Blue Screen after sleep with new RAM

Last response: in Memory
Share
June 3, 2012 5:07:04 PM

I just bought 24GB of Crucial RAM and replaced the stock memory with it to max out my motherboard. Everything runs fine until the system wakes up from sleep. It'll either crash and restart (from the fans it almost sounds like it's going to resume, but then restarts completely) or I'll get a blue screen with the "MEMORY_MANAGEMENT" message. Once it was waking up and did a "Resuming Windows" thing and worked fine after (still weird though). I switched my Power Options to High Performance once and it locked up. I ran a basic Windows Memory Diagnostic and got nothing. A few forums seem to discuss a similar problem, but I haven't found any posted solutions. Any advice would be cool. Thanks

More about : blue screen sleep ram

a c 347 } Memory
June 3, 2012 6:59:25 PM

Often this is a voltage issue of the RAM and or if mixing two sets i.e. 3x4GB + 3x4GB Kits even IF they're two of the same exact kit. Versus a fully matched and rated 6x4GB Kit which is best.

Assuming this is an X58 then raise the QPI/VTT Voltage-> 1.25v~1.35v depending on the kit. If 1.50v RAM then even 1.20v~1.25v, but if a 1.65v kit then 1.30v~1.35v. IF mixing two kits you might need to add +0.02v~+0.05v to the DRAM Voltage over the Rated Voltage i.e. 1.50v->1.55v or 1.65v->1.68v; >1.65v will light-up some MOBO warning LEDs.

Above is generic for X58 and not know the kit or kits in question makes it difficult to help you. On an LGA 1155 VCCIO/VCCSA -> 1.20v~1.25v.

You can try both the XMP (Intel only) or to set the DRAM Frequency, CAS Timings, and DRAM Voltage manually. On AMD (2x8GB + 2x4GB) on non-FX will require OC >DDR3-1333 not to mention the mixing, and LGA 1155 still the mixing issues.

Q - What CPU?
Q - What MOBO?
Q - What RAM? ; provide a link or links
Q - What BIOS?
m
0
l
Related resources
June 3, 2012 9:02:04 PM

It's an ASUS Essentio CG5290
i7 920 2.6GHz (LGA1366)
ASUS Gene II (generic I'm sure)
24GB 240-Pin DDR3 SDRAM 1333 (PC3 10600)
- I got two of these:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
The RAM is compatible according to the numbers in case anyone thought that might be it (Crucial's website even verifies this with its web software, specific to my model)
I think there has been one BIOS update since the one I currently have, but I read it had issues and never loaded it. I guess I'll do that. A friend just recommended testing each module individually to see if its just a faulty one. Think I'll do that next.

I'll be honest, I have no idea how to do what you're suggesting with the voltage, but I'm going to look into it.
m
0
l
a c 347 } Memory
June 3, 2012 9:39:15 PM

Okay, in the BIOS there are (2) approaches XMP (generally DDR3-1600 and faster) and Manually, Manually typically works best. In your manual refer to page 3-9 and down. ASUS sometimes misreads the 'SPD' JEDEC information and you get an Overclock Error (press F1), manually setting the RAM prevents that error as well.

BLS3KIT4G3D1339DS1S00 DDR3-1333 CAS 9-9-9-24 @ 1.50v (one kit not two) ; ref - http://images.crucial.com/pdf/productFlyer/ProductFlyer...

BIOS:

Manually set RAM:
(optional) Press F5 ; Loads Defaults -- ensures other erroneous errors are cleared; if you changed other BIOS settings e.g. SATA -> AHCI either don't press F5 or modify the settings as needed.
DRAM Frequency -> DDR3-1333
DRAM Timing Control /Enter
DRAM CAS -> 9
DRAM RAS to CAS -> 9
DRAM RAS PRE -> 9
DRAM RAS ACT -> 24
-
DRAM Bus Voltage -> 1.55v ; tweak (2 kits)
QPI/DRAM Core Voltage -> 1.25v ; tweak (2 kits) fancy name for the CPU's IMC voltage

Exit & Save Changes = Yes

Test the RAM, Sleep, etc.
m
0
l
June 4, 2012 12:28:19 AM

Updated the BIOS, and changed the settings you showed up to the voltage which I don't think I'm able to change, though I did find them in the voltage monitor:
DRAM Bus Voltage - 1.51
QPI/DRAM Core Voltage - 1.13

I brought the system out of sleep once and it seemed to work fine, so I went ahead and ran Crysis 2 to test. As I was exiting the game after a couple minutes of gameplay I got a sudden BSOD that said something about ntfs.sys. Tried a second time to bring it out of sleep and after a few seconds got:
win32k.sys
PAGE_FAULT_IN_NONPAGED_AREA
*** STOP: 0x00000050

Before updating the BIOS and fixing the RAM settings in the BIOS, I switched out the RAM for the old RAM and everything was fine as before. I'm going to go ahead and test each module one at a time to see what I can rule out.
m
0
l
a c 347 } Memory
June 4, 2012 1:34:02 AM

Well the settings were from the Rampage II GENE manual, and not from the OEM which might have a locked-down BIOS - http://www.asus.com/Desktop/Gaming/Essentio_CG5290#down...

I'm pretty sure it's a RAM issue based on your comment

RE:
"win32k.sys
PAGE_FAULT_IN_NONPAGED_AREA
*** STOP: 0x00000050


Other than RAM that error can have it's origins from a ton of other items, so IMO sort out the presumably bad stick(s). Nice video basically what I do (same as in Windows 7) - http://www.youtube.com/watch?v=aUJW6X6BnTY
m
0
l
a c 84 } Memory
June 4, 2012 2:46:10 AM

try this use two dimms in ao and bo and see if it hangs or bsod. if not switch the dimms and retest. if no issue swapp to the other two slots and retest for bad dimm slot if fine. add one more dimm and run. if fine add the last dimm. if error comes back it could be a issue with the kit and the mb. i would check to see if that kit on the mb qal list.
m
0
l
June 5, 2012 12:25:07 AM

Update: it was a bad module. Just one. Pretty annoying. Already set the RMA in motion. Thanks for the advice guys.
m
0
l
!