Sign in with
Sign up | Sign in
Your question

Compaq laptop sound - no device problem

Last response: in Components
Share
September 14, 2011 12:18:26 PM

I have no sound on my laptop compaq Presario, on the sound devices it says no device. There was someone a year ago that had the same problem and I don't seem to see what fixed it. Any suggestions? Thank you
a b D Laptop
September 14, 2011 3:01:10 PM

Sound driver malfunctioning or not installed, laptop model?
m
0
l
September 14, 2011 3:32:01 PM

yeah its most likely a driver error. try reinstalling it. also check the bios and make sure the sound device is enabled.
m
0
l
Related resources
September 14, 2011 9:01:23 PM

ET900 said:
yeah its most likely a driver error. try reinstalling it. also check the bios and make sure the sound device is enabled.



I have no idea what a bios is or where to go to download the driver again, It says no sound card when I go to sounds on the control panel. Thank you, Eli
m
0
l
September 14, 2011 9:05:21 PM

das_stig said:
Sound driver malfunctioning or not installed, laptop model?



Compac Presario 7000 I think, yes it is a laptop. Please help! Thank you, Eli
m
0
l
September 14, 2011 10:56:15 PM

As said above your sound driver probably got knocked out by something. Go to compaq's website, search for the model number of your laptop, there should be a page in the support section that has driver downloads for all your system's devices. Just download and install the latest sound driver.

If that fails, you will have to go into your BIOS. To get there, when you turn on your computer you should see a screen that will tell you to press Delete, F1, F2 or something like that to enter setup. Hit the appropriate key to enter the BIOS. You will have to search through the menu screens to find where it says sound device, and see if it detects a device or not. If no sound device is selected, try to select one. Failing that you can try resetting to setup defaults, that may also reenable your sound if the device got disabled in the BIOS.

If none of the above work, that probably means the onboard sound is dead, and you will have to see about getting the laptop repaired.
m
0
l
!