Sign in with
Sign up | Sign in
Your question

6870 Standard VGA Problem

Last response: in Graphics & Displays
Share
April 6, 2011 9:01:51 PM

Hello, I've bought in the beginning of the year a 6870 and it has worked fine till yesterday. I was playing Dragon Age II for about two hours when suddenly I started having problems with peformance, something I had never experienced. The game started to work like an online video when you watch it with a slow internet connection; it froze for about 3 seconds and then it worked normally for 5 seconds, then it froze and repeated again. So I got pissed off, saved and exited the game, then normally restarted the computer, without making any modification. When it restarted, it was with a different resolution, when I tried to changed it back to the one I normally use (1920 x 1080 - the highest), I couldn't find it, and the max res was 1920 x 1400 or something like that, one that my monitor couldn't support.

I checked MSI Afterburner and it recognized my video card as Standard VGA Graphics Adapter. I thought the problem was with drivers, so I downloaded and installed Cataclyst 11.3. Still the same problem and I can't play any 3D games. I opened my computer and checked the VGA and its cables, the fan was working and the cables were in their places. I removed the card and installed it again, still the same problem. I only have one PCI-E slot, so I can't test it on another one.

I didn't try yet to restore my system to a previous date, because a lot of programs will be excluded. I don't wanna do this, just if I have no other options. Could anyone help with this?
April 6, 2011 9:22:26 PM

Ah, two important things too:
- My motherboard is a Asrock 780GMH
- My video card was overclocked @920 Mhz with Afterburner. Temperature was below 70.
m
0
l
April 6, 2011 9:33:30 PM

Also, CCC display a message when started:
"The Cataclyst Control Center is not supported by the driver version of your enabled graphics adapter. Please update your AMD graphics driver, or enable your AMD adapter using the Displays Manager."

The Device Manager also identifies the video card as "Standard VGA Graphics Adapter". Disabling or enabling doesn't resolve the problem.

m
0
l
April 7, 2011 4:35:33 PM

Thanks for all the help, but I managed to fix the problem myself. Had to restore the PC to a previous date.
m
0
l
!