Can't overclock 3960x on rampage iv extreme

hey there. I'm having trouble overclocking this i7 3960x on the asus rampage iv extreme motherboard. i tried just loading the small overclock profiles and even the cpu level up thing. whenevere i overclock even the smallest amount the display turns off. when i overclock from the bios the computer shuts off then restarts on it's own but the display never comes on and the computer eventually shuts down and turns itself on again. I have also tried manually overclocking by adjusting the frequency and voltage as i usually do but that didn't work either.

any ideas?

Thank you


this is what's in my computer

Asus rampage iv extreme
i7 3960x
OCZ 1250 W psu
geforce gtx 690
g skill 2400 mhz 32GB 4x8
ocz agility 3 ssd 240 GB
corsair h100 liquid cooling
8 answers Last reply
More about overclock 3960x rampage extreme
  1. Welcome to Tom's Forum! :)

    OC what?? CPU, RAM or GPU??
  2. I was wondering does the computer run stable at stock settings?
    I think your referring to OC'ing the CPU right? That's what this means, "hey there. I'm having trouble overclocking this i7 3960x on the asus rampage iv extreme motherboard".

    You have a lot of RAM on that puppy did you check it with "Memtest', a bad stick of ram will do that. Temps OK? Power supply is adequate ?
  3. Intels new CPUs have to be multiplyer overclocked.
    Overclocing the old FSB way will not work.
    Look at the stickie posts in the overclocking forum.
  4. You can OC the SB-E locked or not using the CPU Strap, but never the BCLK. Unlike the SB/LGA 1155 with a single clock the SB-E/LGA 2011 offers (2) clocks: BCLK for the PCIe, SATA, etc (leave at 100MHz) and CPU Strap which is fine on most MOBO's up to 133MHz and on some 'maybe' 160MHz.

    However, as @Rick_Criswell pointed-out both the i7-3930K and i7-3960X have unlocked CPU Multipliers and that's what you need to adjust along with a few other BIOS settings: vCore, CPU Multiplier, LLC, Phase control and a few others and at various levels depending on the target OC.
  5. hey thanks for the feedback. sorry i wasn't clear. it is the processor i'm trying to overclock. it runs fine at stock settings. my psu is 1250 watts ocz 80 plus gold. i tried using the rampage boards pre set overclok profiles. there is normal o.c., gamer o.c. and extreme o.c. any setting causes this problem. but as long as i leave everything default it runs. i even adjusted to multiplier and voltage myself but got same problem.
  6. I've got some idea here - http://valid.canardpc.com/show_oc.php?id=2261309

    Q - What OC are you trying to obtain? You can try the ASUS AI Suite II and let it run, typically you get a 4.4GHz OC using it or manually 5GHz but with a vCore that I don't recommend; keep the vCore <1.45v.

    IF using ASUS AI Suite II then don't manually tweak the BIOS.

    Q - What manual settings have you tried?
  7. i tried asus ai suite II. as soon as i made the slightest adjustment, my display turned off. the computer stayed on for about 5 mins, powered down, then powered itself back on right away. when it turned back on i still had no display. i had to press the reset cmos button on the mobo to be able to get back to bios or windows. I tried adjusting the bclk and vcore, and i tried adjusting the max frequency for all cores i think.

    it's tough cuz it's my friends computer that i built for him so i have no access to it right now. he is just running stock settings. gonna try to get over to try more things this weekend.
Ask a new question

Read More

Motherboards Overclocking Rampage