Closed Solved

Sabertooth 990FX - Can't Enter BIOS

When I boot up the computer it goes through the normal screens, but there's no "Press [key]" to enter BIOS on any of the screens. I tried F1, F2, F10, and two full keyboard swipes on the American Megatrends boot screen. I'm pretty sure that was where a key was supposed to be pressed to enter BIOS. I used to be able to enter BIOS, but I have no clue when I stopped being able to since I haven't entered it in months. I wonder if installing a SSD a few months back had anything to do with it. I'd like to update my firmware and doing it through the BIOS is the easiest way and I'd like to access BIOS in the future, of course. Any help would be appreciated. Thank you.

Specs:
AMD FX-4100 (3.61GHz)
Manufacturer: ASUSTek Computer Inc.
Model: Sabertooth 990FX
8gb DDR3 @1600
AMD Radeon HD 6950
Chipset: AMD
BIOS:
American Megatrends Inc.
Version: 0901

-Aaron
7 answers Last reply Best Answer
More about sabertooth 990fx enter bios
  1. Best answer
    del(ete) key is usually the command to get into BIOS!
  2. ... and tap the DEL key every second or so while it's booting. Sometimes you have to catch it at just the right time.
  3. I have that board and the command works on the 2nd BIOS screen after the jmicron splash.
  4. The Delete key was it. Thanks! I updated my BIOS to 1208.
  5. Great.glad you have it done.
  6. Best answer selected by vindictivegnome.
  7. This topic has been closed by Nikorr
Ask a new question

Read More

Asus BIOS Computer Boot Motherboards