Sign in with
Sign up | Sign in
Your question

Troubleshooting my systems current issues - WIP

Last response: in Systems
Share
June 21, 2011 4:25:57 PM

Hi everyone,

I am new to the Tomshardware forums, well at least as a registered user. I have a long post here below about my current PC which most of the components are no more then 2.5 years old. I appreciate your time to look over my details and any advice and help that can be can be provided. If you need any further information please ask.

I have had some experience in troubleshooting hardware issues as described below. I am familiar with PCs, I install my own upgrades (RAM, storage, video cards etc.) and have never had to deal with any major errors besides software and viruses.

Here's some info about my system from Windows System Information:


OS Name Microsoft Windows 7 Ultimate
Version 6.1.7600 Build 7600
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name BAZERK-PC
System Manufacturer MICRO-STAR INTERNATIONAL CO.,LTD
System Model MS-7357
System Type X86-based PC
Processor Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz, 3003 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. V1.3, 8/07/2008
SMBIOS Version 2.5
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale Australia
Hardware Abstraction Layer Version = "6.1.7600.16385"
User Name bazerk-PC\bazerk
Time Zone E. Australia Standard Time
Installed Physical Memory (RAM) 4.00 GB
Total Physical Memory 3.25 GB
Available Physical Memory 1.70 GB
Total Virtual Memory 6.49 GB
Available Virtual Memory 4.64 GB
Page File Space 3.25 GB
Page File C:\pagefile.sys


So where to begin. My current build is about 2.5 years old. The previous systems CPU bit the dust, I had to take to a shop it was beyond my scope (Chinese technician actually said "I think cockroaches have been urinating on your PC, I can see arcs from electricity"!). He built me a nice and cheap PC at the time and it worked well. I put a new video card in HD4850 and upgraded RAM to Kingston HyperX DD2 not long after.

Anyway, jump to 4 weeks ago. A friend of mine bought a new computer and had Windows 7 Ultimate thrown into the package and already owned a copy which he offered to me. I was happy with my XP build but decided to give it a go, I had used my sisters computer a few times and liked some of the features in Win7.

After installing everything was sweet and I was very happy with the performance on my aging 160gb Seagate drive. I was especially happy because I had a DirectX 10 card and could now look at playing some updated games. 2 weeks later during the "Windows is Starting" sequence with the animated Windows logo, it froze during this process of loading Windows.

After a hard restart using the restart button on my PC case, it would prompt me for error recovery/hard disc check. I did this several times and it found no errors. The funny thing was after an initial boot, and it prompting me to complete the this check, I would choose "Start Windows normally" and it would boot fine right into my new Windows 7 build. I was getting beep codes at boot, 1 long 3 short - but when I say "long" it's not a long sound, just a beep, pause, beep beep beep. Apparently that's a memory failure error. (Later on I did a MEMTEST86+ session explained below.)

I wiped the drive and reinstalled Windows XP because I wasn't in the mood for mucking around if it was an OS issue. The same boot problem occurred, froze upon loading Windows, hard restart, start Windows normally and it did so.

I had no mission critical bits to do so I formatted drive and installed Windows 7 again. Same symptoms and frozen boot sequence, restart, "Start Windows normally" and it would start up. I was due for a new drive and figured these signs were a failing hard drive.

I purchased a Western Digital drive, WD20EARS, a 2TB drive, it was on special (I think I found out why). I installed Windows 7 and was running great for a few days and then BAM, same boot issues as described above. The guy I bought the drive from said maybe my SATA cables were the problem, he said using genuine cables on machines that had boot issues fixed the problem - I haven't bought new cables but decided to troubleshoot the cable issue by plugging into old drive and swapping SATA ports alongside with my ASUS DVD drive (swapping between the two).

At this stage when trying to identify if my SATA cables were an issue I couldn't get the new WD20EARS drive to boot AT ALL. BIOS would recognise but then I got an error that I can't remember! I wrote it down but can't find the piece of paper, something along the lines of "Primaster failure drive etc. etc." After several reboots and trying to get the drive the drive to boot, I pulled my computer up on my desk and reseated RAM, replugged every cable, just in case and when I booted I heard it - "click click click click" - dammit.

So I think my new drive is done for - I was getting beep codes, 3 of them - to do with memory I read, not storage - according to bioscentral.com for my AMI Bios 1.3. I completed a 12 hour session of MEMTEST86+ which gave no errors.

I removed my video card, removed old DVD and CD (I never use) and reseated RAM again and I only go 3 beeps "memory parity error" - I put it all back in bar the old DVD and CD drive and now I get 2 beeps :(  Seriously this has got me stuffed.

I ran Seagate diags on the working drive, no errors found. I didn't get an opportunity to run any WD software on the dud drive because it died before I had an opportunity.

I am totally lost here - I can't afford a new PC right now and my "PC funny bone" is tickling towards to the idea that my Mainboard might be stuffed.

I can boot up use my PC, but I don't feel it's health is very stable - it requires a boot to the "frozen" point in loading Windows 7, then hard restart, Start Windows normally and then I can boot up and load Windows.

I haven't experienced this before and I am WAY out of touch with this stuff. I used to build and rebuild hardware, and troubleshoot all and any software/OS issues - but that was more than 7 years ago. I am VERY rusty and would appreciate any help and advice.

Thanks for reading this far into my post :D  I am going to try more tests and hardware configs in the mean time. A work in progress indeed.

June 21, 2011 4:43:52 PM

IMO you've ruled out OS issues. Memtest has cleared your RAM but you are still getting "bad memory" beeps. This makes me think memory controller. If I'm not mistaken, for your system, the mem controller is on your mainboard.

Did you try clearing your CMOS? There may be a funky BIOS setting or something.

Check your boot order and make there's nothing fishy going on with it.

Was your "old" drive an IDE?
June 22, 2011 12:37:07 AM

Hi there Eight,

OK, as I said I am pretty rusty with this stuff! Probably jumped in a bit deep. I'll step back a bit and look at the OS as possible culprit.

Alrighty - I will check out my controller, clear CMOS and check my BIOS settings. I haven't changed the BIOS settings, other than boot order in the past. I haven't updated it either, maybe I should try that.

What does the memory controller look like? It's the actual slots for the RAM is it? Upon my quick read up it's the thing that allows information to be written back and forth from RAM to mainboard/computer etc.? Is that something I can change?

Both drives "old" and "new" are SATA - I was advised to buy new cables by the reseller of my failed WD20EARS (Western Digital 2TB), to purchase genuine intel SATA controllers cables not 3rd party and swap them to see if that changed anything, but that has nothing to do with the memory controller right?


One odd thing... my external hard drive boots hard when I power up. I have unplugged this at the beginning of all this fiasco and it did boot up without issue, but the problem just ended up happening again after subsequent boots.

Thanks Eight, I'll post back - appreciate any more tips or advice from other users.
Related resources
June 22, 2011 12:50:27 AM

The memory controller is part of your northbridge which is probably covered by a heatsink. :)  It's part of your motherboard. You cannot replace it or repair it. Sorry, I should have been more clear about that.

I think we can maybe rule out any other problems before considering replacing the motherboard. The best way to go about that, I think, is to start with empty HDDs rather than trying to repair possibly-corrupt installations. It's probably best to keep the system as simple as possible as you do this (so only one HDD at a time).

1) Can you identify your motherboard manufacturer and model, please?

2) If you unplug every drive from your computer, leaving only the CPU, RAM, video card (unless you have onboard video), does it POST or do you get the bad memory beep?

3) When you are wiping and formatting drives, how are you going about that? My concern is that you are only deleting certain partitions which may be leaving boot sectors/records.

4) What do you mean by "my external hard drive boots hard when I power up"? Does your system boot normally without the external?
June 22, 2011 1:09:24 AM

Ok I think I've located my memory controller - what do I do? Remove heatsink, unplug, put back in etc.?

Eessh, I will have to do all of this tomorrow - I'm off to track, and if I win I'll have someone else fix this computer! Haha.

1 - MSI G33M 7357 - micro atx

2 - I'll try this tomorrow

3 - I use FDISK, or whatever it's called, the Windows based one - I clear partitions and then format drives with that utility, nothing else

4 - external hard drive starts up at boot, at the post checks - I turned off OEM splash screen so I could see what messages it was showing, one of them was "checking/scanning external drives" or something along those lines, I'll get exact expression - it comes up to fast!

Thanks Eight for your attention - I'll post back in about 24 hours with updates based on advice from your two posts.
June 22, 2011 1:35:35 AM

eepandook said:
Ok I think I've located my memory controller - what do I do? Remove heatsink, unplug, put back in etc.?


No! :)  You can't fix or replace it. If the memory controller is faulty, you'll need to replace the motherboard. I mostly wanted to point out that memtest will *only* test your RAM. It isn't very hard on the mem controller at all. So, if you are getting "bad memory" beeps and your RAM is good, it's your mem controller causing the problem.
!