Sign in with
Sign up | Sign in
Your question
Closed

Why does windows 7 ask for a password on network

Last response: in Wireless Networking
Share
December 12, 2010 1:22:26 PM

I have 3 computers on a home network that could share files/folders in the begining. Now the windows 7 PC asks for a password if you try to access it from the XP pc and vice versa. the xp computer and the win 98 computer shares files in both directions perfectly! what happened to the win 7 machine?
Anonymous
a b $ Windows 7
December 13, 2010 10:27:27 AM

Annoying isn't it ?
As I recall I quit using a password on my Win7 machine in order to eliminate this "problem". Networked Win7 machines aren't always very good at being detected from XP machines and vice versa.

To be fair, with Win7 MS have tried to introduce sort of scaled back security for home machines, but networking is still designed for business when the vast majority of users now are at home, accessing their own machines and security really isn't the big issue that Windows makes it.
Score
0
Related resources
December 13, 2010 2:19:44 PM

SR-71 Blackbird said:
http://www.purenetworks.com/product/pro.php

TRY THIS!


I have Network Magic version 5.5.9195.0 that I bought this past January when I had a cisco 320 router. That router slowed my connections down to a crawl in about a week. I saw on line where they were having trouble with that router and I took it back and got this Belkin N+ wireless. Anyhow, Network Magic has not helped me with this problem. When I click on "trouble sharing folders" it goes through it's test and says the folder in question should be accessible. The windows 7 PC has not been perfect from the start. Before this, some times I would have to reboot it to see it on the newwork. I have about an inch of paper I have printed out from things I find on google and none have helped so far. Thanks for the link but everyone keep trying for me please.
Score
0
a b $ Windows 7
December 14, 2010 5:40:35 AM


In Control Panel>Network and Sharing Centre, buried among the options and below the screen so you have to scroll down, there is the option to remove the need for passwords in W7 networking. When I say "networking", I don't mean using the Homegroup - leave that along and go for conventional networking.

Before W7 can be an acceptable package for networking, they wil need to ease these restrictions - or make them easier to overcome - and I hope this comes out in SP1.

Score
0
December 14, 2010 8:33:35 AM

Saga Lout said:

In Control Panel>Network and Sharing Centre, buried among the options and below the screen so you have to scroll down, there is the option to remove the need for passwords in W7 networking. When I say "networking", I don't mean using the Homegroup - leave that along and go for conventional networking.

Before W7 can be an acceptable package for networking, they wil need to ease these restrictions - or make them easier to overcome - and I hope this comes out in SP1.


Not sure what you mean about not using Homegroup and go for conventional networking. What group do I use?
I have checked the box to "not use password" on there
Score
0

Best solution

a b $ Windows 7
December 14, 2010 11:47:43 AM

dbarnho595 said:
Not sure what you mean about not using Homegroup and go for conventional networking. What group do I use?
I have checked the box to "not use password" on there



Windows 7 offers networking through a Homegroup but most people find that restrictive. Below that in the left hand pane is Networking and if you set your network up in there, having ticked for no password, you should find things run better.

However, I've noticed that the W7 Computer Browser Service doesn't scan as frequently as it did in XP so you may need to wait a little longer for other computers to show in the Workgroup. Don't be in too much of a rush to assume your settings are wrong and start changing them - give it twenty minutes, at least.

Share
December 14, 2010 2:09:54 PM

Saga Lout said:

Windows 7 offers networking through a Homegroup but most people find that restrictive. Below that in the left hand pane is Networking and if you set your network up in there, having ticked for no password, you should find things run better.

However, I've noticed that the W7 Computer Browser Service doesn't scan as frequently as it did in XP so you may need to wait a little longer for other computers to show in the Workgroup. Don't be in too much of a rush to assume your settings are wrong and start changing them - give it twenty minutes, at least.

OK, thanks. I'll try that out and let you know how I made out.
Score
0
December 21, 2010 1:52:37 PM

Best answer selected by dbarnho595.
Score
0
December 21, 2010 1:58:28 PM

Had to select a "Best Answer" but problem still here. The router has a USB slot that I have a USB thumb drive pluged into and all PC's can access that. Make transfer of files to and from that. Will post here when I find a solution.
Score
0
a b $ Windows 7
December 21, 2010 5:56:43 PM


You didn't "have to" but thanks for doing so. However, it's much less fun if the problem remains.

Is the W7 machine still unable to network properly even with the suggestions I made in place?

Score
0
August 2, 2011 2:12:56 PM

I'm sorry if this question is redundant but I don't see an answer to my question.
I have a small business network.
1 Win7 desktop is wired to my wireless router.
1 Win7 desktop is wireless.
1 Win Vista laptop is wireless.
2 WinXP laptops are wireless.
My 2 WinXPs cannot see the Win7 wired desktop. This is crucial because that is the shared drive.
Are there settings that I need to change on the WinXPs in order to access the shared Win7? The password function is turned off on the shared Win7.
Score
0
a b $ Windows 7
August 2, 2011 6:05:29 PM


Hello and welcome to Tom's Hardware Forums.

It might be better to start your own thread in case someone accuses you of necro-posting - bringing back the dead.

However, some silly questions first - are they all in the same Workgroup? Has Windows 7 Homegroup been eliminated. Can the W7 system "see" the others?


Score
0
August 2, 2011 6:44:56 PM

I'm sorry if I offended anyone by posting here. Since I feel that my question is related to the post, I thought best to ask here.

All listed PCs are on the network/workgroup. When I created the network I renamed it and changed it on all listed PCs.
I don't know what you mean by eliminating the Win 7 Homegroup.
The wired/shared Win 7 can see all other PCs. For that matter all PCs can see each other.
Again, my Win Vista and 2nd Win 7 can access the shared Win 7 but my 2 Win XP PCs cannot access the wired/shared Win 7 PC. When I try to access from either Win XP PC I am prompted for a password. Password is off on the shared Win 7.
Score
0
a b $ Windows 7
August 3, 2011 5:34:31 AM



When you say password protetion is offf on the W7 system, does that include the bit at the bottom of the page in Network and Sharing Centre where you take off the requirement for all other systems to have passwords?

My comment about eliminating Homegroup was because it's better to stick with conventional networking in networks of mixed systems. Homegroup may have a place in a future where every system is W7 or 8 but not where XP or even 2000 are mixed in.



Score
0
August 3, 2011 2:09:31 PM

Yes to your first question.

If you answered my original question, I still don't understand. Why am I prompted on both my Win XP systems for passwords to access the wired/shared Win 7 system?
Score
0
a b $ Windows 7
August 3, 2011 6:07:20 PM



If the Windows 7 system folders are set to be shared, and no password is required to access those folders in their own system, XP doesn't need a password either. Try remaking the shares in XP by running the Network Setup Wizard once more.

Score
0
August 3, 2011 6:10:50 PM

I've already done that, more than once.
Score
0
January 24, 2012 10:14:07 AM

Quote:
Annoying isn't it ?
As I recall I quit using a password on my Win7 machine in order to eliminate this "problem". Networked Win7 machines aren't always very good at being detected from XP machines and vice versa.

To be fair, with Win7 MS have tried to introduce sort of scaled back security for home machines, but networking is still designed for business when the vast majority of users now are at home, accessing their own machines and security really isn't the big issue that Windows makes it.



All you have to do is go to your administrator name in control panel, which is under system users and see what your administrator name is. Type that in for the name and leave the password blank and his enter or ok and it will connect.
Score
0
January 29, 2012 3:09:17 AM

your answers are very vague. you are not talking to yourself
Score
0
January 9, 2013 5:45:31 AM

Quote:
Annoying isn't it ?
As I recall I quit using a password on my Win7 machine in order to eliminate this "problem". Networked Win7 machines aren't always very good at being detected from XP machines and vice versa.

To be fair, with Win7 MS have tried to introduce sort of scaled back security for home machines, but networking is still designed for business when the vast majority of users now are at home, accessing their own machines and security really isn't the big issue that Windows makes it.


(Resolve It)I solved this problem when i try to access shared drive from my win7 pc it asks for username and password but does not accept the credentials to work around it on my win7 pc go to control panel\administrative tools\Local security policy\Local policy\security options in right side window go to network security:Lan Manager Authentication and double click, from drown menu select first option send LM and NTLM apply. This worked 100% in my network .
Score
0
January 30, 2013 3:46:35 PM

dbarnho595 said:
I have 3 computers on a home network that could share files/folders in the begining. Now the windows 7 PC asks for a password if you try to access it from the XP pc and vice versa. the xp computer and the win 98 computer shares files in both directions perfectly! what happened to the win 7 machine?






BELOW ARE A LIST OF “FIXES” I FOUND FOR THIS ISSUE. TRIED THEM ALL….. THIS IS THE ONLY ONE THAT WORKED
“I finally gave in and just created an account on the XP machine, with the same name as my main Admin account on the Win 7 machine. I gave it admin rights (on the XPmachine). Now the Win 7 machine connects with no issues at all.”

NON-SUCCESSFUL RESOLUTIONS….(FORGIVE THE LACK OF FORMATTING)
1. Go to Control Panel | Performance and Maintenance | Administrative Tools | Local Security Policy.
2. Expand Local Policies | Security Options.
3. Double-click Accounts: Limit local account use of blank passwords to console login only, which is enabled by default. Disable this option and click OK.

ON WIN 7 MACHINE - right clicking on any folder (you have access to and/or you are an Admin) and clicking the Sharing tab and then go down to "Network Sharing And Security" area and click on the ...if you understand..." it will enable sharing. Now go back to windows 7 and when you click on the computer in question it should let you gain access.

I had similar issue, I had a windows xp share, and a new installed windows 7 pro. I try access the xp share from win 7 but it was not taking the password. i found out that it was the date in the new win 7 that was preventing it to accept the login. it was set to 1/1/2001.

http://www.howtogeek.com/howto/windows-7/share-files-an...

Finally I notices the 2 PCs running Windows 2000 that had the 'wrong' time on them were working (the time was 1 hour behind the Windows 7 PC). The PC running Windows 2000 that DID NOT WORK had the time that matched the time on the Windows 7 PC. I reset the PC (Windows 2000) to 1 hour behind the Windows 7 PC and now it connectes. I tried several different times any only when set about 1 hour behind the Windows 7 PC does it work.

I had this same issue and it was due to simple file sharing being enabled on the XP computer. Once I went into windows explorer-tools-folder options-views and unchecked it, I could access shares, both printers and folders. You would think with the amount of people experiencing this there would be better information.

http://social.technet.microsoft.com/Forums/en-US/itprov...

on the XP machine I went into the Local Security Policy Settings" section to see if there were settings that pertained to this problem. Start>Settings>Control Panel>Administrative Tools>Local Security Policy. I right clicked on Network Access: Sharing and security model for local accounts then selected Properties. I selected Classic - local users authenticate as themselves. Then clicked OK and closed all windows.

In Control_Panel->Administration_Tools->Local_Security_Setting->Local_Policies->Security_Options there is a parameter "Network access: Sharing and security model for local accounts" with two options. Make sure it is set to "Classic: local users authenticate as themselves."

We use an XP machine for a server and have a mixture of Windows 7 and Windows XP machines in the office. I came in this morning and all of the Windows 7 machines were asking for a password to access the server. The XP machines were fine. I tried everything on this thread and elsewhere trying to fix the problem. I could ping the server but could not access it through network discovery. I was able to map drives using an IP address for the server on the Windows 7 machines and while it did not fix the problem it did provide a work around for it. All Windows 7 machines are working fine now using mapped drives with the server IP as an address. For example \\192.168.0.75\c is the entry I used for the mapped drive. Server address and then "c" being the shared folder. No password was required.


Score
0
!