Closed Solved

Black screen after bios update 1.7 plz help

just finished a new build and after downloading and updating all i need I internet flashed my bios using the UEIF but after it was done downloading and said success it had to reboot and that was the last time i i saw anything on my screen.

My pc turns on fine but nothing on screen shows up and my mouse doesn't light up (so its not connected) only my speakers do light up.

Asrock z77 extreme 4
what should i do. plz help.
7 answers Last reply Best Answer
More about black screen bios update help
  1. All you can do now is reset the bios; unplug the power supply and move the cmos jumper over to the "clear" position; after one minute return the jumper to it's original position marked "run" in most motherboard manuals. Most cmos jumpers have 3 pins; those with two pins may simply require you to remove the jumper for one minute, then replace. And next time, don't flash the bios unless you can't get a cpu upgrade to post; flashing always involves a little risk. Some of the newer boards have the bios chip soldered on so you can't replace it.
  2. how do i reset the bios on asrock z77 extreme 4? also the board only has a clr Cmos button that i can press so its not a switch. i have tried pressing it and all it does is restart the pc when its on. should th epc pc be off when i press it or it doesnt matter?


    Edit: i just tried holding the Cmos button for 60 sec w/ PSU unplugged and nothing so i tried it w/ pc on fo r60 sec and still nothing. w/ 1 memory stick placed furthest form CPU
  3. Best answer
    If you can't get a post screen, request an rma from asrock. If asrock doesn't give you a warranty in your country, then you will have to rely on your vender for replacement. You don't have to go into detail about why it doesn't work, simply state "the board won't post". That is all they need to know. In the usa, it takes 2-3 weeks to get a replacement board. Many folks go ahead and order a new one and sell the replacement board when it arrives.
  4. Why are people so quick to update their BIOS. Unless something is broken and doesnt work cause you are missing a BIOS update, dont mess with it.
  5. if the mb not dead if you look under the owners guild they have what called a fast flash that built into the bios. try putting your flash rom on a fat32 formatted usb stick and when you power on your pc hit the f6 key if that wont work hit f2.
  6. Best answer selected by yahiax.
  7. This topic has been closed by Nikorr
Ask a new question

Read More

Chipsets BIOS New Build Motherboards