Sign in with
Sign up | Sign in
Your question

Faulty Card or PSU? Nvidia GeForce GTX 460

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
April 10, 2011 9:38:58 PM

Hi there, earlier my pc died on me, it turned off and when I tried to turn it back on, it wouldn't. I took the side off the case unplugged everything, reset cmos then plugged it all back in. Still the same problem. The green light does appear on the motherboard. When I unplug the two 6 pin connectors from the card the system will power up but not display to the screen, but when they're connected it wont even turn on, the CPU, PSU and GPU fans do seem to try and spin for a brief second the first time i try to power on but after that nothing. I've tried using a different graphics card in my rig and that works fine. (GeForce 210)

So what i'm wondering is has the PSU just messed up so it can't power the graphics card, or has my card died.

My system is


i5 760
Asus p7p55 lx
4gb crosair 1600mhz
Gtx 460 - 768mb point or view
Atrix 720W


Any help would be greatly appriciated, thanks in advance

Ryan
April 21, 2011 8:18:38 AM

Quote:
Hi there, earlier my pc died on me, it turned off and when I tried to turn it back on, it wouldn't. I took the side off the case unplugged everything, reset cmos then plugged it all back in. Still the same problem. The green light does appear on the motherboard. When I unplug the two 6 pin connectors from the card the system will power up but not display to the screen, but when they're connected it wont even turn on, the CPU, PSU and GPU fans do seem to try and spin for a brief second the first time i try to power on but after that nothing. I've tried using a different graphics card in my rig and that works fine. (GeForce 210)

So what i'm wondering is has the PSU just messed up so it can't power the graphics card, or has my card died.

My system is


i5 760
Asus p7p55 lx
4gb crosair 1600mhz
Gtx 460 - 768mb point or view
Atrix 720W


Any help would be greatly appriciated, thanks in advance

Ryan


When your computer crashed did it give you any information such as a BSOD message or did it just shut down? Also, could you give me the amperage on the 12v rails for your PSU or at least a more detailed description? Any additional details would be helpful.
!