Sign in with
Sign up | Sign in
Your question

Monitor losing signal? Need help!

Last response: in Graphics & Displays
Share
April 10, 2011 11:38:23 PM

Hey all,

So 2 days ago I downloaded Metro 2033 from Steam, and when I loaded it up, got an error message saying that I'm missing NVIDA Physx drivers (My graphics card is a Radeon 6850). So I download the NVIDIA Physx System Software Package from their website and start playing Metro and the game runs fine for about an hour, then something happened that's never happened to me before. My monitor went blank, flashed "No Signal," and stayed that way despite the fact that my PC was still powered up and apparently running. I couldn't do anything except a hard reset.

Now, 2 days later, every time I load up a game my monitor loses signal after anywhere from 5-30 minutes of gaming. Sure seems like a driver issue, given the way this problem came about, right? Well, I ran Driver Sweeper to clean out all the NVIDIA drivers from my system (ran it twice), downloaded the latest AMD Catalyst package, deleted Metro 2033, and STILL my monitor is losing connection, but only when gaming! I've been gaming daily on this machine and everything has been running fine until I downloaded Metro 2033 and Physx. Any suggestions?

System Specs:

Windows 7 Home Premium 64bit
Intel Core 2 Quad q9300 @ 2.5ghz
Gigabyte GA-P43T-ES3G Mobo
Radeon HD6850 (minimally OC'd w/ Afterburner)
Samsung SyncMaster P2570HD HDTVmonitor
8 GB DDR3 RAM
680 watt Sunbeam PSU

More about : monitor losing signal

a b C Monitor
April 11, 2011 12:33:28 AM

Physx might be causing conflicts with your AMD drivers. I'm not sure how it works with the cpu-only physx or whatever but try running metro without.
m
0
l
April 11, 2011 1:02:06 AM

Well, yeah I know. That's why I deleted it. :/ 
m
0
l
!