Sign in with
Sign up | Sign in
Your question

One USB 3.0 port not working

Last response: in Systems
Share
June 25, 2011 4:46:09 AM

Hi guys,

I am new to this forum and wanted to know why one of my front usb 3.0 ports of my HAF X case is not detecting anything on windows when I plug something into it, however the other one does. I have the usb 3.0 extension cables routed out of the case and plugged into the included dock that was included with the motherboard. Here are my specs:

CoolerMaster HAF X Full Tower Case
ASUS P8Z68-V Pro Motherboard
Corsair Vengeance Blue 2 x 4GB RAM @ 1600mhz
OCZ Vertex 3 SSD
Samsung Spinpoint F3 1TB HDD
MSI GTX 570 Twin Frozr III
Intel Core i7 2600k OC'd to 4.3Ghz
CoolerMaster Hyper 212+ CPU Cooler
Windows 7 Ultimate 64 Bit
LITE-ON iHAS424-98 DVD Burner Drive
OCZ ModXStream Pro 700w Modular PSU

Any suggestions on how to fix this issue?

EDIT: Also, the USB 3.0 port seems to work if i connect one of the extension cables directly to a port on the motherboard's I/O

More about : usb port working

June 25, 2011 7:19:51 PM

Bump

Any help please?
m
0
l
October 2, 2011 7:08:31 PM

I have the same problem with my front USB 3.0 port. Only one recognizes devices even though both powers them properly.

Did you find any solution?
m
0
l
February 25, 2013 7:34:16 AM

I have the exact same problem, I bought a NZXT Switch 810 case, it comes with Front Panel 2x 3.0 USB slots, one of them does not work. I have built in USB 3.0 on back panel... and the Front Panels come with a blue connector but like I said only one out of two work.

NZXT Switch 810 Case
MSI Z77A GD80 Mobo
Intel i7-3770k

Anything else does not seem relevant for this issue! I truly hope its not faulty hardware, is there a possible driver/software issue here?
m
0
l
!