Sign in with
Sign up | Sign in
Your question
Closed

4GB Ram becomes 1.8 GB ramdisk?

Last response: in Memory
Share
June 12, 2012 7:08:31 AM

I seem to be losing allot of space here! I tried 2 free Ramdisk programs, and neither is able to use over 2GB of my unallocated Ram.

I have 2x4GB Mushkin 1600 Ram sticks, and 3.4 is used on my x32bit OS, while the other is free for whatever. SO I decided to make a Ramdisk. I tried Disk and that program only used 2.3, was unable to increase. I then used ImDisk, now this program was more experienced, and I could use the (-s memory size) from either ram.

Example:
(imdisk -a -s -500M -m Y: -p "/fs:ntfs /q /y") *Notice the (-)* This creates a ramdisk on the usable ram, bad idea..

(imdisk -a -s 1900M -m X: -p "/fs:ntfs /q /y") I can make on the unallocated ram. THE PROBLEM! Only using 2GB of 4GB ram!
I have tried going up in memory with this example, but unable to go past 1.9 before imdisk responds with the error message, "Unable to create these parameters do not exist".

Further note: I have had to change the 1.9 to 1.8 for some reason.. losing ram somehow! At first I had 1.8 of 1.9 usable (creating 1.85G). Now I have 1.7 of 1.8 Usable. BAH!

P.S. Intel DH61BE Loaded new drivers, then had to re-install windows. Now I change ram timings to 7-7-7, yet windows 8 either does not allow this, or my bios is ignoring me. CPU-Z shows timings at 9-9-9.

More about : 4gb ram ramdisk

a c 146 } Memory
June 13, 2012 5:46:36 AM

Do u see in the bios both sticks?
Score
0
June 13, 2012 2:11:15 PM

Bios only has 1 entry for my Memory, though I'm guessing this is cause they are identical and in dual channel. This Intel board only has 2 slots for ram. My bios is currently set to 7-7-7, yet CPU-Z shows 9-9-9
Score
0
Related resources
a c 347 } Memory
June 13, 2012 3:02:08 PM

RamDisk 11 - http://www.superspeed.com/desktop/ramdisk.php ; only one to use - period.

RE: (imdisk -a -s 1900M -m X: -p "/fs:ntfs /q /y" )
1GB = 1024MB, 1900/1024= 1.86GB - NTFS (formatting)
4GB*1024MB/GB = 4096MB

Not having a clue of ImDisk (imdisk -a -s 4096M -m X: -p "/fs:ntfs /q /y" )

imdisk -a -s 4096M -m R: -p "/fs:ntfs /q /y" ; noted others used R (vs X)
Score
0
June 14, 2012 7:41:44 AM

Quote:
RE: (imdisk -a -s 1900M -m X: -p "/fs:ntfs /q /y" )
1GB = 1024MB, 1900/1024= 1.86GB - NTFS (formatting)
4GB*1024MB/GB = 4096MB

Not having a clue of ImDisk (imdisk -a -s 4096M -m X: -p "/fs:ntfs /q /y" )

imdisk -a -s 4096M -m R: -p "/fs:ntfs /q /y" ; noted others used R (vs X)

Thanks for the info, yet I'm still unable to get over 2GB with 8GB ram, or 2x4GB ram from 1 slot. ImDisk is a very reasonable program.. might be the first one I have used, but it has all the tools I want (PageFile at startup, image filing for temp files, qualifying the leftover space from the useable ram). The ONLY problem that I have is not being able to access more than 2GB from the unallocated 4GB stick. Not to mention, I remember my 1900M Ramdisk actually had to be shrunk to 1700 after I deleted/re-made the partition a few times. It seems the program loses memory space from editing the Ramdisk. :hello: 

Quote:
Do u see in the bios both sticks?


Still unable to see ram-timing changes after startup, no matter how many times I change bios timings.
[/quotemsg]
Score
0

Best solution

a c 347 } Memory
June 14, 2012 12:35:29 PM

If the BIOS is losing the CAS Timings then one of (2) possibilities comes to mind: 1. CMOS corruption (bad battery/bad chip) try Clear CMOS, 2. you have some BIOS invasive app installed, often an OC'ing app e.g. ASUS AI Suite that's overwriting the manual BIOS settings.

'Free' isn't so free if it sucks-up a bunch of your time...
Share
June 15, 2012 2:05:05 PM

Reset CMOS from the jumper, and the battery. No changes to timings. Giving-Up
Score
0
June 15, 2012 2:05:33 PM

Best answer selected by alterlvian.
Score
0
a c 146 } Memory
June 15, 2012 2:06:54 PM

This topic has been closed by Nikorr
Score
0
!