Closed Solved

Dr Debug code 53: motherboard or memory?

I'm building a computer with this motherboard and memory:

ASrock Z68 Extreme3 Gen3
Corsair Vengence DDR3 8GB (2X4GB) CMZ8GX3M2A1600C9B

When trying to boot with both sticks in either configuration or a single stick in different slots, it didn't work but gave a code 53 on the Dr Debug display (no useable memory detected). I also tried booting with no memory installed, and still got 53 (even though there is a different code for no memory installed).

I know you're about to say bad motherboard, so here's the twist. Two weeks ago I RMA'd the mobo for a replacement, popped it in, and got the same error.

After the first time I did check for compatibility (http://www.asrock.com/mb/Intel/Z68%20Extreme3%20Gen3/?cat=Memory) to find my memory wasn't explicitly supported. But every resource I can find says mobo.

Now I don't know if I got two bad sticks of memory, or if I somehow broke both of them, or if I got two mobos with the same problem. I still have time to return the memory if I need to; what should I do?
5 answers Last reply Best Answer
More about debug code motherboard memory
  1. Best answer
    I would have to question if the ram is seated all the way in the slot. It's a common mistake, especially if the notches are a tight fit. You may have to return the ram to corsair, or sell it on craigslist and try another brand.
  2. Agreed, try one stick at a time and try it in each of the slots.

    Push hard on it to make sure its all the way in. If the clamps come up that doesn't mean it is in far enough.
  3. You were both right. The memory was a very tight fit indeed. On a closer inspection I saw the clamps weren't all the way closed. I had to lay my tower on its side and really push, thought I was going to crack the mobo but finally got the memory to click all the way in.

    Thanks much!
  4. Best answer selected by zach000.
  5. This topic has been closed by Nikorr
Ask a new question

Read More

Motherboards Debugger Memory