Closed Solved

PCI Simple Controller install fail

Just bought a new rig. Pretty entry level I'd say but really surprised at the performance. However I cannot get the pci simple communications controller to install. I believe its a usb port because my keyboard wont work in one of the rear usb port. I cannot find a solution for this. Did scan for hardware changes tryed to install it via the web and window's update and no go on any of it.

Specs are as follows
gigabite z77 ds3h
i5 3570k ivory bridge
4 gigs of ddr3 1333
nvidia gt 545 1.5 gigs
400 watt psu

Like i said performance wise its great just every time i restart it trys to install the pci com controller and all it does is fail.
8 answers Last reply Best Answer
More about simple controller install fail
  1. Some of those random drivers can be a big PITA to install. I recently got a Z77 myself and had the same sort of difficulty trying to get some of the stuff to recognize.

    Did you use the CD that came with it? Sometimes it doesn't work to just direct the installer to the folder where the drivers are, sometimes you have to actually install the little helper program stuff to get it to work right.

    It could be the USB Extensible Host Controller or perhaps Intel Rapid Response Technology too, if you don't see those things in your device manager.
  2. Or you can have a bios update to see it fixed.
  3. One more problem I'm running into is i get an error that says auto run is not compatible with the version of this software! Guess its one file at a time lol
  4. Best answer
    I don't think a BIOS update is going to accomplish what he wants. I had to do the exact same thing and I just installed the right drivers and it worked.
  5. it missing the network driver...did you install a thrid party wifi card?? if you go under device id it give you a dring if numbers and letters this with a ggole search twlls you the vendor and device that your missing drivers for.also check that you loaded all the usb drivers...the new intel chipset drivers have the intel ones..there may be on the mb cd or web page ones for third party usb chipset.
  6. OK so what i did was install window's 7 on a new hard drive and it all works. May have been a vista issue. Thanks for all your help how ever!
  7. Best answer selected by briansklein.
  8. This topic has been closed by Nikorr
Ask a new question

Read More

Gigabyte Performance Controller PCI Motherboards