Sign-in / Sign-up
Your question
Closed

Crossfire concerns

Tags:
  • Graphics Cards
  • Crossfire
  • Graphics
Last response: in Graphics Cards
April 14, 2011 7:19:33 PM

First, I've checked google for this and not found the answers I'm looking for. Second, I've asked questions along the same lines as this, but I've found ways to band-aide the situation but not found a complete answer.

I'm running a i7-930 system with a Sapphire and a Gigabyte Radeon HD 5850 at 775/1000 in crossfire. When things are running good I'm really pleased.

The issue I am seeing is anytime I a) open an Internet Browser (Chrome, Firefox, and Internet Explorer tried) or b) change any graphics settings, when I open a game that uses crossfire I get a heavy strobe-ligh effect in the game, like one card is barely pushing any performance. One 'fix' to the problem is to disable Catalyst AI, which disables crossfire, so that's a NO-GO; once I re-enable Catalyst AI the issue returns. The only thing that actually resolves the concern is to restart my system.

I've tried (and for anyone who has tried would no this stuff is time intensive):
A) Completely removing all drivers and software related to AMD or NVIDIA, booted into safe mode and sweeped drivers, and booted into normal and installed latest drivers (I've actually tried every 10.x and 11.x driver to no avail
B) Running cards at stock speed (775/1000 is max normal OC in catalyst control center), slightly overclocked, slightly underclocked, mixed clocks all to no avail
C) Tried each card on top with 5 different driver levels in each config (don't remember the numbers, but each was reported as highly stable from multiple sources for crossfire)

I've tried a few other things but I can't recall of the top of my head.

I'm tired of having to restart my computer every time I change any setting or my wife has surfed the internet. I would like to be able to listen to YouTube when gaming or check my email in the middle of a long session.

Any help is greatly appreciated!

More about : crossfire concerns

a c 170 U Graphics card
April 14, 2011 7:29:48 PM

There are some games that will give you texture/graphic glitches when you enable Crossfire(because they don't support it).
What games did you test ?
Score
0
April 14, 2011 7:43:50 PM

Good question: Star Trek Online, Bad Company 2, Star Trek Online, Civilization IV, Dragon Age, and Rome Total War (all the games I currently have installed).

The issue is that when I just restart my computer, or haven't done either of the triggers, there are zero hiccups at all and things look and run great on the above games. I have actually measured the difference between disabled crossfire and with crossfire enabled and there is a significant difference when the cards are being taxed. When the issue occurs it's basically like one card is performing at max, but the other is running at less than max.

It's when I do one of the trigger events do my issues start for all games above. It doesn't matter when I do these things (when playing or when not playing) that's when the problem starts.
Score
0
Related resources
a b U Graphics card
April 14, 2011 8:36:59 PM

drivers are ***, im not going to get into reiterating what I always do but my advice would be to ditch the crossfire for a powerful single card, I did and I havent looked back
Score
0
April 14, 2011 8:49:59 PM

That is definitely the long term plan, but I've made my choice now and there isn't room in my budget to go out and buy a card with the power I want. If I had people who would pay enough for each card, I would be highly tempted to do just as you suggest.

Unfortunately I was a non-believer when I read the criticism about crossfire and took the plunge anyhow and am now 'reaping' the benefits.

I know that AMD drivers are bad, especially so with crossfire, and I still hold out hope they will get better, but I have strong doubts.

My main reason for this thread was to see if there was anything I could check/change/whatever just to minimize the hassle before I do upgrade my card in early 2012 or so.
Score
0
a b U Graphics card
April 14, 2011 11:51:42 PM

I too was in your position just waiting and waiting, I understand why you went with a setup like that on paper it sounds great, I just hope you do something about it instead of waiting for a fix that will likely never come... Personally I had to eventually say "enough is enough" especially when spending 400-500+ on gpus to have them work like crap was really disappointing, like I said above once I went to a single gtx 570 i have been happier than ever before... just my .02 cents good luck
Score
0
April 15, 2011 12:04:01 AM

I really appreciate you telling it like it is. The performance is great when it is good, but crap when it isn't working right.

If I could get 150-200 per card, and definitely sell them and buy a 570 myself, or maybe even a 580.
Score
0

Best solution

a b U Graphics card
April 15, 2011 12:47:31 AM

yeah sorry man I feel your pain, now only you can make the choice to also say "I have had enough" it was easy for me because at the time I had extra money so I went and got the gtx 570 first then sold the two 6870s on ebay and I did get around 150-200 per gpu which more than made up for the 304 AR I paid for my 570 and now I have 100 towards a new monitor upgrade all in all it was worth it
Share
a b U Graphics card
April 15, 2011 12:51:02 AM

@Jfby

^btw are you a member of the original golds gym in venice beach where arnold and lou farigno used to work out?
Score
0
April 15, 2011 1:02:20 AM

Lol, I was visiting family in LA and we walked all over Venice to find it... Justa fan:) 
Score
0
a b U Graphics card
April 15, 2011 3:32:16 AM

very cool^
Score
0
a c 170 U Graphics card
April 15, 2011 7:07:40 AM

jfby said:
Good question: Star Trek Online, Bad Company 2, Star Trek Online, Civilization IV, Dragon Age, and Rome Total War (all the games I currently have installed).

The issue is that when I just restart my computer, or haven't done either of the triggers, there are zero hiccups at all and things look and run great on the above games. I have actually measured the difference between disabled crossfire and with crossfire enabled and there is a significant difference when the cards are being taxed. When the issue occurs it's basically like one card is performing at max, but the other is running at less than max.

It's when I do one of the trigger events do my issues start for all games above. It doesn't matter when I do these things (when playing or when not playing) that's when the problem starts.

Startrek and rome total war don't benefit from CF but BC2 and Dragon IV should work just fine.
Do both of your cards perform fine simultaneously ?
Score
0
April 15, 2011 11:53:31 AM

On startup yes, but after opening an internet browser or changing any graphic settings I must restart the computer to work without issue.
Score
0
a c 170 U Graphics card
April 15, 2011 4:47:26 PM

So both of your cards(not Crossfire,each of them simultaneously) have this problem ? or it just happens with both cards installed(with CAT A.I enabled) ?
Score
0
April 15, 2011 4:58:13 PM

Ah... I haven't tried disabling Cat and seeing if they run, I missed that part of your question. It happens with both cards installed with Cat A.I. enabled.

So you are saying trigger the issue, disable A.I., the plug the monitor into the different cards?
Score
0
a c 170 U Graphics card
April 15, 2011 7:41:32 PM

No.
I meant take both of your cards and test them one by one and check if they both work fine in single mode.
Score
0
April 15, 2011 9:13:09 PM

Yes, I have done that, using the same 5 drivers each time. And both cards were good and performed nearly equally in Heaven Benchmark at the same clock speeds.

I tried both cards with each of the 5 drivers when they were in cross fire with different cards on top/in the primary slot
Score
0
a c 170 U Graphics card
April 16, 2011 7:51:54 AM

Raise your 2D clocks and see if it helps,here's how
1_Open CCC and choose Overdrive tab,unlock the settings(by clicking on the " Gold Key" icon)
2_Go top options,profile and choose profile manager.
3_In the composition tab,choose "The following settings" and in the "ATI Radeon HD 5800 series"make sure only ATI overdrive is checked.
Then enter a profile name,then save and close it(Do not activate).
4_Go to C:\Users\Your UserName\AppData\Local\ATI\ACE\Profiles (Its hidden so make sure you unlock hidden files and folders)
5_Open the profile with wordpad and do this edits:
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="40000" /> (default is 15700)

<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="90000" /> (default is 30000)

and for the second card:

<Feature name="CoreClockTarget_1">
<Property name="Want_0" value="40000" />

<Feature name="MemoryClockTarget_1">
<Property name="Want_0" value="90000" />

Save the changes and close.

6_Open CCC,in options tab go to profiles,profile manager and choose the profile that you saved before and then click on Activate and close.

Now your cards will idle @ 400/900 and you should not experience any more problems in 2D mode.
Score
0
April 16, 2011 11:41:18 AM

Is this to address the issue that AMD cards have with getting stuck at 2D clocks after watching an encoded video (the primary card gets stuck in UVD mode/2d clocks)? After I watch a YouTube video one card gets stuck at 2D at 400/900 and doesn't raise, and this does cause a slow response to graphics, but manually setting the primary card using AMD clock tool to match the secondary card, this stops causing an issue, but even with clocks at full 3D speeds YouTube and internet in general gave me many problems.

I've had that problem and will try this to see if it works, but if I get stuck in 2D on one card, will that not just keep one card at 400/900 and the other will go to 775/1000?

A side note: last night I reinstalled 11.2 (for at least the 4th time) and this time I was able to actually run a few of my games that previously had the strobing issue even with Firefox and Internet Explorer open! Previously this caused all the issues I've detailed above. I still had to run Vsync to have a clean playing experience, but with 10.12 I was running this would've been a non-starter. Tonight I'll try YouTube and see if I can still play without issues. Also Morphological AA is very nice, for anyones information.
Score
0
a c 170 U Graphics card
April 16, 2011 5:32:18 PM

No,it will make both cards run @ 400/900
I have a 5970 and I can't upgrade to anything higher than 10.10,so for me older drivers are better.
If 11.2 is giving you good results then stick with it for now;otherwise, try older drivers such as 10.10(or the method I mentioned above)
Score
0
April 28, 2011 4:37:08 PM

Best answer selected by jfby.
Score
0
April 28, 2011 4:39:00 PM

Thanks for the replies all; no real answer as I'm still having hiccups with Crossfire, but so are a lot of people with crossfire. My plan is to wait and see NVIDIA and AMDs offering in their next generation (or two) of video cards and pick up a single, powerful GPU, maybe the succesor to the 580 or 6970.

Again, thank you very much.
Score
0
a c 332 U Graphics card
April 28, 2011 6:02:16 PM

This topic has been closed by Mousemonkey
Score
0