Sign in with
Sign up | Sign in
Your question

Worried about my sapphire hd 5750...

Last response: in Graphics & Displays
Share
April 15, 2011 5:24:34 AM

hi every1 i just buyed sapphire radeon 5750 1gb but my system is giving me problems.When i run games like cod 4,Gta san andreas they show me fps about 60-90 but sometimes frames gets dropped to 1-10!!!.It shocked me my cpu also gets used 100%.It alos gets heated.Games like cod 6 gta 4 shows me low fps like 20-60.But i have seen its benchmark they should run like 90 fps as my monitor is 19".Sometimes blue screen of death also comes into action.I have updated every driver of my system including BIOS.And one more thing when i left any game CPU usage gets low to 9%.My system spec is
Windows 7 32 bit
Ram 2 gb
Asus m2n-cm dvi
amd altolon x2 5400+ CPU
Power supply 450w
HDD 1 tb+250gb
Sapphire HD 5750
View sonic va1912 monitor
plzz help me....

More about : worried sapphire 5750

a b U Graphics card
April 15, 2011 10:47:44 AM

^ agree, your CPU is too slow to handle the games, adding 2 GB RAM would help, but not much
m
0
l
a c 173 U Graphics card
April 15, 2011 10:56:18 AM

if it drops to 1fps all of a sudden, the most likely cause is loading from the hard drive. Ram and CPU together are your biggest killers here. More ram is a good cheap place to start for an upgrade. Also, enable vsync and tripple buffering, that will smooth out fps a little bit. Your motherboard is am2+ so you should be able to get a quad core athlonx4 in there for a good cheap speed boost, particularly in gta 4.
m
0
l
April 15, 2011 12:03:47 PM

iam2thecrowe said:
if it drops to 1fps all of a sudden, the most likely cause is loading from the hard drive. Ram and CPU together are your biggest killers here. More ram is a good cheap place to start for an upgrade. Also, enable vsync and tripple buffering, that will smooth out fps a little bit. Your motherboard is am2+ so you should be able to get a quad core athlonx4 in there for a good cheap speed boost, particularly in gta 4.


yea i think it is problem in my hard driver it is also making some noise which is hard to explain....
after reading this noise issue are you sure its my HD drive problem???
m
0
l
!