Sign in with
Sign up | Sign in
Your question

FiiO E9 Desktop Headphone Amplifier and Dock for E7 USB DAC

Last response: in Components
Share
September 23, 2011 7:54:32 PM

Hey all, I'm having a problem getting this new device working. I read online that in order to get the most out of my audiophile headphones I need to buy a headphone amplifier, so I got the FiiO E9 Desktop Headphone Amplifier and Dock for E7 USB DAC found on Amazon. I plugged it into the USB port, it's turned on, headphones are plugged into it, and no sound comes out. The computer doesn't acknowledge that it's plugged in. I had a Creative X-fi Fatal1ty card installed and working fine before I plugged this thing in, so I removed the card and uninstalled all its programs hoping that might fix the problem, but nope. Nothing. When I click Manage Audio Devices in the Control Panel, it shows that both speakers and headphones are disabled, but there are two devices called Digital Audio (S/PDIF) High Definition Audio Device (Default Device and Default Communications Device) that both show that they're making noises on the volume bar but still no sound. Any ideas on this one?

I hope I don't have to buy the E7 device to get this thing working...
September 23, 2011 8:09:29 PM

Another interesting thing...I installed the latest version of the motherboard audio drivers and tried plugging the headphones into the basic audio plug-in on the motherboard, it makes a scratchy noise as I'm plugging it in but there is still no sound from that either. So I'm guessing the problem lies somewhere in there.
m
0
l
September 23, 2011 8:17:23 PM

Alright, I've got the default motherboard audio plug-in to play sound, but still nothing from the FiiO E9. The computer isn't recognizing when I plug it in at all.
m
0
l
!