Sign in with
Sign up | Sign in
Your question

GTS 250 Direct3D Acceleration Not Available

Last response: in Graphics & Displays
Share
April 16, 2011 6:24:04 AM

Hello all,
I have a PNY GTS 250 1GB card, and for some reason right now I can't get any 3D graphics. Games won't run, Nvidia Control Panel "Adjust Image Settings with Preview" window where you normally see a spinning 3D Nvidia logo is blank as well.
When I run dxdiag Direct3D acceleration is listed as Not Available.
Card was working fine, never overclocked. I didn't notice when the problem started since I haven't run games for several months, and DirectDraw acceleration which is still "Enabled" was providing sufficient performance for browsing, using office and programming software as well as watching movies for me not to notice any problems. Even if a restore point exists, I won't know how far to roll it back to anyway. I would be reluctant to do that since I have probably installed other software since then.
I tried reinstalling the Nvidia drivers. First I uninstalled the driver from Add/Remove in the Control Panel, then downloaded 266.58 (latest for my card) from nvidia.com and installed using the clean install option (a checkbox you tick that purges any previous settings or profiles you had). This didn't solve the problem.
Next, when I Googled the problem (pardon me, this is a common problem with no obvious solution), some suggested reinstalling DirectX. I'm down for that, so I downloaded the latest DirectX web installer from Microsoft. Ran it, it says I have a newer or the same version already installed, and then quits.
Tried using one of those remover scripts that restore DirectX to the version you had on your Window CD. it refuses to run for me, don't like my Server 2003 CD for some reason. Yes, I run Server 2003.
How do I fix this problem?
Sorry I can't just reformat this machine, this is my primary workstation with many IDEs and various engineering tools I use for work.
Help is much appreciated.
a b Î Nvidia
April 16, 2011 5:54:42 PM

Corrupted installation you have. Most difficult to fix it will be.

Server 2003 is based off XP, which means it is limited to Direct X 9. Trying to use DX10 or 11 isn't going to work as those are only for Vista on Up. MS had to do it because the DX 9 API was too bloated and they needed a new driver model, but anyway.....

Try going back to DX 9.0b, and then upgrade to 9.0c. Not sure how you're going to force 9.0b on Server 2003 -_-

m
0
l
a b Î Nvidia
April 16, 2011 5:58:16 PM

You can find some DX removal tools through google, though of course they may just corrupt your install more than it already is ^_^. Anyway, since alot of drivers depend on Direct X make sure to uninstall them. Remove your video card, sound, and game controller drivers before you try removing Direct X. Don't reinstall those drivers until after you reinstall Direct X
m
0
l
Related resources
April 16, 2011 8:11:22 PM

I bought DirectX Happy Uninstall ($20), which rolled me back to 8.1 on my Windows installation CD. I then installed 9.0c from Microsoft's site, then reinstalled the Nvidia driver. Still the same problem.
m
0
l
April 17, 2011 2:56:06 AM

So... DirectX setup doesn't even try to copy files. After DirectX 9.0c setup, dxdiag still reports 8.1. And still Direct3D acceleration is "Not Available".

I think I tried just about everything. I guess this is going to be just another thread on this topic with no solution... Damn you Microsoft.
Ah the fu...
m
0
l
!