Sign in with
Sign up | Sign in
Your question

This device cannot find enough free resources... (Code 12)

Tags:
  • Chipsets
  • BIOS
  • Motherboards
Last response: in Motherboards
Share
June 17, 2012 7:58:26 PM

Hi,

I've moved this from the graphics card thread, as it's a wider issue to do with the BIOS and possibly OS.

I've just installed 2 x Asus GTX670 Direct CUII TOP in SLI but am getting the above message in Device Manager (the first card listed has the yellow symbol but the second is working properly). Nothing else has changed, except replacing the 2 x Asus GTX580 Direct CUII.

I've read in another forum that clearing or updating the BIOS can help, so I updated the BIOS to the latest version but that didn't work. I then removed the CMOS battery & cleared the jumper and when I eventually got back in (the boot device priority had re-ordered itself) it was fixed! That didn't last long though. As I'd read in the other forum, re-starting the computer undoes all that good work and so it turned out for me. I'm back to square one but at least I know that both cards work in SLI, albeit briefly. I was thinking of re-installing Windows but I don't believe that will have any effect. I want to manually assign I/O, IRQ & DMA but there doesn't seem to be any way of enabling this in the BIOS or Device Manager. Has anyone else experienced something like this?

Thanks


Coolermaster HAF X
Coolermaster silent pro gold 1000W
i7-2600k @ 3.4GHz
Arctic Freezer 13 Pro
Asus P8Z68-V Pro
SLI (2-way) Asus GTX670 Direct CUII TOP
8GB Corsair Vengeance 1600MHz
OCZ Vertex Max IOPS 120GB SSD
WD 450GB Velociraptor
30" Dell Ultrasharp 2560x1600

More about : device find free resources code

July 20, 2012 6:43:07 AM

I see a lot of people have been reading this thread, so hopefully this solution will help those as exasperated as I was.

The problem is solved and it's a BF3/SLI issue.

For Nvidia users & BF3 players the thing seems to be that BF3 must have 'SLI rendering mode' set to 'Single-GPU' in the Nvidia control panel (under 'Manage 3D settings'). The default setting is 'Use global setting', which seems to have caused all my problems.

It kind of defeats the purpose of having SLI but as soon as I chose that setting there are no more crashes and no more code 12 errors. Every time I re-start it's all good. I still have SLI enabled but for BF3 it's off.
!