Sign in with
Sign up | Sign in
Your question

ASRock Z68 extreme3 gen3 not passing POST.

Tags:
  • ASrock
  • Motherboards
  • Product
Last response: in Motherboards
Share
June 17, 2012 8:29:34 PM

Hey guys, need some help.


I got my ASRock Z68 extreme3 gen3 motherboard in the mail, as well as everything else I'm building with, and I'm having some issues.

I get everything hooked up, ready to go, and I go to power on my system to make sure everything is working. It doesn't pass its POST, and beeps 4 times. Dr. Debug is giving me error 55.

After some reading, I've come to the conclusion that the motherboard isn't accepting the ram, and that I probably need to update my BIOS. Are there any other things that could cause this problem? Everything's compatible, installed the way it should be, etc.

Thanks

More about : asrock z68 extreme3 gen3 passing post

a b V Motherboard
June 17, 2012 8:59:35 PM

Ya according to the manual "0x55" is memory related, what memory sticks are you using?

Also have you tried booting with a single stick installed?(sometimes it's easier for a system to address a single stick on startup)



m
0
l
June 17, 2012 9:16:05 PM

CDdude55 said:
Ya according to the manual "0x55" is memory related, what memory sticks are you using?

Also have you tried booting with a single stick installed?(sometimes it's easier for a system to address a single stick on startup)



This RAM, and yes, I've tried using one stick. I've tried with both slots, and still no bueno.
m
0
l
June 26, 2012 7:49:08 PM

I ran into this problem myself. If you think the RAM is still working then it's a bios issue. And yes, updating the bios fixed it.

This line shipped with a bios before the Ivy Bridge existed, and doesn't support it. Flashing a new bios isn't exactly possible unless you have a sandy bridge lying around, but if you call ASROCK they'll send you a chip with the new bios. If you bought the Mobo recently it will be free, otherwise it's $15. It's really easy to swap out the chip.

Good luck.

m
0
l
!