Sign in with
Sign up | Sign in
Your question

Please Help With Problem Playing Games

Last response: in Graphics & Displays
Share
April 17, 2011 4:49:37 PM

I recently did a new build, which includes the following:

Intel 2600K overclocked to 4.3 GHZ on a Noctua C14 Heatsink
12 GB of 1600 Corsair Dominator RAM
Asus Revolution P67 Motherboard
2x EVGA GTX 570's overclocked to about 800/1600/2000

The build went pretty smoothly, including the overclocks. Temps are fine. Everything runs fine except for when I play games. For whatever reason, the games run fine but the graphics are completely messed up even in the intro movies and menus. What's supposed to be there is there, but the colors are all vibrantly adorned with artificial "snow" that flickers a variety of greens, purples, reds, etc. The whole screen usually flickers and the mouse pointer has a flickering box around it. I have absolutely no idea what is causing this problem. Note that this problem only occurs while playing fullscreen games; I can run games in a window without a problem. Although I don't think its relevant, I'm on a Dell 3007 monitor at 2650 x 1600.

I have tried basically every solution I can think of. The first step was obviously uninstalling my drivers and then reinstalling them. I have done this many times, getting beta drivers from 3D Guru as well as using official WHQL ones from the Nvidia site. I use Drive Sweeper to eliminate leftovers. Each time the installation goes without a hitch, and afterwards I re-setup SLI mode and then I can play games fine. The next couple times I boot up my computer, I can also play fine. However, after several boots, the problem comes back. When this happens, I get a message from Fraps on startup saying DirectX9 failed to initialize. This is also very strange, as I download the DirectX installer straight from Microsoft and it tells me that I have the latest version of DirectX fine. However, the problem persists whenever I run a game.

I think what's happening is each time I reboot my computer, something with the drivers has a chance of getting corrupted. I just don't know what it could be though, and would appreciate insight from the more technically savvy people on this forum. Thanks.

Edit: Its not the OC, which is one of the first things I checked. I forgot to mention this, but I immediately reverted my CPU and GPU overclocks to stock. Same problem happens. Also, I don't think my OC is all that aggressive for Sandy Bridge with a top level cooler.

This is not artifacts as a result of GPU overclocking, as I get nothing when I run GPU tests and benchmarks. The "snow" in the game is not due to GPU failure. I think the problem is the drivers, which cause the colors to be completely messed up. GPU failure also wouldn't explain why it runs perfectly in windowed mode at the same resolution.

More about : problem playing games

April 17, 2011 6:19:52 PM

Here is a picture of the problem:


Here is a picture of the game running absolutely normally at the exact same resolution. The only difference is its in a window:


The other thing is if I take a screenshot of the game when the problem is occurring, the screenshot comes back perfectly normal.
a b Î Nvidia
April 17, 2011 6:48:15 PM

jcorqian said:
The other thing is if I take a screenshot of the game when the problem is occurring, the screenshot comes back perfectly normal.

this is interesting. Does anyone here actually know for certain where screenshotting takes the data?
Related resources
a b Î Nvidia
April 17, 2011 8:19:25 PM

So this also happens with the GPU's at stock clocks? I would turn off all overclocks until you figure out what the issue is.
April 17, 2011 9:05:01 PM

Yep, already tested on stock with everything. First thing to check obviously. Same problem.
a b Î Nvidia
April 18, 2011 2:46:57 AM

What power supply are you using? Dual 570's and an OCed CPU will take some juice.
April 19, 2011 3:28:06 AM

Using a Corsair 1000W. I figured out the problem; it's the SLI not working properly.

However, right now my only solution is to disable and then enable SLI every time I boot. See below for the explanation. Shed some light on that?

Thanks

a b Î Nvidia
April 19, 2011 12:41:43 PM

Any Mobo BIOS updates that might address this issue. I remember my buddy had some SLI issues WAY back and it was fixed in a BIOS update for his mobo. Just a thought.
April 20, 2011 2:06:23 AM

I'm trying to update BIOs, downloading the ones on the Asus site. It's weird, I put Win 7 64 bit in my configuration on the site, but the installer downloaded always opens with a message that says "Verify correct version of Windows" as if its only for the 32-bit version. Any other sources to get BIOS?
!