Sign in with
Sign up | Sign in
Your question
Solved

Replaced power supply, now won't recognize CD/DVD drive

Last response: in Components
Share
September 26, 2011 9:48:18 PM

Hey, wanted to see if I could get some advice. My wife has a Dell Dimension E510. It works good enough for her, but I wanted to speed it up a bit. I added 2MB of RAM. In the process of that, the original power supply died. I got a replacement power supply, which powered up the machine fine. My wife enjoyed the higher speed processing for a few days and then pointed out that the CD/DVD drive isn't recognized.

It's got power. The tray ejects and retracts. I can hear test discs spinning. But nothing beyond that.

I'm a novice at this type of thing. I've tried going into into the Device Manager to look for it, but it doesn't show up. The Add Hardware function in Control Panel doesn't find it either. I've tried plugging another known working drive in the same slot to no avail.

Any ideas? Thanks in advance!
September 26, 2011 11:28:17 PM

What connection is it sata or IDE? If it is IDE make sure you plugged in the proper way and not force it in backwards. Try another port. Make sure the cable isn't snipped. How did the PSU die? If it's sata just make sure its tight. I've had it fall off alot.
m
0
l
a b ) Power supply
September 27, 2011 12:36:27 AM

On IDE sockets the plug can also be off sideways by 1 pin in some sockets. The cable is directional too meaning their is a mobo end and a drive end.
m
0
l
Related resources
September 27, 2011 5:37:01 PM

Thanks for the responses.

To answer the questions...

- It is an IDE connection.

- I'm fairly confident it's not the connecting, I've plugged both ends in and out a couple dozen times by now. I've tried both power supply connections (labeled P8 and P9) and both drive connections on the IDE cable to the same result.

- The cable is correctly hooked up, mother board side is in the right place. The ends are keyed so they will only snap on if lined up correctly and right side up.

- The power supply went out during the original RAM install something like this... Shutdown computer. Unplug power. Add RAM. Plug in power. Light on mother board turns on, but computer would not power on.

While troubleshooting the power supply, I removed the Li-Ion battery. Could that have cause some kind of setting to change?

So is the next step to try a new cable? Is it possible when the power supply went out it damaged either the cable or drive or both?

Also, there is another thread on this forum that recommended editing a registry folder to remove lower and upper limit files...I tried that and that didn't work either.
m
0
l

Best solution

a b ) Power supply
September 27, 2011 6:38:02 PM

I would try a different IDE cable. I highly doubt that the problem lies in the PSU, as the drive powers up.

Removing the CMOS battery does change your settings in the BIOS. Doing this resets your BIOS to default; usually to the state the BIOS was in when the mobo left the manufacturing plant. However, I don't know of and haven't heard of any BIOS setting that forces SATA connection only.
Share
September 27, 2011 10:45:52 PM

Thanks for the responses.

I've got the drive working again. It wasn't faulty hardware at all, it was the darned PATA settings in Setup. They must have reset to Off after the battery removal.

Aarrgghh!
m
0
l
September 27, 2011 10:46:08 PM

Best answer selected by eddie_72.
m
0
l
!