Sign in with
Sign up | Sign in
Your question

Wireless Keyboard Problem

Last response: in Windows 7
Share
December 10, 2011 1:04:36 PM

I have an hp mini wireless keyboard plugged into my HTPC (in one of the front usb ports) in the living room. The HTPC is running Windows 7 x64.
I usually put the computer to sleep, and to "wake it up" I tap one of the keys.

The machine boots up and in a couple of seconds I see the windows login screen. I then hear the computer make the sound of a USB device being unplugged, at this point my keyboard no longer works. I have to unplug the dongle and plug it back in for it to work, which is obviously annoying seeing that I'm sitting on the couch lol.

I don't understand what's happening, since I'm able to wake the machine up with the wireless keyboard I presume the front ports are still receiving power, and why would the device disconnect just as windows boots up?
I have no problems when doing a cold start

Any ideas to fix this?
December 11, 2011 3:12:29 AM

Update your USB drivers for the computer.

Other than that I really don't know. It shouldn't do that IME, I had an issue with it having to re install the driver every time I plugged the USB bit in a different port.
m
0
l
December 11, 2011 3:29:06 AM

Are your motherboard drivers up to date?
m
0
l
Related resources
December 11, 2011 12:36:12 PM

More interesting... or enraging lol

I updated the chipset drivers and now when I resume from sleep the keyboard works! BUT I can't wake it using the keyboard anymore, I have to push the power button....

Now I guess the question is how do I make sure the wireless keyboard is able to send a signal when the computer is asleep
m
0
l
a b $ Windows 7
December 11, 2011 6:10:10 PM

B0L0 said:
More interesting... or enraging lol

I updated the chipset drivers and now when I resume from sleep the keyboard works! BUT I can't wake it using the keyboard anymore, I have to push the power button....

Now I guess the question is how do I make sure the wireless keyboard is able to send a signal when the computer is asleep

Try to go to BIOS and enable to wake on...
m
0
l
December 11, 2011 7:03:16 PM

click the start button, type - power options -, select change plan settings (make sure you choose according to the one you have enabled), select advanced power settings, navigate to Sleep -> Allow wake timers -> 'enable'
next navigate to USB settings -> USB selective suspend setting -> 'enable'



m
0
l
December 14, 2011 11:26:09 AM

BIOS wake on was already enabled,

enabled wake timers, USB selective suspend was already enabled.

Still no luck, any other ideas?

m
0
l
December 18, 2011 3:47:33 AM

in device manager, double click on your keyboard. Should be visible in the main list. when the properties window opens, click on the power management tab. there should be an option to click -> allow this device to wake computer

Obviously here you would want that to be checked.

report back and we'll go from there.
m
0
l
January 16, 2012 6:49:00 PM

Sorry I've left this thread lapse, but I unfortunately haven't had the time to work on the problem.

Here's where we're at. Currently the keyboard now works when I resume from sleep (doesn't disconnect) but I have to press the power button to wake the computer.

I go into device manager, into the keyboard, and noted that the "allow this device to wake the computer" was unchecked. So I check the box, hit ok. I put the computer to sleep, hit the space bar and the computer turns on! and then I hear the usb tone of a device disconnecting and the keyboard no longer works, so I'm back to where I started.

If I leave the box unchecked, the keyboard does not disconnect when it resumes from sleep
m
0
l
!