Sign in with
Sign up | Sign in
Your question

Mother board (biostar a870u3), on board USB not workiing please help!

Last response: in Components
Share
September 28, 2011 5:56:35 AM

Hey everyone,

I just bought a new mother board (biostar a870u3) and a new processor (amd phenom II x6 T1090)

after putting everything together i find that none of the USB ports are working. (USB 3.0 and 2.0) I have tried uninstalling the driver from device managers, restarting my computer and letting it reinstall on its own. I have tried unplugging the power cord and letting it sit for a whole night. I have tried updating all the drivers to the latest drivers. I am truely and completely stuck you guys are my last hope :( 
September 28, 2011 2:00:34 PM

is this "Scan Your PC" free or does it only allow you to scan it and then you have to pay to get the items fixed?
m
0
l
Related resources
September 28, 2011 2:02:20 PM

Well, I never tried that but should be free since that is Biostar Support. Give it a try and reply back for further troubleshooting.
m
0
l
a c 80 V Motherboard
September 28, 2011 10:09:09 PM

Have you tried the usb ports on the backside? I would test with a bootable USB flash drive and then if they dont work then its definitely the motherboard.
m
0
l
September 28, 2011 10:59:28 PM

none of the usb drives work on the back
m
0
l
September 28, 2011 11:11:19 PM

Have you checked in the BIOS to see if the ports are enabled?
m
0
l
September 29, 2011 2:04:19 AM

Yes I have, I am currently nuking my HD and reinstalling my OS
hopefully this will work, if not then there is most definitely something wrong with the MB
m
0
l
September 29, 2011 3:46:37 AM

is it possible that my power supply doesnt provide enough power to the mother board?

I have a corsire 500w PSU
currently i am running:
AMD x6 t1090
1x HD radeon 6850 graphics card
1 500gb HD (no biggy)

would a 500w PSU be enough to support this?
m
0
l
!