Sign-in / Sign-up
Your question

Question to Asrock Z77 extreme 4 motherboard?

Tags:
  • ASrock
  • HD
  • Motherboards
Last response: in Motherboards
June 22, 2012 2:56:30 PM

Hello,

just installed my new gaming rig:
i5 3570k
hd 7870 sapphire OC
asrock z77 extreme 4
8gb 1600 corsair low profile ram
550 watt tx corsair
ssd 128gb samsung 830series
wd 500gb 7200rpm

And my question is, I had two cables to connect to audio. HD audio and AC97 or something. I connected HD Audio, and sound is working perfect. But the problem is i have installed from the driver CD of the motherboard, realtek sound driver, and some THX true sound. Do i need both?
And the main question here is, i dont have any sound effects to choose in realtek and its not that good sound for me, please help!!! thank you!

More about : question asrock z77 extreme motherboard

a b V Motherboard
June 22, 2012 3:03:29 PM

santino5 said:
And the main question here is, i dont have any sound effects to choose in realtek and its not that good sound for me, please help!!! thank you!


That's not even a question. Not sure what your asking, please elaborate.
June 22, 2012 3:06:39 PM

The question is, where are the sound effects, in realtek (Powerful, Rock etc.) I had them in my last PC build, with another motherboard and no problem. Now i wanna put powerful but there are no sound effects to choose and I need them. Sorry for my bad english Im from Croatia.
Related resources
June 25, 2012 9:29:19 AM

Solved
March 31, 2013 9:24:49 AM

santino5 said:
The question is, where are the sound effects, in realtek (Powerful, Rock etc.) I had them in my last PC build, with another motherboard and no problem. Now i wanna put powerful but there are no sound effects to choose and I need them. Sorry for my bad english Im from Croatia.


March 31, 2013 9:26:16 AM

Santino how did you solve it? I've the same problem with the same motherboard
April 1, 2013 8:18:59 AM

Hello, the problem was that i had automatically installed 2 audio programs realtek and one more that has been installed automatically via mobo drivers or windows installation I cant remember. But what you need to do is find that second program and delete it. I can see the equalizer tab in my realtek driver. Hope it helped!!